|Re: [equinox-dev] new services|
Is there any indication when IP verification procedure will complete?
org.eclipse.equinox.provisioning -> org.eclipse.equinox.ip
such naming is not a very good idea - mainly because IP = Intelectual Property
maybe we may use "initialprovisioning", "initialprv" or "iprv" (org.eclipse.equinox.iprv)?
We may combine with equinox.common (preferable). But maybe initially it will be separately service?
Now it is used in all other implementation because it provides basic services for logging, collections, xml parsing, timer, thread pooling, object pooling etc.
Great point (about provisioning). Yes, we should do a naming review. It probably makes sense to do that before committing just to reliminate churn. Let me take a initial pass here...
- Name is too general as noted in the originating bug report. Choices here are org.eclipse.equinox.scr (Service Component Registry) or org.eclipse.equinox.ds (replace the current "ds" bundle when the new one has been reviewed and graduated.
- personally I lean towards "ds". If all goes well would we keep to implementations around? If not, why change the name?
- no particular issues here
- Name collision with the Equinox provisioning work
- perhaps consider org.eclipse.equinox.ip? Other options/thoughts?
- conceptual conflict with equinox.common. Consumers will be confused as to what is in common vs. util.
- consider combining?
- util appears to have lots of useful stuff in it. Reviewing how and when it is used may help us come to some naming/grouping conclusions.
- collides with the current wireadmin bundle.
- as with the DS implementation, perhaps the new one should just replace the old one when it graduates? In that case we can leave the name as is.
No problem from our side after the IP verification process complete.
Maybe also is good to discuss implementation packages and names because it is good do refractoring prior the check-in.
Especially I think that we agree on the name org.eclipse.equinox.scr for Declarative Services.
Regarding initial provisioning - currently I use similar to OSGi package name (org.eclipse.equinox.provisioning) but because of the conflict with general provisioning work already being done in the incubator we may decide for the other name.
What do you think?
equinox-dev mailing list