[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[eclipselink-users] EclipseLink Buddy Policy in OSGi

Hi,

We've been trying to get EclipseLink MOXy to work in an OSGi environment in
Equinox, and we found that in order to allow EclipseLink to instantiate our
model objects, we need to set up a Buddy Policy.  

We had to modify the EclipseLink manifest to say:
Eclipse-BuddyPolicy: registered

Then we edited the bundle containing our model objects to say:
Eclipse-RegisterBuddy: org.eclipse.persistence.core

This works, but I don't like tweaking files that belong to a third-party
library.  It seems like everyone that uses Equinox would need the
BuddyPolicy.  So will you be willing to add the "Eclipse-BuddyPolicy" entry
to the EclipseLink manifest?  Or are we doing something wrong?  If there's a
better way to solve this problem, please let me know.

Thanks!
Polly
-- 
View this message in context: http://www.nabble.com/EclipseLink-Buddy-Policy-in-OSGi-tp19579730p19579730.html
Sent from the EclipseLink - Users mailing list archive at Nabble.com.