[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[eclipse.org-planning-council] Europa Fall Maintenance Release - build FAILS on Modeling and Platform

We are six weeks and two days from the Europa Simultaneous Maintenance Release and I'd like to get the Europa-matic building green again in preparation for that release. The builds are still failing: http://dash.eclipse.org/~bfreeman/europa/

Modeling Projects
The modeling projects (EMF, etc) are failing the build because they have features with download.php urls, e.g.:
        <feature id="org.eclipse.emf.sdk" version="2.3.1.v200708072030" url=""moz-txt-link-freetext" href="http://www.eclipse.org/downloads/download.php?r=1&file=/modeling/EMF/updates/features/org.eclipse.emf.sdk_2.3.1.v200708072030.jar">http://www.eclipse.org/downloads/download.php?r=1&amp;file=/modeling/EMF/updates/features/org.eclipse.emf.sdk_2.3.1.v200708072030.jar" patch="false">
These feature urls are not supported by the org.eclipse.update.core.standaloneUpdate application that is used to build the Europa update site.

Ed or Nick had asked me to change the code to accommodate this url mechanism, but my reply is that I don't think it wise to change the build mechanism that we successfully used for the main Europa release. The Modeling projects need to provide site.xmls that work with existing Europa build mechanism as they did before.

Eclipse Platform Project
The Platform build is failing on:
    !MESSAGE An exception occured while downloading feature from "file:/home/data/users/bfreeman/downloads/eclipse/updates/3.3/features/org.eclipse.rcp_3.3.0.v20070607-8y8eE8NEbsN3X_fjWS8HPNG.jar".
    !STACK 0
    java.io.FileNotFoundException: /home/data/users/bfreeman/downloads/eclipse/updates/3.3/plugins/org.eclipse.swt.gtk.linux.s390_0.0.0.jar (No such file or directory)
Kim has stated that she doesn't know why this exception is occurring and, sigh, neither do I. The only hypothesis I have is that something changed in the Platform's update site because I know nothing has changed in the Europa-matic. My hypothesis is that the Platform update site contained the 390 plug-in before and then, in a post-Europa clean-up, it was deleted.  Again, because the Europa-matic is just using a plain vanilla org.eclipse.update.core.standaloneUpdate application, we must rely on the Platform team to fix their update site.

The command line being used is:
Command-line arguments: -clean -application org.eclipse.update.core.standaloneUpdate -data /home/data/users/bfreeman/europa/org.eclipse.europa.tools/build-home/buildworkspace -debug -consolelog -command mirror -featureId org.eclipse.platform -version 3.3.0.v20070612-_19UEkLEzwsdF9jSqQ-G -from file:///home/data/users/bfreeman/downloads/eclipse/updates/3.3/site.xml -to /home/data/users/bfreeman/europa/staging -ignoreMissingPlugins true
Note that it includes "-ignoreMissingPlugins true" so one assume that it shouldn't die, but of course it is dying.
Perhaps the Platform releng team would like to run this same command line and see if fails in the same way for them...?

- Bjorn