[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [eclipse-scripting-dev] [ease-dev] EASE vs Eclipse Workbench (e4 or Eclipse 3)

Good. So I think we can conclude that pre-e4 compatibility is indeed a wish, but that the main focus is definitely about the new e4 model.

Concretely, I suggest that the main UI plugin might be built around the e4 model, and therefore exploit most e4 goodies, namely behaviour annotations dependency injections, css, and so on. A backward compatibility plugin might be created afterward, probably based on org.eclipse.e4.tools.compat or whatever other approach that will be appropriate.

Insights, issues, comments or objections, anyone?



James Watkins-Harvey
Software architect and Research and Developement director

Le 2014-08-22 à 05:27, GAUFILLET, PIERRE <pierre.GAUFILLET@xxxxxxxxxx> a écrit :

Hi!
 
Not really interested by Eclipse 3 compatibility on my side: we are still using the legacy TOPCASED scripting code on Eclipse 3.x platforms. EASE is really intended for Eclipse 4.x in my company. But of course, keeping a layer of compatibility somewhere, even with limited features, is always a good idea, especially in open projects. Maybe we just need a wiki page describing this aspect?
 
Pierre
 
De : eclipse-scripting-dev-bounces@xxxxxxxxxxx [mailto:eclipse-scripting-dev-bounces@xxxxxxxxxxx] De la part de Christian Pontesegger
Envoyé : 22 August 2014 6:48 AM
À : ease developer discussions; Discussions about scripting Eclipse.
Objet : Re: [eclipse-scripting-dev] [ease-dev] EASE vs Eclipse Workbench (e4 or Eclipse 3)
 
 
On 22.08.2014 04:22, James Watkins-Harvey wrote:
is EASE targeted at running only in e4? Or is maintaining compatibility with Eclipse 3 Workbench a goal? I see that there has been some attempts at exploiting e4 to dynamically build the script menu, but it seems to me that the equivalent is also possible without compromising Eclipse 3 support….

Not sure how many people already subscribed to the new group, so I will crosspost this to the old group too, as I think this is an important decision:

My personal interests do not include 3.x compatibility anymore. However when we started out last year there were quite some people around asking for 3.x compatibility. That's why the UI menu integrations are somehow splitted. We have the e4-ish way of adding scripts to any context menu (the code needs some adaptions and is currently in a parked state) and we have the 3.x compatible way of adding menu contributions to toolbars and view menus.

So as long as we can still support 3.x I would try to stick with it. But therefore some additional adaptions would be needed. eg a target platform using only 3.x components. I am pretty sure that we have some unnecessary version ranges in the plugin dependencies.

Anyone on the list that definitely wants 3.x support?

regards
Christian
The information in this e-mail is confidential. The contents may not be disclosed or used by anyone other than the addressee. Access to this e-mail by anyone else is unauthorised.
If you are not the intended recipient, please notify Airbus immediately and delete this e-mail.
Airbus cannot accept any responsibility for the accuracy or completeness of this e-mail as it has been sent over public networks. If you have any concerns over the content of this message or its Accuracy or Integrity, please contact Airbus immediately.
All outgoing e-mails from Airbus are checked using regularly updated virus scanning software but you should take whatever measures you deem to be appropriate to ensure that this message and any attachments are virus free.
_______________________________________________
ease-dev mailing list
ease-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/ease-dev