[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [eclipse-pmc] Pack2000 removal in Java 14



On Tue, Nov 5, 2019 at 10:18 PM Mickael Istria <mistria@xxxxxxxxxx> wrote:
Can we already define "negative" requirement on the bundle BREE to not work with future Java, and make it optional in the features?

Sure. The require-capability is full featured. The following should give the range [1.8, 14):
osgi.ee; filter="(&(osgi.ee=JavaSE)(version>=1.8)(!(version>=14)))"
Â
_______________________________________________
eclipse-pmc mailing list
eclipse-pmc@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/eclipse-pmc


--
Alexander Kurtakov
Red Hat Eclipse Team