|[eclipse-pmc] Request to backport improvement in default naming scheme of Smart Import|
In https://bugs.eclipse.org/bugs/show_bug.cgi?id=493716, there an enhancement about how 2 folders with same names get named as projects inside the IDE when using "File > Open projects for filesystem": rather than having one called myModule and the other called myModule_(1), they'd get called myModule and the other called myComponent_myModule (with myComponent being the name of the parent folder). This patch was pushed into master about a month ago, and this choice of naming was based on discussion with BuildShip maintainers on the platform-ui-dev mailing-list.
As it's improving greatly the user experience for big projects (I usually take wildfly as example which has a lot of folders called "impl" and being maven modules) and the change doesn't add much risk (on the contrary, the change includes a very good test cases to prevent from regressions), I believe it's a good candidate for backport into Neon maintenance branch.Can PMC please review this request for backport?
Back to the top