Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [eclipse-pmc] Raising minimum EE for org.eclipse.core.runtime to Java 5

+1 without Equinox, I guess that not much can run on 1.4 anyways


On 10/04/2012 07:53 PM, John Arthorne wrote:
I am planning to raise the minimum EE for org.eclipse.core.runtime to Java SE 5. There is a concrete need to use newer class library API in bug 391047, but the main reasons are:

 - There are no JDK 1.4 or older VM's available that are not beyond end of service life
 - We have been unable to run or test Eclipse on JDK 1.4 for at least a couple of years already. We have no confidence that we can still run reasonable on such VMs.
 - The Equinox framework implementation has already moved to Java SE 5.
 - org.eclipse.core.runtime is comprised of a small set of mostly deprecated platform APIs that are not of interest in embedded scenarios anyway. Any API useful for small footprint OSGi applications was moved to other bundles such as org.eclipse.equinox.common.

For details see:


eclipse-pmc mailing list

Martin Oberhuber , SMTS / Product Architect – Development Tools, Wind River
direct +43.662.457915.85  fax +43.662.457915.6

Back to the top