int StatusAdapter#getHandlingHint() to be renamed to int
StatusAdapter#getStyle() void StatusAdapter#setHandlingHint(int
handlingHint) to be renamed to StatusAdapter#setStyle(int style)
Addition of the following API
int StatusManager#BLOCK - block the
return from handleStatus until the user has responded
int StatusManager#NO_BLOCK - do not
block the return from handleStatus until the user has responded
The name of the handlingHint in the status handling facility should be
renamed to be consistent with Eclipse conventions such as SWT. This flag
is also stronger than a hint and so the name hint is misleading.
No known risks as we are currently the only consumers .