Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[ecf-dev] feature.xml IDs vs. folder names


today I've continued to work on the CVS to Git transition. So far the
Hucky build (Hudson + Buckminster) used to checkout code twice. Once
done by Hudson and a second time by Buckminster. Since Buckminster does
not come with a Git repo reader, the build has to switch to the local
reader anyway. This means we can't continue to use map files to map from
feature.xml IDs to folder names anymore. E.g.

org.eclipse.ecf.sdk (feature) -> org.eclipse.ecf.sdk-feature
org.eclipse.ecf.platform_feature -> org.eclipse.ecf.platform-feature

Due to the fact that a dash isn't a valid character in feature.xml IDs,
we should rename all folders to underscore and change the (legacy) map
files. That makes it more consistent in a couple of other places too.


Back to the top