I realize these changes are already in master, but I think we are getting too specific with our model. Having an MWizardDialog only opens the door to having an MWizardPart and IMHO that defeats the entire purpose of having a generic model in the first place.
If we are going to model the Wizard (which I can make arguments either way) it should inherit from MPart if anything. I guess I am more for modeling Wizards AND WizardPages because I feel that makes a better argument for reuse. But all of this is for naught if we are going to delineate our model so rigidly.
I would even be for creating a model element that blurs the line between WizardPage and PreferencePage (call it an MInteractionPage). Because, from an abstract sense, WizardPage and PreferencePage accomplish the same thing; taking some form of user interaction. Combine that with the existing DI framework and there is no need to have separate entities.
So I would vote:
-1 on MWizardDialog
0 on MDialog
I think we can enhance our existing tags on MWindow to accomplish everything the Dialog does (like even having a "dialog" tag).
JD