|[dsdp-tm-dev] SubSystemConfiguration vs. SubSystemFactory ??
Hello Dave's and Kushal, While I was working on RSE today, I was wondering why you had chosen to rename SubSystemFactory --> SubSystemConfiguration. After all, it *is* the factory which creates new subsystems, isn't it? Sure enough, it also holds configuration data about the subsystems, but in terms of lifecycle, the interesting point is that the factory exists before the subsystem -- and the configuration data will apply to *all* new subsystems created. In other words, it is never possible to have different configurations for subsystems of the same type, because all of them are created by the same factory, right? Moreover, there are still lots of Javadoc comments and local variable names etc. that refer to factories. Looking at existing Platform extension points, I'm finding: org.eclipse.ui.console.consoleFactories org.eclipse.ui.elementFactories org.eclipse.ui.presentationFactories The semantics especially of the last one is a bit similar to our subsystem configurations I think. I found only one named org.eclipse.ui.acceleratorConfigurations which is deprecated. Well it's my personal feeling, but I'm more comfortable with a SubSystemFactory than with a SubSystemConfiguration. What would you think about renaming it back ??? I don't think it would be much work to do, a simple plaintext-search-and-Replace of SubSystemConfiguration (case sensitive!) should do since the word is long enough to avoid unintended matches. Replacing in html, xml etc. as well would also fix ISV docs along the way. I could make the change easily if you agree. Comments? Thanks, -- Martin Oberhuber Target Management Project Lead, DSDP PMC Member http://www.eclipse.org/dsdp/tm
Back to the top