Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Orbit Bundles To Be Removed From 2018-09 M3

On Wed, 2018-08-01 at 16:01 -0400, Nick Boldt wrote:
> As to Lucene removals:
> * org.eclipse.recommenders.models 2.5.3 requires lucene.core 3.5
> * o.e.epp.logging.aeri.feature requires lucene.analysis 6.1
> * org.eclipse.datatools.sqltools.result (DTP) and org.eclipse.m2e.wtp.jpa.feature (WTP) both require org.apache.lucene.queryparser 6.1.0.v20161115-1612, which doesn't exist in 7.1 (Lucene loves to add and drop bundles will-nilly, don't they?)
> So... either those bundles / features need updating to use lucene 7.1+ or else they'll have to build against old Orbit... and Simrel will end up having multiple versions of these IUs peppered in the mix.

You've highlighted another issue, which is that sometimes, when a newer
version of a set of bundles gets pushed in, the initial contributor
will handle the ones that are of interest to their project. lucene-
queryparser does exist for > 6.1.0, but likely some class(es) within it
were moved elsewhere and there was no need to include it.

> What version of HttpComponents are you thinking would be included/dropped? Currently I'm using httpcore 4.4.6 and httpclient 4.5.2, but I think I saw a thread about Platform moving to newer versions? cc: @Aleksandar Kurtakov  

Yes, I believe they'd move to httpcore 4.4.9 / httpclient 4.5.5 . I'm
fine with not removing certain sets of bundles (eg. lucene,
httpcomponents) but I did want to clean up some known cases where it's
used/updated by a single project that always migrates to the newer

Roland Grunberg

Back to the top