[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Java 7 is dead:

Hi

I see no real problem. I was just highlighting that Java 8 time had finally come, hopefully saving others time in debugging new failures.

    Regards

        Ed Willink

On 07/10/2015 16:34, Daniel Megert wrote:
Hi Ed

As mentioned in my announcement, the appendix with the BREEs will change until we release in June. The next update of our Neon plan, including the appendix, is planned for M4 and then M7.

You can still use Java 7 or lower in your projects if you want, though be aware that Oracle does not provide public updates anymore for Java 7.

If you see a problem by our move to Java 8, e.g. an API no longer working because it got wrongly generified, or any other issue, please file a bug report and cc me. Also, if anyone has an issue with the build, create a bug report and add David Williams to it,. He can usually help very quickly to resolve the issue.

Dani



From:        Ed Willink <ed@xxxxxxxxxxxxx>
To:        cross-project-issues-dev@xxxxxxxxxxx
Date:        02.10.2015 18:45
Subject:        Re: [cross-project-issues-dev] Java 7 is dead:
Sent by:        cross-project-issues-dev-bounces@xxxxxxxxxxx




Hi Lars

As of a couple of minutes ago that plan [1] lists only the anomalous
jdt.annotation as a Java 8 minimum version.

Since that was the case six weeks ago too, I assumed that Java 8 BREE
would not actually occur for most plugins.

     Regards

        Ed Willink

[1]
https://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/eclipse/development/plans/eclipse_project_plan_4_6.xml

On 02/10/2015 12:34, Lars Vogel wrote:
> Dani did send the information around a while ago Neon will require
> Java 8. See
https://dev.eclipse.org/mhonarc/lists/cross-project-issues-dev/msg12177.html
>
> Best regards, Lars
>
> On Fri, Oct 2, 2015 at 6:01 PM, Ed Willink <ed@xxxxxxxxxxxxx> wrote:
>> Hi
>>
>> I didn't see any announcement, but there was little dissent in earlier
>> discussions.
>>
>> In M2, org.eclipse.core.jobs has moved to Java 8 BREE so to all intents and
>> purposes Java 7 support is dead.
>>
>>       Regards
>>
>>          Ed Willink
>>
>>
>> On 07/03/2015 22:54, Lars Vogel wrote:
>>
>> On Wed, Mar 4, 2015 at 5:42 PM, Igor Fedorenko <igor@xxxxxxxxxxxxxx> wrote:
>>> This is getting off-topic, but I think we should plan to move to java 8
>>> for the next release after mars.
>>
>> +1
>>
>>
>>
>> _______________________________________________
>> cross-project-issues-dev mailing list
>> cross-project-issues-dev@xxxxxxxxxxx
>> To change your delivery options, retrieve your password, or unsubscribe from
>> this list, visit
>>
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev
>
>

_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev




_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev


No virus found in this message.
Checked by AVG - www.avg.com
Version: 2015.0.6140 / Virus Database: 4435/10774 - Release Date: 10/07/15