[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Java 7 is dead:

Hi Ed,

not sure when Dani updates the list, but the move to Java was announced for Neon.

Best regards, Lars

Am 02.10.2015 6:45 nachm. schrieb "Ed Willink" <ed@xxxxxxxxxxxxx>:
Hi Lars

As of a couple of minutes ago that plan [1] lists only the anomalous jdt.annotation as a Java 8 minimum version.

Since that was the case six weeks ago too, I assumed that Java 8 BREE would not actually occur for most plugins.

  ÂRegards

    Ed Willink

[1] https://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/eclipse/development/plans/eclipse_project_plan_4_6.xml

On 02/10/2015 12:34, Lars Vogel wrote:
Dani did send the information around a while ago Neon will require
Java 8. See https://dev.eclipse.org/mhonarc/lists/cross-project-issues-dev/msg12177.html

Best regards, Lars

On Fri, Oct 2, 2015 at 6:01 PM, Ed Willink <ed@xxxxxxxxxxxxx> wrote:
Hi

I didn't see any announcement, but there was little dissent in earlier
discussions.

In M2, org.eclipse.core.jobs has moved to Java 8 BREE so to all intents and
purposes Java 7 support is dead.

   Regards

    ÂEd Willink


On 07/03/2015 22:54, Lars Vogel wrote:

On Wed, Mar 4, 2015 at 5:42 PM, Igor Fedorenko <igor@xxxxxxxxxxxxxx> wrote:
This is getting off-topic, but I think we should plan to move to java 8
for the next release after mars.

+1



_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from
this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev



_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev