[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] b3 aggregator can't consume kepler repo?

Do you mean the SDK repo? Yes I tried, it works, but it doesn't contain the stuff I need.
Do you mean in addition to the simrel repo? How would this change anything, isn't the simrel repo (supposed to be) self-contained?

If this is not what you suggested, please be more specific,

thanks
Stephan

PS: just as of this writing I succeeded creating a big aggregator file with lots of individual repos from the projects that I depend on and with myriads of exclusion rules. This validates OK by avoiding the kepler repo, so it seems I have an (ugly) workaround. But still there seems to be a severe bug, right?

----- ursprÃngliche Nachricht ---------

Subject: Re: [cross-project-issues-dev] b3 aggregator can't consume kepler repo?
Date: Mo 07 Okt 2013 22:42:34 CEST
From: Pascal Rapicault<pascal.rapicault@xxxxxxxxxxxx>
To: Cross project issues&lt;cross-project-issues-dev@xxxxxxxxxxx&gt;

Did you try adding the platform repo?

-----Original Message-----
From: cross-project-issues-dev-bounces@xxxxxxxxxxx [mailto:cross-project-issues-dev-bounces@xxxxxxxxxxx] On Behalf Of Stephan Herrmann
Sent: October-07-13 4:40 PM
To: cross-project-issues-dev@xxxxxxxxxxx
Subject: [cross-project-issues-dev] b3 aggregator can't consume kepler repo?

I've had some fights with the b3 aggregator today and it seems to boil down to the fact that the aggregator cannot consume the kepler repository, neither releases/kepler, nor one of the children 201306260900 or 201309270900.

To witness: I have a toy aggregation (1 feature with one plugin) that validates OK, but as soon as I add the kepler repo the aggregator dies with:

org.eclipse.core.runtime.CoreException: Cannot complete the install because some dependencies are not satisfiable
	at org.eclipse.b3.aggregator.engine.ValidationSetVerifier.run(ValidationSetVerifier.java:686)
	at org.eclipse.b3.aggregator.engine.Builder.runRepositoryVerifier(Builder.java:1704)
	at org.eclipse.b3.aggregator.engine.Builder.run(Builder.java:1635)
	at org.eclipse.b3.aggregator.presentation.AggregatorActionBarContributor$BuildAggregationAction$1.run(AggregatorActionBarContributor.java:292)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

It's the same exception as in https://bugs.eclipse.org/bugs/show_bug.cgi?id=321756#c11

Adding the juno SR2 repo doesn't have this effect (full juno repo has a conflict in a modisco feature).

Has anybody else seen this?
Are those repos broken, or is it "just" b3?

FWIW I tried 4.2 and 4.3 versions of b3.

Stephan
_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev
_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev


---- ursprÃngliche Nachricht Ende ----