Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] versions

> Since the bulk of Eclipse is still Java 5 compliant, this seems like a killer.

The bulk, in terms of bundles, maybe ... but I know the Platform requires 1.6 (for Help to work, because Jetty requires 1.6) and I believe all the EPP packages specify 1.6 as minimum runtime (for that "product", not at a bundle level).

So, I may be showing my ignorance, or missing your point, but if its simply a matter that using 12 would require users to use 1.6, it does not seem like a killer to me. Of course ... depends greatly on your adopters and target user.

For interest, the "distribution" of BREEs are listed in one of our "simrel repo" reports ...

It shows the bulk still at 1.5 level, on a bundle-by-bundle basis, but a number at 1.6 and even some at 1.7! (Those requiring 1.7 make me a little nervous .. but, assume its necessary and satisfactory for adopters, or they would say if it was causing them problems).

From:        Ed Willink <ed@xxxxxxxxxxxxx>
To:        Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>,
Date:        05/07/2013 05:11 PM
Subject:        Re: [cross-project-issues-dev] versions
Sent by:        cross-project-issues-dev-bounces@xxxxxxxxxxx

Hi and give details on issues.

My class version error arises because 12 has Java 6 rather than Java 5 classes. Since the bulk of Eclipse is still Java 5 compliant, this seems like a killer.


       Ed Willink

On 07/05/2013 20:11, David M Williams wrote:

Can you explain more? I don't recall any previous problems (which, I know, says more about my memory than anything else .... just asking for current details).

There are versions 10, 11, and 12 available from Orbit ... are you saying in your individual build you are getting multiple versions? If so, sounds like you simply need to "constrain" which version you want.

Or ... are you saying multiple projects are using different versions and that causes a problem? If that's the case, I suggest a "cross-project bug" and describe what you are seeing, and if possible who is using which versions and see if you can gain some agreement to use "the highest version"? (Assuming that's the right one).


Ed Willink <ed@xxxxxxxxxxxxx>
Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>,
05/07/2013 02:58 PM
[cross-project-issues-dev] versions
Sent by:        


My recollection is that there was a version problem at M6.

It seems to have got worse for M7.

I find that I have version 10, 11 and 12 and  no doubt the bad class
version trouble is a consequence.

How are we going to solve this?


       Ed Willink
cross-project-issues-dev mailing list


cross-project-issues-dev mailing list

No virus found in this message.
Checked by AVG -
Version: 2013.0.3272 / Virus Database: 3162/6306 - Release Date: 05/07/13

cross-project-issues-dev mailing list

Back to the top