Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] icu.base and Java 1.5

On Tue, Apr 26, 2011 at 8:05 AM, Ralf Sternberg <rsternberg@xxxxxxxxxxxxxxxxx> wrote:

While we can still build with the new version, we get an
UnsupportedClassVersionError when icu classes are loaded while running
on a 1.4 VM (bug 340000).

I wonder if this does not cause problems with other consumers of icu.
As an example, org.eclipse.jface.databinding imports the icu.text
package, even though it has the execution environment
CDC-1.0/Foundation-1.0,J2SE-1.3. Any thoughts?

This won't have an effect on building (ex, org.eclipse.core.resources and org.eclipse.osgi are now at 1.5, but the workbench and IDE build on top of them as BREE: J2SE-1.4).  The Eclipse Platform now allows bundles to move to java 1.5, and some have started.

But yes, the Indigo ICU won't run on a 1.4 JVM.

If you require a 1.4 ICU runtime, you need to use the ICU base shipped with 3.6, available in orbit, ex:


Paul Webster
Hi floor.  Make me a sammich! - GIR

Back to the top