[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[aspectj-users] cflow not working in J2EE (weblogic 8.1) ??

hi

using AJDT 1.3.1, aspectj 1.5.1a
I've got cflow working in the eclipse env
ajdt cross references : OK
testclasses : OK

then I try to instrument a webapp (very basic Struts, no EJB calls) with
the same cflow
in Eclipse env - cross references page : OK

I build the webapp using maven2 aspectj plugin
joinpoint reporting by maven : OK
build successful

however: Running the webapp nothing happens
no errors, no output
I'm using weblogic 8.1 SP4
I can debug until :
-> CFlowCounter.isValid line:45
-> step in gives:
ThreadStackFactoryImpl$ThreadCounterImpl.isNotZero()line:43
after that the 'instrumented method' returns - and that's it (which is not
enough of course)

All other instrumentations work just fine

So, should the cflow work ?
I'm I missing something ?

All input more than welcome

Danny


______________________________________________________________________________________________

SmalS-MvM sluit elke aansprakelijkheid uit in verband met de juistheid, de
volledigheid of het tijdig toekomen van de informatie in deze e-mail. Aan
deze e-mail kunnen geen rechten worden ontleend en deze e-mail houdt in
geen geval een erkenning van welkdanige aansprakelijkheid in.
Dit bericht is alleen bestemd voor de geadresseerde. Indien dit bericht
niet voor u bestemd is, verzoeken wij u dit onmiddellijk aan ons te melden
en het bericht te vernietigen.

SmalS-MvM décline toute responsabilité quant à l'exactitude, à
l'exhaustivité et au délai de transmission des informations contenues dans
cet e-mail. Aucun droit ne peut être revendiqué sur cet e-mail et cet
e-mail n'implique en aucun cas une reconnaissance de responsabilité, quelle
qu'elle soit.
Ce message s'adresse uniquement au destinataire. Si ce message ne vous est
pas destiné, nous vous prions de nous le signaler immédiatement et de
détruire le message.