Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Jubula » AUT Unable to Get Focus(Running the test via Hudson slave fails to get focus from RHEL login screen.)
AUT Unable to Get Focus [message #1591651] Thu, 29 January 2015 17:11 Go to next message
a goettl is currently offline a goettlFriend
Messages: 17
Registered: December 2014
Junior Member
I have a test suite that executes successfully running in Eclipse. It also runs successfully via command line using external test executor and AUTAgent instead of them being embedded in eclipse. However, when I schedule a Hudson job to execute the test suite on a slave machine my test will start and the first test case executes successfully (click OK button on first application window to accept), but then the AUT opens a new window which cannot get focus. The screenshot for the test failure shows my AUT window on top the the RHEL login screen. The text that should have been entered in the AUT text field is instead in the username field of the RHEL login screen.

I attempted workarounds listed in other posts, like creating an event handler to perform external button clicks like alt+shift+tab to cycle through the list of running applications in order to get focus, but these too failed. It seems that test execution is behaving differently when there is no active user session in the OS?

The error is an Action Error due to timeout received before confirming the posted event and the screenshots show the text being repeatedly appended into the RHEL username field.
Re: AUT Unable to Get Focus [message #1591783 is a reply to message #1591651] Thu, 29 January 2015 18:46 Go to previous messageGo to next message
a goettl is currently offline a goettlFriend
Messages: 17
Registered: December 2014
Junior Member
I also have the Xvnc plugin installed in Hudson and have it enabled for the hudson job executing the tests.
Re: AUT Unable to Get Focus [message #1592674 is a reply to message #1591783] Fri, 30 January 2015 06:45 Go to previous message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member
I think that the problem is that you do need an active user session. Jubula sends clicks and key presses like a real user would, so you do need to have a user logged in to a real session to perform tests.

Hope that helps!
Alex
Previous Topic:Object Mapping Not Working
Next Topic:extension point
Goto Forum:
  


Current Time: Wed Apr 17 15:47:22 GMT 2024

Powered by FUDForum. Page generated in 0.02592 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top