Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Jubula » Problem with the Inspector(Inspector)
Problem with the Inspector [message #1511910] Mon, 15 December 2014 09:16 Go to next message
Benno Heilmann is currently offline Benno HeilmannFriend
Messages: 13
Registered: November 2014
Junior Member
Hi,

my Inspector does not behave the way it should.
I read here at sourceforge the 4DIAC help (<5 Posts => no link)
(section: Development Documentation -> Automatic testing with Jubula)

So I do Window-> Show View-> Inspector and activate it.
My intention is to get the path of the encircled item in the palette.
I click on it, and change back to Jubula but the area that is meant to show the results of the Inspector is empty in my case. I dont understand.

However, I once successfully made Jubula double click an item in a tree adressing
it like 'tree'/'subtree'/'subsubtree'.
But the area displays something like org.fordiac.application.editparts.FBEditPart_1, instead of a path structure.
Or is there a path structure that can address the tree item hidden inside org.fordiac....?

Thank you so much for your help

Cheers,
Benno
Re: Problem with the Inspector [message #1513109 is a reply to message #1511910] Tue, 16 December 2014 08:21 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member
Hi there,

you may need to click once to activate your AUT then click again to collect the path to the item. The image you posted does show a path structure - you should be able to right click and select "copy path" for the leaf element in the image you added.

Hope that helps!
Alex
Re: Problem with the Inspector [message #1517061 is a reply to message #1513109] Fri, 19 December 2014 08:17 Go to previous messageGo to next message
Benno Heilmann is currently offline Benno HeilmannFriend
Messages: 13
Registered: November 2014
Junior Member
Thank you for your help. Unfortunately it still is not working. I found a post on the Forum stating Jubula supports pure e4, e4 with compat layer and e3 and that the Jubula team is waiting for gef4 to add support for e4 ( "e4" terrific first move in chess ;D). Is this still an issue or is it outdated?
Re: Problem with the Inspector [message #1549162 is a reply to message #1517061] Tue, 06 January 2015 11:09 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member
Thanks for the update! Yes, GEF support with E4 compat layer hasn't been realised yet. Is your AUT a pure e4 AUT or an AUT with compat layer?
Re: Problem with the Inspector [message #1559795 is a reply to message #1549162] Mon, 12 January 2015 07:46 Go to previous message
Benno Heilmann is currently offline Benno HeilmannFriend
Messages: 13
Registered: November 2014
Junior Member
Yes it is a pure E4 AUT. But with older Versions of the AUT I can use the inspector.
Previous Topic:drag&drop, palette, graphic component
Next Topic:E4 GEF Support?
Goto Forum:
  


Current Time: Mon Apr 22 22:42:06 GMT 2024

Powered by FUDForum. Page generated in 0.03417 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top