Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Eclipse crash with RHEL 2.6.32-504.el6.i686
Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1448997] Mon, 20 October 2014 19:21 Go to next message
Riley Brown is currently offline Riley BrownFriend
Messages: 2
Registered: October 2014
Junior Member
Guys,
We have some users who have updated to the latest RHEL kernel (2.6.32-504.el6.i686) and Eclipse will crash on them when trying to edit a certain development copy. It happens for every developer with this kernel.

The error message is:
eclipse: cairo-misc.c:380: _cairo_operator_bounded_by_source: Assertion `NOT_REACHED' failed."

v1.9.4 of Cairo may fix this, but it is not out on our Repo and it is up to date. The latest we have is v1.8.8.

Can you guys advise?
Thanks!
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1454919 is a reply to message #1448997] Tue, 28 October 2014 22:35 Go to previous messageGo to next message
Jens Stobernack is currently offline Jens StobernackFriend
Messages: 4
Registered: November 2011
Junior Member
Can anyone comment on this? I just update to CentOS 6.6 and Kepler SR2. Now I have a development environment which is unusable.

Eclipse will just close, no java output or pop-up error window. The only output on the console is the error message in the OP. The same issue is seen in Kepler SR1.

Edit: Forget it. Found that Luna SR1 has it fixed. I missed this report.

http://git.eclipse.org/c/platform/eclipse.platform.swt.git/commit/?h=R4_4_maintenance&id=e221e17eab2d3a2fe8fa3f815e7df1b6bbd62b20

Regards,
Jens.

[Updated on: Tue, 28 October 2014 22:58]

Report message to a moderator

Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1455967 is a reply to message #1454919] Wed, 29 October 2014 23:28 Go to previous messageGo to next message
Dan Pan is currently offline Dan PanFriend
Messages: 1
Registered: October 2014
Junior Member
suffering from exactly the same failure. I'm a scala developer and our project sticks to 2.10.x this moment, which means I could not upgrade my eclipse to Juno this moment b/c of the Scala-IDE for juno is for 2.11.x only (I tried the nightly build for Scala 2.10.x and Eclipse Juno but it failed). Hope the community could fix it asap.
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1456300 is a reply to message #1448997] Thu, 30 October 2014 08:02 Go to previous messageGo to next message
Christoph Mayer is currently offline Christoph MayerFriend
Messages: 2
Registered: October 2014
Junior Member
Hi -:)
I also upgraded my System to CentOS 6.6 and I'm using Kepler. I have the still problem but found not much stuff on google.
I tried Luna and it worked everything without any problems. Smile

Is there also a fix for Kepler available? I can't upgrade to Luna because my University is still using a SVN 1.6 Server Sad

Best Regards and thank you for your help
Christoph
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1456529 is a reply to message #1456300] Thu, 30 October 2014 13:01 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
It's theoretically possible to install Subversive with 1.6 connectors into Luna. See https://www.eclipse.org/forums/index.php/t/826574/

[Updated on: Thu, 30 October 2014 13:01]

Report message to a moderator

Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1456569 is a reply to message #1448997] Thu, 30 October 2014 13:46 Go to previous messageGo to next message
Riley Brown is currently offline Riley BrownFriend
Messages: 2
Registered: October 2014
Junior Member
Guys,
One of my users found a workaround via adding "-Dorg.eclipse.swt.internal.gtk.cairoGraphics=false" to eclipse.ini.
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1457017 is a reply to message #1456569] Thu, 30 October 2014 23:56 Go to previous messageGo to next message
Christoph Mayer is currently offline Christoph MayerFriend
Messages: 2
Registered: October 2014
Junior Member
Hey Riley,
your fix worked for me... Smile

Thank you very much
Best Regards
Christoph
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1457036 is a reply to message #1457017] Fri, 31 October 2014 00:24 Go to previous messageGo to next message
koray katmer is currently offline koray katmerFriend
Messages: 1
Registered: October 2014
Junior Member
RHEL kernel (2.6.32-504.el6.i686) my problem.

[Updated on: Tue, 04 November 2014 13:52] by Moderator

Report message to a moderator

Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1457291 is a reply to message #1448997] Fri, 31 October 2014 07:04 Go to previous messageGo to next message
Mario Philippi is currently offline Mario PhilippiFriend
Messages: 1
Registered: October 2014
Junior Member
Thanks Riley, for providing this workaround Smile
Works like a charm!

//mario
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1460620 is a reply to message #1448997] Mon, 03 November 2014 19:18 Go to previous messageGo to next message
Darrin Barr is currently offline Darrin BarrFriend
Messages: 1
Registered: November 2014
Junior Member
I've seen similar with the kernel I'm on (RHEL 2.6.32-358.14.1.el6.x86_64) but with a twist.

I've had to upgrade to Luna SR1 on a few DELL 6700 laptops with the same issue.

However, i have one laptop in which the Windows Builder plugin goes "bonkers" (a technical term) when in Design mode. The pallette appears to be empty, but tooltips appear when hovering the mouse where templates should be. Otherwise, the templates are invisible. Additionally, the panel with all of the controls that have been added to it is similarly invisible, yet clickable (the Properties panel fills in). Other refresh problems occur when resizing the editor windows.

It feels more like an X dispay problem (the laptop has an NVIDIA K4000M card). However, this is the only laptop with this problem (out of several I've updated successfully) and i've tried the latest NVIDIA drivers (and a whole slew of legacy ones, too). The Optimus setting is turned off.

An error is displayed when starting eclipse:
org.eclipse.m2e.logback.configuration: The org.eclipse.m2e.logback.configuration bundle was activated before the state location was initialized. Will retry after the state location is initialized.
org.eclipse.m2e.logback.configuration: Logback config file: /home/local/user/workspace/.metadata/.plugins/org.eclipse.m2e.logback.configuration/logback.1.5.0.20140606-0033.xml
org.eclipse.m2e.logback.configuration: Initializing logback
java.lang.ClassCastException: org.eclipse.osgi.internal.framework.EquinoxConfiguration$1 cannot be cast to java.lang.String
at org.eclipse.m2e.logback.configuration.LogHelper.logJavaProperties(LogHelper.java:26)
at org.eclipse.m2e.logback.configuration.LogPlugin.loadConfiguration(LogPlugin.java:189)
at org.eclipse.m2e.logback.configuration.LogPlugin.configureLogback(LogPlugin.java:144)
at org.eclipse.m2e.logback.configuration.LogPlugin.access$2(LogPlugin.java:107)
at org.eclipse.m2e.logback.configuration.LogPlugin$1.run(LogPlugin.java:62)
at java.util.TimerThread.mainLoop(Timer.java:555)
at java.util.TimerThread.run(Timer.java:505)

Anyone else seen something similar and have a fix/workaround or can point me to an area with more diagnostic information?

The workaround provided earlier (-Dorg.eclipse.swt.internal.gtk.cairoGraphics=false) has allowed me to downgrade back to Juno where Windows Builder doesn't have this problem.

Thanks.
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1465346 is a reply to message #1456569] Sat, 08 November 2014 08:51 Go to previous messageGo to next message
Mehul Chuahan is currently offline Mehul ChuahanFriend
Messages: 1
Registered: November 2014
Junior Member

Thanks .

It has been worked for Eclipse Juno , and Eclipse Mars.

Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1465652 is a reply to message #1456569] Sat, 08 November 2014 15:05 Go to previous messageGo to next message
Volodymyr Krupach is currently offline Volodymyr KrupachFriend
Messages: 1
Registered: November 2014
Junior Member
Riley Brown, Thank you very much!
You saved me a lot of time!
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1489910 is a reply to message #1448997] Thu, 27 November 2014 19:59 Go to previous messageGo to next message
Christiano Monteiro is currently offline Christiano MonteiroFriend
Messages: 1
Registered: November 2014
Junior Member
Hi Riley,

Your fix worked for me.

Thank you very much
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1496905 is a reply to message #1448997] Wed, 03 December 2014 11:22 Go to previous messageGo to next message
John Grasett is currently offline John GrasettFriend
Messages: 1
Registered: December 2014
Junior Member
I ran into the same issue attempting to upgrade IBM Rational application Framework from version 3.0.0 to 3.0.1, using the bundled vesion of IBM Installation Manager (which is eclipse based).

I found adding the string to the IBMIM.ini file bypassed the crash/error.

Thanks for the help!
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1498910 is a reply to message #1496905] Thu, 04 December 2014 19:17 Go to previous messageGo to next message
Jack Bonn is currently offline Jack BonnFriend
Messages: 2
Registered: December 2014
Junior Member
I had the same problem with Nvidia CUDA development tool called nsight which contains Eclipse. I added:

-Dorg.eclipse.swt.internal.gtk.cairoGraphics=false

to the appropriate nsight.ini file.

Thanks for the help.
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1524567 is a reply to message #1498910] Tue, 23 December 2014 14:20 Go to previous messageGo to next message
David Jones is currently offline David JonesFriend
Messages: 2
Registered: November 2013
Junior Member
The work-around works for me. However, it makes the frame margins in eclipse look pretty ugly. Is that normal?

What exactly is the problem? Is it that cairo doesn't work right on CentOS 6.6, or that Cairo shouldn't be used with Eclipse on CentOS at all?

If the latter, then using this workaround shouldn't effect the appearance of eclipse, right?
Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1546827 is a reply to message #1524567] Mon, 05 January 2015 04:41 Go to previous messageGo to next message
Piyush Chordia is currently offline Piyush ChordiaFriend
Messages: 1
Registered: January 2015
Junior Member
Works perfectly fine. I've tried for IBM products like RAD, RTC, IBM Installation Manager and it works too.
icon14.gif  Re: Eclipse crash with RHEL 2.6.32-504.el6.i686 [message #1696568 is a reply to message #1456569] Wed, 27 May 2015 10:09 Go to previous message
Vikas Garg is currently offline Vikas GargFriend
Messages: 1
Registered: May 2015
Junior Member
Thanks for the solution. It still works.
Previous Topic:How to create or add smali project?
Next Topic:Lắp Mạng internet FPT Thường Tín, Tp Hà Nội
Goto Forum:
  


Current Time: Tue Aug 09 17:23:40 GMT 2022

Powered by FUDForum. Page generated in 0.03524 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top