Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » What happened to "Alt+Shift+X" shortcuts??(Alt+Shift+X not working and haven't for some time.)
What happened to "Alt+Shift+X" shortcuts?? [message #1385325] Thu, 05 June 2014 15:59 Go to next message
Dave Rathnow is currently offline Dave RathnowFriend
Messages: 25
Registered: March 2014
Junior Member
I've been having this problem since Juno (at least) where none of the Alt+Shift+X short cuts key sequences are working. The one's I use the most are "Alt+Shift+X, J" = Run Java Application, and "Alt+Shift+X, T" = Run JUnit Test.

These key sequence do nothing. When I press "Alt+Shift+X", the little popup menu shows up in the lower right corning but as soon as I hit another key, it disappears and nothing happens. No errors in the error log, nothing in the Eclipse log file, and nothing in the console.

I have notice that if I press "Alt+Shift+X, T" while editing a non-junit test, a dialog pops up saying "No JUnit tests found" but even if I do it while editing a junit test, nothing happens.

I've check my key bindings and they are all look right.

Is anyone else having this problem?
Re: What happened to "Alt+Shift+X" shortcuts?? [message #1385328 is a reply to message #1385325] Thu, 05 June 2014 16:05 Go to previous messageGo to next message
Felix Dorner is currently offline Felix DornerFriend
Messages: 295
Registered: March 2012
Senior Member
On 05/06/2014 17:59, Dave Rathnow wrote:
> I've been having this problem since Juno (at least) where none of the
> Alt+Shift+X short cuts key sequences are working. The one's I use the
> most are "Alt+Shift+X, J" = Run Java Application, and "Alt+Shift+X, T" =
> Run JUnit Test.
> These key sequence do nothing. When I press "Alt+Shift+X", the little
> popup menu shows up in the lower right corning but as soon as I hit
> another key, it disappears and nothing happens. No errors in the error
> log, nothing in the Eclipse log file, and nothing in the console.
>
> I have notice that if I press "Alt+Shift+X, T" while editing a non-junit
> test, a dialog pops up saying "No JUnit tests found" but even if I do it
> while editing a junit test, nothing happens.


Works for me with Kepler SR2 (Run Junit Plugin Test). May be placebo,
but did you try to Preferences->Editors->Keys->Reset? I use the Emacs
scheme and stuff sometimes gets messed up for now obvious reason.
Re: What happened to "Alt+Shift+X" shortcuts?? [message #1385363 is a reply to message #1385328] Thu, 05 June 2014 20:14 Go to previous message
Dave Rathnow is currently offline Dave RathnowFriend
Messages: 25
Registered: March 2014
Junior Member

I forgot to mention my Eclipse version is 4.3.0.

The reset is a bit of a hammer approach but it seems to have done the trick. Everything is working again. I'm at a loss to explain why. I never changed those key bindings and they look no different now than they did before the reset. Now I just have to figure out what key bindings I did change and are now lost.

Thanks!
Previous Topic:Eclipse Source Build
Next Topic:Problem importing a project
Goto Forum:
  


Current Time: Sat Jun 15 13:10:39 GMT 2024

Powered by FUDForum. Page generated in 0.04246 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top