Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dynamic Languages Toolkit (DLTK) » RSE plugin integration with dltk
RSE plugin integration with dltk [message #22435] Tue, 22 April 2008 05:06 Go to next message
Abhijit is currently offline AbhijitFriend
Messages: 18
Registered: July 2009
Junior Member
Hi all,

I'm developing an dltk based IDE for a custom scripting language using
dltk 1.0.

Earlier we have developed the IDE using eclipse base framework 3.3, in
which we have used default project wizard of eclipse. We then used the
remote system explorer (RSE) feature which added the drop down entry in
Project wizard for creating new project on remote system.

How to do the same with default project wizard provided by dltk 1.0.
Please help?

thanks and regards,
Abhijit.
Re: RSE plugin integration with dltk [message #22486 is a reply to message #22435] Tue, 22 April 2008 06:02 Go to previous messageGo to next message
Andrei Sobolev is currently offline Andrei SobolevFriend
Messages: 72
Registered: July 2009
Member
Hi Abhijit,

Latest DLTK 1.0 provide feature named environments, and we have implementation of RSE environment for each existed
connection (except telnet, windows).

DLTK Project wizards allow selection of connection or host on which project will be created.
So if RSE and RSE intergarion plugins are available, it will work almost same as default project wizard with RSE.

Best regards,
Andrei Sobolev.


> Hi all,
>
> I'm developing an dltk based IDE for a custom scripting language using
> dltk 1.0.
>
> Earlier we have developed the IDE using eclipse base framework 3.3, in
> which we have used default project wizard of eclipse. We then used the
> remote system explorer (RSE) feature which added the drop down entry in
> Project wizard for creating new project on remote system.
>
> How to do the same with default project wizard provided by dltk 1.0.
> Please help?
>
> thanks and regards,
> Abhijit.
>
Re: RSE plugin integration with dltk [message #24397 is a reply to message #22486] Thu, 29 May 2008 06:05 Go to previous messageGo to next message
Abhijit is currently offline AbhijitFriend
Messages: 18
Registered: July 2009
Junior Member
Thanks for the help.

We now had eclipse 3.4M7/3.4RC2 installed with dltk1.0RC1 and required
dltkrse plugin. Also we have RSE3.0RC1 intalled.

But now we are getting "org.eclipse.swt.SWTException: Invalid Thread
Access" whenever we try to open our script in editor. We also tried
creating a ruby script and opened it. Still we get
"org.eclipse.swt.SWTException: Invalid Thread Acess" exception.

We observed that if we donot install RSE3.0RC1, our product works fine.

Should I raise this as a bug in eclipse 3.4M7/3.4RC2 or in RSE3.0RC1?

Please help.

regards,
Abhijit.
Re: RSE plugin integration with dltk [message #24477 is a reply to message #24397] Thu, 29 May 2008 07:14 Go to previous messageGo to next message
Andrei Sobolev is currently offline Andrei SobolevFriend
Messages: 72
Registered: July 2009
Member
Hi Abhijit,
> Thanks for the help.
> We now had eclipse 3.4M7/3.4RC2 installed with dltk1.0RC1 and required
> dltkrse plugin. Also we have RSE3.0RC1 intalled.
> But now we are getting "org.eclipse.swt.SWTException: Invalid Thread
> Access" whenever we try to open our script in editor. We also tried
> creating a ruby script and opened it. Still we get
> "org.eclipse.swt.SWTException: Invalid Thread Acess" exception.
>
> We observed that if we donot install RSE3.0RC1, our product works fine.
>
> Should I raise this as a bug in eclipse 3.4M7/3.4RC2 or in RSE3.0RC1?

There is already bug for this in RSE https://bugs.eclipse.org/bugs/show_bug.cgi?id=227750
This is caused by early initialization of RSE.

For a workaround please try to start Eclipse with -clean argument.

Best regards,
Andrei Sobolev.

>
> Please help.
>
> regards,
> Abhijit.
>
Re: RSE plugin integration with dltk [message #24599 is a reply to message #24477] Thu, 29 May 2008 18:17 Go to previous messageGo to next message
Andrey Platov is currently offline Andrey PlatovFriend
Messages: 28
Registered: July 2009
Junior Member
Problem shall be fixed in DLTK 0.95RC2. Note: we downgraded version
number from 1.0 to 0.95 since we're still incubating project.

> Hi Abhijit,
>> Thanks for the help.
>> We now had eclipse 3.4M7/3.4RC2 installed with dltk1.0RC1 and required
>> dltkrse plugin. Also we have RSE3.0RC1 intalled.
>> But now we are getting "org.eclipse.swt.SWTException: Invalid Thread
>> Access" whenever we try to open our script in editor. We also tried
>> creating a ruby script and opened it. Still we get
>> "org.eclipse.swt.SWTException: Invalid Thread Acess" exception.
>>
>> We observed that if we donot install RSE3.0RC1, our product works fine.
>>
>> Should I raise this as a bug in eclipse 3.4M7/3.4RC2 or in RSE3.0RC1?
>
> There is already bug for this in RSE https://bugs.eclipse.org/bugs/show_bug.cgi?id=227750
> This is caused by early initialization of RSE.
>
> For a workaround please try to start Eclipse with -clean argument.
>
> Best regards,
> Andrei Sobolev.
>
>> Please help.
>>
>> regards,
>> Abhijit.
>>
Re: RSE plugin integration with dltk [message #24862 is a reply to message #24599] Tue, 03 June 2008 11:36 Go to previous message
Abhijit is currently offline AbhijitFriend
Messages: 18
Registered: July 2009
Junior Member
Hi Andrey,

The RSE is working fine in new 0.95RC2 version. Thanks for the help.

regards,
Abhijit.
Previous Topic:Reconiling strategy problem in dltk1.0RC1
Next Topic:Ruby module in DLTK
Goto Forum:
  


Current Time: Wed May 22 09:00:50 GMT 2024

Powered by FUDForum. Page generated in 0.03970 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top