Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Is org.eclipse.ocl.ecore for equinox only?(Is there a way to make org.eclipse.ocl.ecore work in Felix?)
Is org.eclipse.ocl.ecore for equinox only? [message #1328091] Fri, 02 May 2014 14:00 Go to next message
Geoffry Roberts is currently offline Geoffry RobertsFriend
Messages: 13
Registered: May 2014
Junior Member
Is there a way to make org.eclipse.ocl.ecore work in Felix?

I just encountered a very nasty surprise. I am using some third party bundles that depend on the org.eclipse.ocl.ecore, which in turn depends on org.eclipse.runtime. The bundles in question run nicely in equinox but not in Felix. Class casting exceptions arise when one tries this. The tragedy is I have other bundles that are fine in Felix but problematic in equinox. To top it off, Felix is my production platform.

Everything works great outside OSGi.

Thanks all
Re: Is org.eclipse.ocl.ecore for equinox only? [message #1328197 is a reply to message #1328091] Fri, 02 May 2014 15:14 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 7099
Registered: July 2009
Senior Member
Hi

Please use the OCL newsgroup for OCL discussion.

However this seems like an Equinox issue.

There is very little/no significant OSGi code in org.eclipse.ocl.ecore
so I suspect that the problem lies in your launcher. After all it can be
run standalone. Does EMF work fin? What are the CCEs ?

Bottom line. If you want to run in an unsupported configuration you may
have to debug the problems. Please report back with any useful solutions.

Regards

Ed Willink

On 02/05/2014 15:51, Geoffry Roberts wrote:
> Is there a way to make org.eclipse.ocl.ecore work in Felix?
>
> I just encountered a very nasty surprise. I am using some third party
> bundles that depend on the org.eclipse.ocl.ecore, which in turn
> depends on org.eclipse.runtime. The bundles in question run nicely in
> equinox but not in Felix. Class casting exceptions arise when one
> tries this. The tragedy is I have other bundles that are fine in
> Felix but problematic in equinox. To top it off, Felix is my
> production platform.
> Everything works great outside OSGi.
>
> Thanks all
Re: Is org.eclipse.ocl.ecore for equinox only? [message #1328248 is a reply to message #1328197] Fri, 02 May 2014 15:48 Go to previous messageGo to next message
Geoffry Roberts is currently offline Geoffry RobertsFriend
Messages: 13
Registered: May 2014
Junior Member
Thanks Ed,

Yes, EMF works fine. it's the *ocl* clutch of bundles that are at issue. Everyone of them requires org.eclipse.runtime.

I'll look for the ocl group and try again.
Re: Is org.eclipse.ocl.ecore for equinox only? [message #1328249 is a reply to message #1328248] Fri, 02 May 2014 15:49 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 7099
Registered: July 2009
Senior Member
Hi

If EMF works fine, its probably a silly problem.

What are the CCEs?

Regards

Ed Willink


On 02/05/2014 16:48, Geoffry Roberts wrote:
> Thanks Ed,
>
> Yes, EMF works fine. it's the *ocl* clutch of bundles that are at
> issue. Everyone of them requires org.eclipse.runtime.
>
> I'll look for the ocl group and try again.
Re: Is org.eclipse.ocl.ecore for equinox only? [message #1328273 is a reply to message #1328249] Fri, 02 May 2014 16:00 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31839
Registered: July 2009
Senior Member
Actually it's not just a silly problem:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=328227

But it looks like I'm close to a solution that would make model and edit
bundles work in Equinox or in any OSGi container.

To support this fully does require changes in existing MANIFEST.MF as
well as changes in the bundle activator implementations, but hopefully
there will be a generated solution for all those things.


On 02/05/2014 5:49 PM, Ed Willink wrote:
> Hi
>
> If EMF works fine, its probably a silly problem.
>
> What are the CCEs?
>
> Regards
>
> Ed Willink
>
>
> On 02/05/2014 16:48, Geoffry Roberts wrote:
>> Thanks Ed,
>>
>> Yes, EMF works fine. it's the *ocl* clutch of bundles that are at
>> issue. Everyone of them requires org.eclipse.runtime.
>>
>> I'll look for the ocl group and try again.
>


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Is org.eclipse.ocl.ecore for equinox only? [message #1328380 is a reply to message #1328273] Fri, 02 May 2014 17:11 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 7099
Registered: July 2009
Senior Member
Hi

"it's a silly problem" was predicated on "EMF works fine". Clearly it
doesn't.

Good to see someone working on it. Hopefully the solution will be useful
for derived EMF projects too.

Regards

Ed Willink


On 02/05/2014 17:00, Ed Merks wrote:
> Actually it's not just a silly problem:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=328227
>
> But it looks like I'm close to a solution that would make model and
> edit bundles work in Equinox or in any OSGi container.
>
> To support this fully does require changes in existing MANIFEST.MF as
> well as changes in the bundle activator implementations, but hopefully
> there will be a generated solution for all those things.
>
>
> On 02/05/2014 5:49 PM, Ed Willink wrote:
>> Hi
>>
>> If EMF works fine, its probably a silly problem.
>>
>> What are the CCEs?
>>
>> Regards
>>
>> Ed Willink
>>
>>
>> On 02/05/2014 16:48, Geoffry Roberts wrote:
>>> Thanks Ed,
>>>
>>> Yes, EMF works fine. it's the *ocl* clutch of bundles that are at
>>> issue. Everyone of them requires org.eclipse.runtime.
>>>
>>> I'll look for the ocl group and try again.
>>
>
Previous Topic:Prevent generating the extension_parser extension point
Next Topic:[EMFStore] authentication and authorization
Goto Forum:
  


Current Time: Tue Apr 20 02:15:02 GMT 2021

Powered by FUDForum. Page generated in 0.02181 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top