Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » IE v10 browser compatible issue
IE v10 browser compatible issue [message #1096557] Wed, 28 August 2013 15:02 Go to next message
zhen nan is currently offline zhen nanFriend
Messages: 6
Registered: July 2013
Junior Member
Hi

I am trying to use a portlet to display BIRT report, and I found a compatible issue of using IE browser to view the report. This issue happens on IE v9 and v10.
In IE console, I see following errors related with BIRT javascript:

SCRIPT5007: Unable to set property 'overflowX' of undefined or null reference
AbstractBaseReportDocument.js, line 171 character 5
SCRIPT5007: Unable to get property 'collect_parameter' of undefined or null reference
BirtNavigationBar.js, line 238 character 3

Can anyone tell me if there is a fix on this from BIRT?
Re: IE v10 browser compatible issue [message #1106158 is a reply to message #1096557] Tue, 10 September 2013 19:39 Go to previous messageGo to next message
Kristopher Clark is currently offline Kristopher ClarkFriend
Messages: 130
Registered: January 2013
Senior Member
I haven't tried it but it sounds like you'll either need to run IE in compatibility mode or use X-UA-Compatible to tell internet explorer what version the page needs to be rendered in. Since I'm not familiar with your project I don't know where it makes sense to place it, but you could give that a shot. I would first try compatibility mode though to see if that could be a quick fix.
Re: IE v10 browser compatible issue [message #1106216 is a reply to message #1106158] Tue, 10 September 2013 21:03 Go to previous messageGo to next message
zhen nan is currently offline zhen nanFriend
Messages: 6
Registered: July 2013
Junior Member
Hi Kristopher

Using X-UA-Compatible solved my problem. Thanks.
Re: IE v10 browser compatible issue [message #1106219 is a reply to message #1106216] Tue, 10 September 2013 21:08 Go to previous messageGo to next message
Kristopher Clark is currently offline Kristopher ClarkFriend
Messages: 130
Registered: January 2013
Senior Member
You're welcome! Where did you set it to get it to work?
Re: IE v10 browser compatible issue [message #1106240 is a reply to message #1106219] Tue, 10 September 2013 21:45 Go to previous message
zhen nan is currently offline zhen nanFriend
Messages: 6
Registered: July 2013
Junior Member
Hi Kristopher

I am using WebSphere Portal Server. The portlet does not allow me to set X-UA-Compatible. so I have to add following <meta> tag in WebSphere Portal theme theme_en.xml:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" />

Previous Topic:Error while opening a .rptdesign file in Eclipse Juno
Next Topic:Sub item
Goto Forum:
  


Current Time: Thu Oct 28 12:34:36 GMT 2021

Powered by FUDForum. Page generated in 0.02488 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top