Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » deploying on tomcat6
deploying on tomcat6 [message #1060875] Tue, 28 May 2013 19:17 Go to next message
Julia Kurde is currently offline Julia KurdeFriend
Messages: 88
Registered: November 2011
Location: Berlin, Germany
Member
Hello...

I'm trying to deploy an application with tomcat6.
I'm using Juno Service Release 2 with target platform RAP 2.0 and WAR Products (Incubation) 0.2.2.201212132117.
I deployed the examlpe rapdemo like described here
http://eclipse.org/rap/developers-guide/devguide.php?topic=deployment.html&version=2.0
and it works with out any problem.

I compared the .warproduct files and the only difference are the application plugins themselves.
But when I enter the URL in my browser I get
HTTP Status 404 - ProxyServlet: /my_context_path/my_entrypoint_path

type        Status report
message     ProxyServlet: /my_context_path/my_entrypoint_path
description The requested resource (ProxyServlet: /my_context_path/my_entrypoint_path) is not available.

I don't know anymore where to look for differences between the working example and my own not working war product.
Enabling the -console option in the web.xml does not produce any additional logging in the tomcat's logs folder.

The application plugins are loaded into the work/Catalina/localhost directory but it seems the app does not start on server start (the log file generated by the app on startup is not there).

There is another strange thing: With the URL
server/my_context_path/rap
I get
HTTP Status 500 - 

type        Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception   java.lang.IllegalArgumentException: Entry point not found: /rap
[...]

Sure, the entry point path is not /rap but /my_entrypoint_path. But what is special about /rap? With /rax or anything else I don't get that IllegalArgumentException.

Any ideas??

Re: deploying on tomcat6 [message #1060964 is a reply to message #1060875] Wed, 29 May 2013 10:42 Go to previous messageGo to next message
Julia Kurde is currently offline Julia KurdeFriend
Messages: 88
Registered: November 2011
Location: Berlin, Germany
Member
I found out that when tomcat tries to deploy my war file it runs into the following exception:
29.05.2013 12:25:37 org.apache.catalina.session.StandardSession writeObject
WARNUNG: Cannot serialize session attribute org.eclipse.rap.rwt.internal.service.UISessionImpl for session 196F74061DCD155EFE0E8F7F473D87CC
java.io.NotSerializableException: org.eclipse.jface.resource.JFaceResources$FontRegistryStore
	at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1180)
	at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:346)
	at java.util.HashMap.writeObject(HashMap.java:1018)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at java.io.ObjectStreamClass.invokeWriteObject(ObjectStreamClass.java:962)
	at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1480)
	at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
	at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
	at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
	at java.io.ObjectOutputStream.defaultWriteObject(ObjectOutputStream.java:438)
	at java.util.Collections$SynchronizedMap.writeObject(Collections.java:2044)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at java.io.ObjectStreamClass.invokeWriteObject(ObjectStreamClass.java:962)
	at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1480)
	at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
	at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
	at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
	at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1493)
	at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
	at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
	at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:346)
	at java.util.HashMap.writeObject(HashMap.java:1018)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at java.io.ObjectStreamClass.invokeWriteObject(ObjectStreamClass.java:962)
	at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1480)
	at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
	at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
	at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
	at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1493)
	at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
	at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
	at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:346)
	at org.apache.catalina.session.StandardSession.writeObject(StandardSession.java:1546)
	at org.apache.catalina.session.StandardSession.writeObjectData(StandardSession.java:989)
	at org.apache.catalina.session.StandardManager.doUnload(StandardManager.java:517)
	at org.apache.catalina.session.StandardManager.unload(StandardManager.java:463)
	at org.apache.catalina.session.StandardManager.stop(StandardManager.java:667)
	at org.apache.catalina.core.StandardContext.stop(StandardContext.java:4611)
	at org.apache.catalina.core.ContainerBase.removeChild(ContainerBase.java:924)
	at org.apache.catalina.startup.HostConfig.checkResources(HostConfig.java:1174)
	at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1342)
	at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:303)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
	at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1337)
	at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1601)
	at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1610)
	at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1590)
	at java.lang.Thread.run(Thread.java:636)

Although it is "only" a warning, it might cause the problem.
I don't use UISessionImpl directly. It is used somewhere in the RWTLifeCycle. How could I avoid this exception?

Thanks,
Julia


Sorry, this war a wrong information!

This Warning happened when stopping tomcat with the rapdemo. When starting tomcat with only my app (jlzhview8.war) in the webapps folder there is no exception. The logfile catalina.out looks like this:
29.05.2013 12:52:22 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0/jre/lib/i386/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0/jre/lib/i386:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0/jre/../lib/i386:/usr/java/packages/lib/i386:/lib:/usr/lib
29.05.2013 12:52:23 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
29.05.2013 12:52:23 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1587 ms
29.05.2013 12:52:23 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
29.05.2013 12:52:23 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.24
29.05.2013 12:52:23 org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive jlzhview8.war
osgi> 29.05.2013 12:52:33 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ROOT
29.05.2013 12:52:33 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
29.05.2013 12:52:33 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
29.05.2013 12:52:33 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/66  config=null
29.05.2013 12:52:33 org.apache.catalina.startup.Catalina start
INFO: Server startup in 10149 ms

All other logfiles in tomcat's logs folder are empty. Everything looks OK, but opening the URL of the app I get the 404 saying that the ProxyServlet cannot be found. Sad

Regards,
Julia

[Updated on: Wed, 29 May 2013 11:04]

Report message to a moderator

Re: deploying on tomcat6 [message #1060979 is a reply to message #1060875] Wed, 29 May 2013 12:00 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Julia,
> Enabling the -console option in the web.xml does not produce any
> additional logging in the tomcat's logs folder.
This option enable the OSGi console. In the Tomcat console window type
"ss" - this will list all the plugins with their statuses. Do you have
non active plugins? What the "diag <number>" command returns for
non-activated plugins. I've tried to deploy the latest Controls Demo
with RAP 2.1 RC1 and got the following error:
.................
osgi> ss
.................
15 INSTALLED
org.eclipse.equinox.http.servletbridge_1.0.300.v20130327-1442
.................
osgi> diag 15
initial@reference:file:plugins/org.eclipse.equinox.http.servletbridge_1.0.300.v20130327-1442.jar

Direct constraints which are unresolved:
Missing imported package javax.servlet_2.3.0.
Missing imported package javax.servlet.http_2.3.0.
Missing imported package org.eclipse.equinox.http.servlet_1.0.0.
Missing imported package org.eclipse.equinox.servletbridge_1.0.0.
Missing required capability Require-Capability: osgi.ee;
filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&
e=JavaSE)(version=1.3)))".
Leaf constraints in the dependency chain which are unresolved:
initial@reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.jar

Missing optionally imported package javax.servlet.annotation_2.6.0.
initial@reference:file:plugins/org.eclipse.equinox.servletbridge_1.2.200.v20120522-2049.jar

Missing required capability Require-Capability: osgi.ee;
filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))
..ee=JavaSE)(version=1.3)))".
initial@reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.jar

Missing optionally imported package javax.servlet.descriptor_2.6.0.
initial@reference:file:plugins/org.eclipse.equinox.servletbridge_1.2.200.v20120522-2049.jar

Missing imported package javax.servlet.http_2.3.0.
initial@reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.jar

Missing required capability Require-Capability: osgi.ee;
filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))
..ee=JavaSE)(version=1.3)))".
initial@reference:file:plugins/org.eclipse.equinox.servletbridge_1.2.200.v20120522-2049.jar

Missing imported package javax.servlet_2.3.0.
initial@reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.jar

Missing imported package javax.servlet.http_[2.3.0,3.1.0).
initial@reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.jar
[14]
Missing imported package javax.servlet_[2.3.0,3.1.0).
.........
Do you get the same error?
Best,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: deploying on tomcat6 [message #1060984 is a reply to message #1060979] Wed, 29 May 2013 12:22 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Jsut to make it clear - this error is related to the following Libra WAR
Product bug:
Remove dependency to servletbridge.extensionbundle
https://bugs.eclipse.org/bugs/show_bug.cgi?id=398780
I'm using the latest version 0.3.0.201305151323. I hope it will be fixed
soon.
Best,
Ivan

On 5/29/2013 3:00 PM, Ivan Furnadjiev wrote:
> Hi Julia,
>> Enabling the -console option in the web.xml does not produce any
>> additional logging in the tomcat's logs folder.
> This option enable the OSGi console. In the Tomcat console window type
> "ss" - this will list all the plugins with their statuses. Do you have
> non active plugins? What the "diag <number>" command returns for
> non-activated plugins. I've tried to deploy the latest Controls Demo
> with RAP 2.1 RC1 and got the following error:
> ................
> osgi> ss
> ................
> 15 INSTALLED
> org.eclipse.equinox.http.servletbridge_1.0.300.v20130327-1442
> ................
> osgi> diag 15
> initial@reference:file:plugins/org.eclipse.equinox.http.servletbridge_1.0.300.v20130327-1442.jar
>
> Direct constraints which are unresolved:
> Missing imported package javax.servlet_2.3.0.
> Missing imported package javax.servlet.http_2.3.0.
> Missing imported package org.eclipse.equinox.http.servlet_1.0.0.
> Missing imported package org.eclipse.equinox.servletbridge_1.0.0.
> Missing required capability Require-Capability: osgi.ee;
> filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&
> e=JavaSE)(version=1.3)))".
> Leaf constraints in the dependency chain which are unresolved:
> initial@reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.jar
>
> Missing optionally imported package javax.servlet.annotation_2.6.0.
> initial@reference:file:plugins/org.eclipse.equinox.servletbridge_1.2.200.v20120522-2049.jar
>
> Missing required capability Require-Capability: osgi.ee;
> filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))
> .ee=JavaSE)(version=1.3)))".
> initial@reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.jar
>
> Missing optionally imported package javax.servlet.descriptor_2.6.0.
> initial@reference:file:plugins/org.eclipse.equinox.servletbridge_1.2.200.v20120522-2049.jar
>
> Missing imported package javax.servlet.http_2.3.0.
> initial@reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.jar
>
> Missing required capability Require-Capability: osgi.ee;
> filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))
> .ee=JavaSE)(version=1.3)))".
> initial@reference:file:plugins/org.eclipse.equinox.servletbridge_1.2.200.v20120522-2049.jar
>
> Missing imported package javax.servlet_2.3.0.
> initial@reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.jar
>
> Missing imported package javax.servlet.http_[2.3.0,3.1.0).
> initial@reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.jar
> [14]
> Missing imported package javax.servlet_[2.3.0,3.1.0).
> ........
> Do you get the same error?
> Best,
> Ivan
>

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: deploying on tomcat6 [message #1061038 is a reply to message #1060984] Wed, 29 May 2013 15:58 Go to previous messageGo to next message
Julia Kurde is currently offline Julia KurdeFriend
Messages: 88
Registered: November 2011
Location: Berlin, Germany
Member
Hi Ivan,

Quote:

This option enable the OSGi console. In the Tomcat console window type
"ss" - this will list all the plugins with their statuses.


How do I get the OSGi console on the server? In eclipse it is clear (it's just there!) and the output is
osgi> ss
"Framework is launched."

id	State       Bundle
0	ACTIVE      org.eclipse.osgi_3.8.1.v20120830-144521
2	ACTIVE      org.eclipse.help_3.6.0.v20120521-2344
3	ACTIVE      org.eclipse.core.commands_3.6.1.v20120814-150512
4	ACTIVE      org.eclipse.rap.rwt.osgi_2.0.0.20130110-2216
5	ACTIVE      org.eclipse.core.databinding_1.4.1.v20120521-2329
6	ACTIVE      org.eclipse.equinox.console_1.0.0.v20120522-1841
7	ACTIVE      eub.jlzhinternal_1.0.0
10	ACTIVE      org.eclipse.equinox.common_3.6.100.v20120522-1841
11	ACTIVE      org.eclipse.rap.ui_2.0.0.20121230-1109
12	ACTIVE      org.eclipse.core.databinding.property_1.4.100.v20120523-1955
13	ACTIVE      org.eclipse.equinox.preferences_3.5.0.v20120522-1841
14	ACTIVE      org.eclipse.core.expressions_3.4.401.v20120627-124442
15	ACTIVE      org.eclipse.equinox.http.registry_1.1.200.v20120522-2049
16	ACTIVE      org.eclipse.equinox.registry_3.5.200.v20120522-1841
17	ACTIVE      org.eclipse.rap.jface.databinding_2.0.0.20121031-1050
18	ACTIVE      org.eclipse.osgi.services_3.3.100.v20120522-1822
19	ACTIVE      org.eclipse.rap.rwt_2.0.0.20130205-1612
20	ACTIVE      org.eclipse.core.contenttype_3.4.200.v20120523-2004
21	ACTIVE      org.eclipse.core.jobs_3.5.300.v20120622-204750
23	ACTIVE      org.eclipse.core.databinding.observable_1.4.1.v20120521-2329
24	ACTIVE      org.eclipse.rap.ui.workbench_2.0.0.20130107-1035
25	ACTIVE      org.eclipse.core.runtime_3.8.0.v20120521-2346
26	ACTIVE      com.ibm.icu.base_4.4.2.v20110831
27	ACTIVE      org.eclipse.equinox.app_1.3.100.v20120522-1841
31	ACTIVE      org.eclipse.rap.jface_2.0.0.20130107-0921
32	ACTIVE      org.apache.felix.gogo.runtime_0.8.0.v201108120515
33	ACTIVE      org.apache.felix.gogo.shell_0.8.0.v201110170705
34	ACTIVE      org.eclipse.jetty.server_8.1.3.v20120522
35	ACTIVE      org.eclipse.jetty.io_8.1.3.v20120522
36	ACTIVE      org.eclipse.jetty.security_8.1.3.v20120522
37	ACTIVE      org.eclipse.jetty.servlet_8.1.3.v20120522
38	ACTIVE      org.eclipse.jetty.continuation_8.1.3.v20120522
39	ACTIVE      org.eclipse.jetty.http_8.1.3.v20120522
40	ACTIVE      org.eclipse.jetty.util_8.1.3.v20120522
41	ACTIVE      org.apache.felix.gogo.command_0.8.0.v201108120515
44	ACTIVE      org.eclipse.equinox.http.servlet_1.1.300.v20120522-1841
47	ACTIVE      org.eclipse.equinox.http.jetty_3.0.0.v20120522-1841
52	ACTIVE      eub.jlzhtools_1.0.0
58	ACTIVE      eub.lzhview_1.0.0
59	ACTIVE      eub.lib_1.0.0
60	ACTIVE      eub.tableeditor_2.0.0
63	ACTIVE      javax.servlet_3.0.0.v201112011016
64	ACTIVE      org.eclipse.core.databinding.beans_1.2.200.v20120523-1955
65	ACTIVE      eub.rapjlzhview_1.0.0.qualifier
osgi> diag 15
initial@reference:file:plugins/org.eclipse.equinox.http.registry_1.1.200.v20120522-2049.jar [15]
  No unresolved constraints.
osgi> 

But on the server I only have the tomcat manager. I searched the documentation but I could not find how to enter a command like "ss".
Quote:

Remove dependency to servletbridge.extensionbundle

This leads to compile errors of the warproduct file. Maybe I have to remove another plugin, too. But on the other hand, the rapdemo example also contains the plugin org.eclipse.equinox.servletbridge.extensionbundle and it works. So I don't think this is the problem.

Regars,
Julia
Re: deploying on tomcat6 [message #1061073 is a reply to message #1061038] Wed, 29 May 2013 19:32 Go to previous messageGo to next message
Paul Bilnoski is currently offline Paul BilnoskiFriend
Messages: 28
Registered: August 2010
Junior Member
You can enable the OSGI console in a web app by adding this to your web.xml:
<init-param>
	<param-name>commandline</param-name>
	<param-value>-console 54321</param-value>			
</init-param>


Where 54321 is the telnet port to run it on. You may want to use a different port. Once you have this setting, and you have the felix console bundles in your application, get a shell to your server and 'telnet localhost 54321' to get the OSGI console.
Also note that entering "quit" in this console will terminate the OSGI runtime and your web app, so escape from the console properly.
--Paul
Re: deploying on tomcat6 [message #1061162 is a reply to message #1061073] Thu, 30 May 2013 10:22 Go to previous messageGo to next message
Julia Kurde is currently offline Julia KurdeFriend
Messages: 88
Registered: November 2011
Location: Berlin, Germany
Member
Quote:

get a shell to your server and 'telnet localhost 54321'

This worked perfectly, thanks!!
And this is the output.
osgi> ss
"Framework is launched."

id      State       Bundle
0       ACTIVE      org.eclipse.osgi_3.8.1.v20120830-144521
                    Fragments=44
1       ACTIVE      com.ibm.icu.base_4.4.2.v20110831
2       INSTALLED   eub.jlzhinternal_1.0.0
3       INSTALLED   eub.jlzhtools_1.0.0
4       INSTALLED   eub.lib_1.0.0
5       INSTALLED   eub.lzhview_1.0.0
6       INSTALLED   eub.rapjlzhview_1.0.0.201305301143
7       INSTALLED   eub.tableeditor_2.0.0
8       ACTIVE      org.apache.felix.gogo.command_0.8.0.v201108120515
9       ACTIVE      org.apache.felix.gogo.runtime_0.8.0.v201108120515
10      ACTIVE      org.apache.felix.gogo.shell_0.8.0.v201110170705
11      ACTIVE      org.eclipse.core.commands_3.6.1.v20120814-150512
12      ACTIVE      org.eclipse.core.contenttype_3.4.200.v20120523-2004
13      ACTIVE      org.eclipse.core.databinding_1.4.1.v20120521-2329
14      ACTIVE      org.eclipse.core.databinding.beans_1.2.200.v20120523-1955
15      ACTIVE      org.eclipse.core.databinding.observable_1.4.1.v20120521-2329
16      ACTIVE      org.eclipse.core.databinding.property_1.4.100.v20120523-1955
17      ACTIVE      org.eclipse.core.expressions_3.4.401.v20120627-124442
18      ACTIVE      org.eclipse.core.jobs_3.5.300.v20120622-204750
19      ACTIVE      org.eclipse.core.runtime_3.8.0.v20120521-2346
20      ACTIVE      org.eclipse.equinox.app_1.3.100.v20120522-1841
21      ACTIVE      org.eclipse.equinox.common_3.6.100.v20120522-1841
22      ACTIVE      org.eclipse.equinox.console_1.0.0.v20120522-1841
23      ACTIVE      org.eclipse.equinox.http.registry_1.1.200.v20120522-2049
24      ACTIVE      org.eclipse.equinox.http.servlet_1.1.300.v20120522-1841
25      ACTIVE      org.eclipse.equinox.http.servletbridge_1.0.300.v20120522-204
9
26      ACTIVE      org.eclipse.equinox.preferences_3.5.0.v20120522-1841
27      ACTIVE      org.eclipse.equinox.registry_3.5.200.v20120522-1841
28      ACTIVE      org.eclipse.equinox.servletbridge_1.2.200.v20120522-2049
29      ACTIVE      org.eclipse.help_3.6.0.v20120521-2344
30      INSTALLED   org.eclipse.jetty.continuation_8.1.3.v20120522
31      INSTALLED   org.eclipse.jetty.http_8.1.3.v20120522
32      INSTALLED   org.eclipse.jetty.io_8.1.3.v20120522
33      INSTALLED   org.eclipse.jetty.security_8.1.3.v20120522
34      INSTALLED   org.eclipse.jetty.server_8.1.3.v20120522
35      INSTALLED   org.eclipse.jetty.servlet_8.1.3.v20120522
36      INSTALLED   org.eclipse.jetty.util_8.1.3.v20120522
37      ACTIVE      org.eclipse.osgi.services_3.3.100.v20120522-1822
38      ACTIVE      org.eclipse.rap.jface_2.0.0.20130107-0921
39      ACTIVE      org.eclipse.rap.jface.databinding_2.0.0.20121031-1050
40      ACTIVE      org.eclipse.rap.rwt_2.0.0.20130205-1612
41      ACTIVE      org.eclipse.rap.rwt.osgi_2.0.0.20130110-2216
42      ACTIVE      org.eclipse.rap.ui_2.0.0.20121230-1109
43      ACTIVE      org.eclipse.rap.ui.workbench_2.0.0.20130107-1035
44      RESOLVED    org.eclipse.equinox.servletbridge.extensionbundle_1.2.100.v2
0120522-2049
                    Master=0
osgi>

There is obviously a problem with all eub plugins (id 2-7) which make up our app, the jetty plugins (id 30-36) and the extensionbundle plugin (id 44).
For the jetty plugins and the extensionbundle it looks the same in the working rapdemo.
Now, I'm afraid it's up to me to find out why tomcat does NOT activate our eub plugins while jetty inside eclipse does...

Regards,
Julia
Re: deploying on tomcat6 [message #1061168 is a reply to message #1061162] Thu, 30 May 2013 10:45 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Julia,
first you have to remove the Jetty bundles from the WAR. You are
deploying your WAR on Tomcat and Jetty is not needed. Second try "diag
<number>" command in OSGi console to find out why your "eub" bundles are
not active.
HTH,
Ivan

On 5/30/2013 1:22 PM, Julia Kurde wrote:
> Quote:
>> get a shell to your server and 'telnet localhost 54321'
>
> This worked perfectly, thanks!!
> And this is the output.
>
> osgi> ss
> "Framework is launched."
>
> id State Bundle
> 0 ACTIVE org.eclipse.osgi_3.8.1.v20120830-144521
> Fragments=44
> 1 ACTIVE com.ibm.icu.base_4.4.2.v20110831
> 2 INSTALLED eub.jlzhinternal_1.0.0
> 3 INSTALLED eub.jlzhtools_1.0.0
> 4 INSTALLED eub.lib_1.0.0
> 5 INSTALLED eub.lzhview_1.0.0
> 6 INSTALLED eub.rapjlzhview_1.0.0.201305301143
> 7 INSTALLED eub.tableeditor_2.0.0
> 8 ACTIVE org.apache.felix.gogo.command_0.8.0.v201108120515
> 9 ACTIVE org.apache.felix.gogo.runtime_0.8.0.v201108120515
> 10 ACTIVE org.apache.felix.gogo.shell_0.8.0.v201110170705
> 11 ACTIVE org.eclipse.core.commands_3.6.1.v20120814-150512
> 12 ACTIVE org.eclipse.core.contenttype_3.4.200.v20120523-2004
> 13 ACTIVE org.eclipse.core.databinding_1.4.1.v20120521-2329
> 14 ACTIVE org.eclipse.core.databinding.beans_1.2.200.v20120523-1955
> 15 ACTIVE
> org.eclipse.core.databinding.observable_1.4.1.v20120521-2329
> 16 ACTIVE
> org.eclipse.core.databinding.property_1.4.100.v20120523-1955
> 17 ACTIVE org.eclipse.core.expressions_3.4.401.v20120627-124442
> 18 ACTIVE org.eclipse.core.jobs_3.5.300.v20120622-204750
> 19 ACTIVE org.eclipse.core.runtime_3.8.0.v20120521-2346
> 20 ACTIVE org.eclipse.equinox.app_1.3.100.v20120522-1841
> 21 ACTIVE org.eclipse.equinox.common_3.6.100.v20120522-1841
> 22 ACTIVE org.eclipse.equinox.console_1.0.0.v20120522-1841
> 23 ACTIVE org.eclipse.equinox.http.registry_1.1.200.v20120522-2049
> 24 ACTIVE org.eclipse.equinox.http.servlet_1.1.300.v20120522-1841
> 25 ACTIVE
> org.eclipse.equinox.http.servletbridge_1.0.300.v20120522-204
> 9
> 26 ACTIVE org.eclipse.equinox.preferences_3.5.0.v20120522-1841
> 27 ACTIVE org.eclipse.equinox.registry_3.5.200.v20120522-1841
> 28 ACTIVE org.eclipse.equinox.servletbridge_1.2.200.v20120522-2049
> 29 ACTIVE org.eclipse.help_3.6.0.v20120521-2344
> 30 INSTALLED org.eclipse.jetty.continuation_8.1.3.v20120522
> 31 INSTALLED org.eclipse.jetty.http_8.1.3.v20120522
> 32 INSTALLED org.eclipse.jetty.io_8.1.3.v20120522
> 33 INSTALLED org.eclipse.jetty.security_8.1.3.v20120522
> 34 INSTALLED org.eclipse.jetty.server_8.1.3.v20120522
> 35 INSTALLED org.eclipse.jetty.servlet_8.1.3.v20120522
> 36 INSTALLED org.eclipse.jetty.util_8.1.3.v20120522
> 37 ACTIVE org.eclipse.osgi.services_3.3.100.v20120522-1822
> 38 ACTIVE org.eclipse.rap.jface_2.0.0.20130107-0921
> 39 ACTIVE org.eclipse.rap.jface.databinding_2.0.0.20121031-1050
> 40 ACTIVE org.eclipse.rap.rwt_2.0.0.20130205-1612
> 41 ACTIVE org.eclipse.rap.rwt.osgi_2.0.0.20130110-2216
> 42 ACTIVE org.eclipse.rap.ui_2.0.0.20121230-1109
> 43 ACTIVE org.eclipse.rap.ui.workbench_2.0.0.20130107-1035
> 44 RESOLVED
> org.eclipse.equinox.servletbridge.extensionbundle_1.2.100.v2
> 0120522-2049
> Master=0
> osgi>
>
> There is obviously a problem with all eub plugins (id 2-7) which make
> up our app, the jetty plugins (id 30-36) and the extensionbundle
> plugin (id 44). For the jetty plugins and the extensionbundle it looks
> the same in the working rapdemo. Now, I'm afraid it's up to me to find
> out why tomcat does NOT activate our eub plugins while jetty inside
> eclipse does...
>
> Regards,
> Julia

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: deploying on tomcat6 [message #1061181 is a reply to message #1061168] Thu, 30 May 2013 12:41 Go to previous message
Julia Kurde is currently offline Julia KurdeFriend
Messages: 88
Registered: November 2011
Location: Berlin, Germany
Member
I found the problem Very Happy ... it was is very stupid one Confused
Somehow the plugin javax.servlet made it into the required plugins of the eub.lib plugin although it should be in the imported packages... so the lib plugin was not activated and so all the other eub plugins which require the lib plugin were not activated either.

Thanks again for your help!
Regards,
Julia
Previous Topic:Buttons not removed from Table
Next Topic:white screen when waiting for response
Goto Forum:
  


Current Time: Mon Dec 06 18:08:08 GMT 2021

Powered by FUDForum. Page generated in 0.02628 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top