Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Eclipse 3.8 and Apache Batik
Eclipse 3.8 and Apache Batik [message #893436] Wed, 04 July 2012 07:39 Go to next message
techteam is currently offline techteamFriend
Messages: 55
Registered: September 2010
at the moment I try to migrate my Eclipse RCP 3.6 application to Juno.
Inside some features of my app I used the Apache FOP framework to
generate diffrent report (xdoc, pdf, html) files.
Even this framework needs the Apache Batik framework in version 1.7.

Until now the are no problem, but with the migration to Eclipse 3.8 as
base framework I run into the problem that Eclipse 3.8 needs also some
batik bundles but restriced it to version 1.6.

Why does Eclipse uses a old version (1.6) of Batik, when the current
version of Batik (1.7) are also mature with release date january 2008???

And how can I handle the issue to uses RCP 3.8 and also FOP?


Re: Eclipse 3.8 and Apache Batik [message #893860 is a reply to message #893436] Thu, 05 July 2012 17:39 Go to previous message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

I don't know how the bundles can co-exist if they're marked as singletons. If they are not marked as singletons, you might be able to install both versions in your application (your own bundles must list a minimum version of 1.7 in order to not be wired up to the 1.6 version).

Upgrade to batik 1.7 is in the list:


Previous Topic:(Eclipse RCP) How can I add shortcut text after a menu entry in toolbar?
Next Topic:integrate the 3rd party jars into eclipse RCP product
Goto Forum:

Current Time: Fri Apr 19 09:40:59 GMT 2024

Powered by FUDForum. Page generated in 0.01953 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top