Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Installing EMF driving me NUTS
Installing EMF driving me NUTS [message #98642] Mon, 08 October 2007 15:29 Go to next message
Eclipse UserFriend
Originally posted by: axonnus.yahoo.com

Hi everybody. My first message here... oh wait, no, it's the second one, I
also posted this in the newcommer area, sorry for that :;- ). I got a
configuration problem with Eclipse which is driving me NUTS!!! I got the
PDT incubation version of Eclipse and I installed on it the WTP for
HTML/CSS and JSEclipse plugins. Now I'm trying to also add CDT for C++.
But CDT requires EMF.query and UML2. I can't install UML2 because I don't
have EMF. I try to install EMF but...

Object Constraint Language (OCL) 2.0
(1.2.0.v200709262202-3309oA55P5R_F_DAU) requires plug-in
"org.eclipse.emf.ecore (2.4.0)", or equivalent.

I mean... what's wrong with it? It's crazy. I already installed the OCL
and UML2 and still the same warning. And before this, it said that it has
a problem with EMF.QUERY. Wait a minute... isn't EMF supposed to ALSO
INSTALL QUERY? How can it ask for something it will install itself? It's
pretty illogical. Maybe somebody has a clue about this.

Thanks a lot in advance ::- D
Re: Installing EMF driving me NUTS [message #98678 is a reply to message #98642] Mon, 08 October 2007 18:41 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: stepper.sympedia.de

Axxon,

Have you installed an EMF or not? If so, which version? You are not very
clear about that.
The error message (OCL 2.0 requires EMF 2.4) implies that you have to
install EMF 2.4.
So, have you done this?

And I don't think that the core EMF distribution is upposed to install
EMF.Query but I may be wrong.
Anyway, you can get it form
http://www.eclipse.org/modeling/emf/downloads/?project=query

Cheers
/Eike


Axonn Echysttas schrieb:
> Hi everybody. My first message here... oh wait, no, it's the second
> one, I also posted this in the newcommer area, sorry for that :;- ). I
> got a configuration problem with Eclipse which is driving me NUTS!!! I
> got the PDT incubation version of Eclipse and I installed on it the
> WTP for HTML/CSS and JSEclipse plugins. Now I'm trying to also add CDT
> for C++. But CDT requires EMF.query and UML2. I can't install UML2
> because I don't have EMF. I try to install EMF but...
>
> Object Constraint Language (OCL) 2.0
> (1.2.0.v200709262202-3309oA55P5R_F_DAU) requires plug-in
> "org.eclipse.emf.ecore (2.4.0)", or equivalent.
>
> I mean... what's wrong with it? It's crazy. I already installed the
> OCL and UML2 and still the same warning. And before this, it said that
> it has a problem with EMF.QUERY. Wait a minute... isn't EMF supposed
> to ALSO INSTALL QUERY? How can it ask for something it will install
> itself? It's pretty illogical. Maybe somebody has a clue about this.
>
> Thanks a lot in advance ::- D
>
Re: Installing EMF driving me NUTS [message #98693 is a reply to message #98678] Tue, 09 October 2007 06:31 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: axonnus.yahoo.com

Hi Eike. Thanks for answering. I think I'm going to do a clean re-install
of Eclipse. I think I mixed up a lot of things among all these versions
problems. How do you recommend installing EMF? From the update site? Or
using separate ZIP files?
Re: Installing EMF driving me NUTS [message #98707 is a reply to message #98693] Tue, 09 October 2007 07:14 Go to previous message
Eclipse UserFriend
Originally posted by: stepper.sympedia.de

Axonn Echysttas schrieb:
> Hi Eike. Thanks for answering. I think I'm going to do a clean
> re-install of Eclipse. I think I mixed up a lot of things among all
> these versions problems. How do you recommend installing EMF? From the
> update site? Or using separate ZIP files?
Oh, I forgot to mention the -clean thing. I always use that switch. It's
in my start link so that it even survives complete reinstalls of the
platform ;-)
I do't think it makes a big difference whether you use an update site or
a zip download given the bundles you need are contained.
I'm not sure if the SDK bundles (most complete features) are contained
in the update site but you will figure this out.

BTW this is the EMF Technology (EMFT) newsgroup where you are always
welcome but the EMF newsgoup seems a better place to ask EMF questions.

Cheers
/Eike
Re: Installing EMF driving me NUTS [message #609934 is a reply to message #98642] Mon, 08 October 2007 18:41 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6683
Registered: July 2009
Senior Member
Axxon,

Have you installed an EMF or not? If so, which version? You are not very
clear about that.
The error message (OCL 2.0 requires EMF 2.4) implies that you have to
install EMF 2.4.
So, have you done this?

And I don't think that the core EMF distribution is upposed to install
EMF.Query but I may be wrong.
Anyway, you can get it form
http://www.eclipse.org/modeling/emf/downloads/?project=query

Cheers
/Eike


Axonn Echysttas schrieb:
> Hi everybody. My first message here... oh wait, no, it's the second
> one, I also posted this in the newcommer area, sorry for that :;- ). I
> got a configuration problem with Eclipse which is driving me NUTS!!! I
> got the PDT incubation version of Eclipse and I installed on it the
> WTP for HTML/CSS and JSEclipse plugins. Now I'm trying to also add CDT
> for C++. But CDT requires EMF.query and UML2. I can't install UML2
> because I don't have EMF. I try to install EMF but...
>
> Object Constraint Language (OCL) 2.0
> (1.2.0.v200709262202-3309oA55P5R_F_DAU) requires plug-in
> "org.eclipse.emf.ecore (2.4.0)", or equivalent.
>
> I mean... what's wrong with it? It's crazy. I already installed the
> OCL and UML2 and still the same warning. And before this, it said that
> it has a problem with EMF.QUERY. Wait a minute... isn't EMF supposed
> to ALSO INSTALL QUERY? How can it ask for something it will install
> itself? It's pretty illogical. Maybe somebody has a clue about this.
>
> Thanks a lot in advance ::- D
>


Re: Installing EMF driving me NUTS [message #609935 is a reply to message #98678] Tue, 09 October 2007 06:31 Go to previous message
Eclipse UserFriend
Originally posted by: axonnus.yahoo.com

Hi Eike. Thanks for answering. I think I'm going to do a clean re-install
of Eclipse. I think I mixed up a lot of things among all these versions
problems. How do you recommend installing EMF? From the update site? Or
using separate ZIP files?
Re: Installing EMF driving me NUTS [message #609937 is a reply to message #98693] Tue, 09 October 2007 07:14 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6683
Registered: July 2009
Senior Member
Axonn Echysttas schrieb:
> Hi Eike. Thanks for answering. I think I'm going to do a clean
> re-install of Eclipse. I think I mixed up a lot of things among all
> these versions problems. How do you recommend installing EMF? From the
> update site? Or using separate ZIP files?
Oh, I forgot to mention the -clean thing. I always use that switch. It's
in my start link so that it even survives complete reinstalls of the
platform ;-)
I do't think it makes a big difference whether you use an update site or
a zip download given the bundles you need are contained.
I'm not sure if the SDK bundles (most complete features) are contained
in the update site but you will figure this out.

BTW this is the EMF Technology (EMFT) newsgroup where you are always
welcome but the EMF newsgoup seems a better place to ask EMF questions.

Cheers
/Eike


Previous Topic:Installing EMF driving me NUTS
Next Topic:[TENEO] Problem of mapping when inheritance hierarchy in a stored metamodel
Goto Forum:
  


Current Time: Sat May 18 00:35:25 GMT 2024

Powered by FUDForum. Page generated in 0.03248 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top