Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Problem running eclipse.exe(need help)
Problem running eclipse.exe [message #795318] Fri, 10 February 2012 10:24 Go to next message
Roar Malkenes is currently offline Roar MalkenesFriend
Messages: 2
Registered: February 2012
Junior Member
Hey

I just downloaded and unzipped eclipse 64-bit. (on my 64-bit Windows 7)
but when i ran the eclipse.exe, this showed up:
A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse. No Java virtual machine was found after searching the following locations:
D:\eclipse\jre\bin\javaw.exe
javaw.exe in your current PATH


So i tried copying the javaw.exe, java.exe and javaws.exe into the location D:\eclipse\jre\bin.

Then this showed up

JVM terminated. Exit code =-1
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx256m
-XX:MaxPermSize=256m
-Djava.class.path=D:\eclipse\plugings/org.eclipse.equinox.la uncher_1.0.201.R35x_v20090715.jar
-os win32
-ws win32
-arch x86
-showsplash
D:\eclipse\\plugins\org.eclipse.platform_3.3.201.v2009091708 00\splash.bmp
-launcher D:\elipse\eclipse.exe
-name Eclipse
--launcher.library
D:\eclipse\plugins/org.eclipse.equinox.launcher.win32.win32. x86_1.0.200.v20090519\eclipse_1206.dll
-startup
D:\eclipse\plugins/org.eclipse.equinox.launcher_1.0.201.R35x _v20090715.jar
-product org.eclipse.epp.package.java.product
-vm D:\eclipse\jre\bin\server\jvm.dll
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx256m
-XX:MaxPermSize=256m
-Djava.class.path=D:\eclipse\plugins/org.eclipse.equinox.lau ncher_1.0.201.R35x_v20090715.jar


Then i fiddeled with the running of the .exe (compability, admin...) but that didn't work either.

I searched online and found this topic: /forums/index.php/t/156521/
But downloading 32-bit didn't work either.

Any ideas?? Sad
Re: Problem running eclipse.exe [message #795333 is a reply to message #795318] Fri, 10 February 2012 10:40 Go to previous messageGo to next message
Roar Malkenes is currently offline Roar MalkenesFriend
Messages: 2
Registered: February 2012
Junior Member
Found a site telling me to create a shortcut to the eclipse.exe and add: -vm [The location of my java files] at the end of the shortcut.

This gave me the following message: Failed to load the JNI shared library "C:\Program Files\java\jre6\bin\client\jvm.dll"

Help me some1 Sad
Re: Problem running eclipse.exe [message #795427 is a reply to message #795333] Fri, 10 February 2012 13:15 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2012.02.10 3:40, Roar Malkenes wrote:
> Found a site telling me to create a shortcut to the eclipse.exe and add:
> -vm [The location of my java files] at the end of the shortcut.
>
> This gave me the following message: Failed to load the JNI shared
> library "C:\Program Files\java\jre6\bin\client\jvm.dll"
>
> Help me some1 :(

Don't copy Java files or make links. Simply follow the counsel here:

http://wiki.eclipse.org/Eclipse.ini
Previous Topic:some newbie's questions
Next Topic:One IDE for AVR, ARM and PIC?
Goto Forum:
  


Current Time: Sun Jul 25 20:23:26 GMT 2021

Powered by FUDForum. Page generated in 0.03070 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top