Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Break points are not breaking
Break points are not breaking [message #84120] Thu, 20 November 2008 17:28 Go to next message
Eclipse UserFriend
Originally posted by: mansour.own.net

I have been trying to install Zend debugger with PDT for few days, and
No where to go but to ask someone here. I am running gentoo 64 with
eclipse 3.4. However, I still can not get the break points to stop when
debugging php files. I don't know what other information is required,
however, here's my /etc/php/apache2-php5/ext-active/zend.ini

[Zend]
zend_extension_ts=/usr/lib64/php5/lib/php/extensions/no-debu g-zts-20060613/ZendDebugger.so
zend_debugger.allow_hosts=127.0.0.1, 192.168.1.100
zend_debugger.expose_remotely=always


I have setup apache2 to server from USERDIR. I can the pages when I
debug from eclipse, but no break points are stopping.

In eclipse> prefrences > PHP > zend debugger settings:
debug port: 10000
client/host IP: 192.168.1.100,127.0.0.1

PHP > php executables:
One executable /usr/lib64/php5/bin/php
php inifile: /etc/php/apache2-php5/php.ini
php debugger: Zend Debugger

PHP > PHP servers:
url that points to the document root of this server:
http://localhost/~mansour
Path mapping- on the server: /
Path mapping - in workspace /my-php-project


If there's any missing info please ask.

Thank you.
Re: Break points are not breaking [message #84134 is a reply to message #84120] Thu, 20 November 2008 19:49 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: michael.zend.com

"Mansour" <mansour@own.net> wrote in message
news:gg46pj$444$1@build.eclipse.org...
<skipped>
> PHP > PHP servers:
> url that points to the document root of this server:
> http://localhost/~mansour
> Path mapping- on the server: /

This must be a full path on the server, not an URL path. Where is your
document root located?
If it's /var/www, for example, the path should be /var/www/your_project.
Re: Break points are not breaking [message #84148 is a reply to message #84134] Thu, 20 November 2008 20:21 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mansour.own.net

Michael Spector wrote:
> "Mansour" <mansour@own.net> wrote in message
> news:gg46pj$444$1@build.eclipse.org...
> <skipped>
>> PHP > PHP servers:
>> url that points to the document root of this server:
>> http://localhost/~mansour
>> Path mapping- on the server: /
>
> This must be a full path on the server, not an URL path. Where is your
> document root located?
> If it's /var/www, for example, the path should be /var/www/your_project.
>
>

What do u mean ? I have my project in /home/mansour/public_html as I
don't have write access to /var/www/. Do I need to modify this access ?
Further more, I found that the command php -m is not showing Zend
debugger installed. I have posted already to the zend forum and waiting
for response. I will see how things will go, and then will move from
there, as this has to be fixed before I continue to set it up with eclipse.
Re: Break points are not breaking [message #84162 is a reply to message #84134] Thu, 20 November 2008 20:23 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mansour.own.net

Michael Spector wrote:
> "Mansour" <mansour@own.net> wrote in message
> news:gg46pj$444$1@build.eclipse.org...
> <skipped>
>> PHP > PHP servers:
>> url that points to the document root of this server:
>> http://localhost/~mansour
>> Path mapping- on the server: /
>
> This must be a full path on the server, not an URL path. Where is your
> document root located?
> If it's /var/www, for example, the path should be /var/www/your_project.
>
>

What do u mean ? I have my project in /home/mansour/public_html as I
don't have write access to /var/www/. Do I need to modify this access ?
Further more, I found that the command php -m is not showing Zend
debugger installed. I have posted already to the zend forum and waiting
for response. I will see how things will go, and then will move from
there, as this has to be fixed before I continue to set it up with eclipse.
Re: Break points are not breaking [message #84178 is a reply to message #84134] Thu, 20 November 2008 20:24 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mansour.own.net

Michael Spector wrote:
> "Mansour" <mansour@own.net> wrote in message
> news:gg46pj$444$1@build.eclipse.org...
> <skipped>
>> PHP > PHP servers:
>> url that points to the document root of this server:
>> http://localhost/~mansour
>> Path mapping- on the server: /
>
> This must be a full path on the server, not an URL path. Where is your
> document root located?
> If it's /var/www, for example, the path should be /var/www/your_project.
>
>

What do u mean ? I have my project in /home/mansour/public_html as I
don't have write access to /var/www/. Do I need to modify this access ?
Further more, I found that the command php -m is not showing Zend
debugger installed. I have posted already to the zend forum and waiting
for response. I will see how things will go, and then will move from
there, as this has to be fixed before I continue to set it up with eclipse.
Re: Break points are not breaking [message #84607 is a reply to message #84178] Sun, 23 November 2008 18:20 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mansour.alakeel.gmail.com

Ok, I have reinstalled xdebug, and gave up on Zend.
I am using gentoo 64. Now, with xdebug things seems to be better as I
can debug a script but not a web page. Here's my configuration. Apache
supports user directory, so I have access to /home/mansour/public_html.
In fact I created a workspace for eclipse in /home/mansour/public_html.
So basically, this is my document root. I have created a test project,
called Project. And for the PDT:

xdebug is the default debugger at port 9000, Under the executable
section, I have only one executable:

path: /usr/lib64/php5/bin/php
debugger: xdebug

URL pointing to doc root for this server: http://localhost/~mansour
Path mapping:
/home/mansour/public_html --> /
/home/mansour/public_html/Project --> /Project (in WorkSpace)

When I click "debug as web page" on the index.php which is in the root
directory of the project, It shows
"http://localhost/~mansour/Project/index.php" which is the correct URL.
However, launching sits there showing that it's at 19% for ever, and
waiting for xDebug session.

Further more I can not find any logs or messages, which makes the issue
little bit frustrating.

I will appreciate any help to get this resolved.





Mansour wrote:
> Michael Spector wrote:
>> "Mansour" <mansour@own.net> wrote in message
>> news:gg46pj$444$1@build.eclipse.org...
>> <skipped>
>>> PHP > PHP servers:
>>> url that points to the document root of this server:
>>> http://localhost/~mansour
>>> Path mapping- on the server: /
>> This must be a full path on the server, not an URL path. Where is your
>> document root located?
>> If it's /var/www, for example, the path should be /var/www/your_project.
>>
>>
>
> What do u mean ? I have my project in /home/mansour/public_html as I
> don't have write access to /var/www/. Do I need to modify this access ?
> Further more, I found that the command php -m is not showing Zend
> debugger installed. I have posted already to the zend forum and waiting
> for response. I will see how things will go, and then will move from
> there, as this has to be fixed before I continue to set it up with eclipse.
>
Re: Break points are not breaking [message #84610 is a reply to message #84607] Mon, 24 November 2008 01:08 Go to previous messageGo to next message
David Muir is currently offline David MuirFriend
Messages: 63
Registered: July 2009
Member
Probably because you have it set to break at first line. Check to see if
you can step through the debugger.


Mansour wrote:

> Ok, I have reinstalled xdebug, and gave up on Zend.
> I am using gentoo 64. Now, with xdebug things seems to be better as I
> can debug a script but not a web page. Here's my configuration. Apache
> supports user directory, so I have access to /home/mansour/public_html.
> In fact I created a workspace for eclipse in /home/mansour/public_html.
> So basically, this is my document root. I have created a test project,
> called Project. And for the PDT:

> xdebug is the default debugger at port 9000, Under the executable
> section, I have only one executable:

> path: /usr/lib64/php5/bin/php
> debugger: xdebug

> URL pointing to doc root for this server: http://localhost/~mansour
> Path mapping:
> /home/mansour/public_html --> /
> /home/mansour/public_html/Project --> /Project (in WorkSpace)

> When I click "debug as web page" on the index.php which is in the root
> directory of the project, It shows
> "http://localhost/~mansour/Project/index.php" which is the correct URL.
> However, launching sits there showing that it's at 19% for ever, and
> waiting for xDebug session.

> Further more I can not find any logs or messages, which makes the issue
> little bit frustrating.

> I will appreciate any help to get this resolved.
Re: Break points are not breaking [message #84618 is a reply to message #84610] Mon, 24 November 2008 01:32 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mansour.alakeel.gmail.com

I unchecked the "Break at first line" option, and tried, but still no
progress.



David Muir wrote:
> Probably because you have it set to break at first line. Check to see if
> you can step through the debugger.
>
>
> Mansour wrote:
>
>> Ok, I have reinstalled xdebug, and gave up on Zend.
>> I am using gentoo 64. Now, with xdebug things seems to be better as I
>> can debug a script but not a web page. Here's my configuration. Apache
>> supports user directory, so I have access to /home/mansour/public_html.
>> In fact I created a workspace for eclipse in /home/mansour/public_html.
>> So basically, this is my document root. I have created a test project,
>> called Project. And for the PDT:
>
>> xdebug is the default debugger at port 9000, Under the executable
>> section, I have only one executable:
>
>> path: /usr/lib64/php5/bin/php
>> debugger: xdebug
>
>> URL pointing to doc root for this server: http://localhost/~mansour
>> Path mapping:
>> /home/mansour/public_html --> /
>> /home/mansour/public_html/Project --> /Project (in WorkSpace)
>
>> When I click "debug as web page" on the index.php which is in the root
>> directory of the project, It shows
>> "http://localhost/~mansour/Project/index.php" which is the correct
>> URL. However, launching sits there showing that it's at 19% for ever,
>> and waiting for xDebug session.
>
>> Further more I can not find any logs or messages, which makes the
>> issue little bit frustrating.
>
>> I will appreciate any help to get this resolved.
>
Re: Break points are not breaking [message #84624 is a reply to message #84607] Mon, 24 November 2008 03:22 Go to previous messageGo to next message
Shawn Clark is currently offline Shawn ClarkFriend
Messages: 70
Registered: July 2009
Member
Mansour,

When debugging I have seen this occur when I have not setup my "PHP Web
Page" server settings properly within Eclipse Debug Configuration. The
19% is when Eclipse has done everything it can to start a debug session
and is waiting to hear back from Xdebug. Eclipse starts the session up
but won't actually do anything more until a filepath / line number
matches with what the path mappings have for the page settings.

From your notes I don't see you ever going in and checking the PHP
server configuration within the Debug Configuration. If you click on the
down arrow beside the debug icon you will see a option to open up the
Debug Configurations. Within there under "PHP Web Page" check what
settings are for your site. Main thing to check is the PHP Server
setting within the server tab. If it is set to "Default PHP Web Server"
then that is the one for localhost. Use the configure button and make
sure the path mapping settings are correct. They have to be absolute
paths so the path on server should have something like
"home/mansour/public_html/Project" and the path in workspace should just
be a selection of that project.

Once that is all setup then you should be able to debug your page. Have
it so that it IS breaking at the first line so that you are able to make
sure that it is starting a debug session. Once you have that confirmed
then you can remove the "break at first line" and setup other breakpoints.

--
Shawn Clark

Mansour wrote:
> Ok, I have reinstalled xdebug, and gave up on Zend.
> I am using gentoo 64. Now, with xdebug things seems to be better as I
> can debug a script but not a web page. Here's my configuration. Apache
> supports user directory, so I have access to /home/mansour/public_html.
> In fact I created a workspace for eclipse in /home/mansour/public_html.
> So basically, this is my document root. I have created a test project,
> called Project. And for the PDT:
>
> xdebug is the default debugger at port 9000, Under the executable
> section, I have only one executable:
>
> path: /usr/lib64/php5/bin/php
> debugger: xdebug
>
> URL pointing to doc root for this server: http://localhost/~mansour
> Path mapping:
> /home/mansour/public_html --> /
> /home/mansour/public_html/Project --> /Project (in WorkSpace)
>
> When I click "debug as web page" on the index.php which is in the root
> directory of the project, It shows
> "http://localhost/~mansour/Project/index.php" which is the correct URL.
> However, launching sits there showing that it's at 19% for ever, and
> waiting for xDebug session.
>
> Further more I can not find any logs or messages, which makes the issue
> little bit frustrating.
>
> I will appreciate any help to get this resolved.
>
>
>
>
>
> Mansour wrote:
>> Michael Spector wrote:
>>> "Mansour" <mansour@own.net> wrote in message
>>> news:gg46pj$444$1@build.eclipse.org...
>>> <skipped>
>>>> PHP > PHP servers:
>>>> url that points to the document root of this server:
>>>> http://localhost/~mansour
>>>> Path mapping- on the server: /
>>> This must be a full path on the server, not an URL path. Where is
>>> your document root located?
>>> If it's /var/www, for example, the path should be /var/www/your_project.
>>>
>>
>> What do u mean ? I have my project in /home/mansour/public_html as I
>> don't have write access to /var/www/. Do I need to modify this access ?
>> Further more, I found that the command php -m is not showing Zend
>> debugger installed. I have posted already to the zend forum and waiting
>> for response. I will see how things will go, and then will move from
>> there, as this has to be fixed before I continue to set it up with
>> eclipse.
>>
Re: Break points are not breaking [message #84654 is a reply to message #84624] Mon, 24 November 2008 17:25 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mansour.alakeel.gmail.com

Shawn,Thank you.

I have tried everything, and nothing seems to be working for me. I
understand that the mapping has to be absolute, and that's what I have.

Here's screenshots for my config:

http://img152.imageshack.us/img152/9427/screenshot1en0.png
http://img219.imageshack.us/img219/1281/screenshot2bj5.png

Do you have any advice ?




Shawn Clark wrote:
> Mansour,
>
> When debugging I have seen this occur when I have not setup my "PHP Web
> Page" server settings properly within Eclipse Debug Configuration. The
> 19% is when Eclipse has done everything it can to start a debug session
> and is waiting to hear back from Xdebug. Eclipse starts the session up
> but won't actually do anything more until a filepath / line number
> matches with what the path mappings have for the page settings.
>
> From your notes I don't see you ever going in and checking the PHP
> server configuration within the Debug Configuration. If you click on the
> down arrow beside the debug icon you will see a option to open up the
> Debug Configurations. Within there under "PHP Web Page" check what
> settings are for your site. Main thing to check is the PHP Server
> setting within the server tab. If it is set to "Default PHP Web Server"
> then that is the one for localhost. Use the configure button and make
> sure the path mapping settings are correct. They have to be absolute
> paths so the path on server should have something like
> "home/mansour/public_html/Project" and the path in workspace should just
> be a selection of that project.
>
> Once that is all setup then you should be able to debug your page. Have
> it so that it IS breaking at the first line so that you are able to make
> sure that it is starting a debug session. Once you have that confirmed
> then you can remove the "break at first line" and setup other breakpoints.
>
> --
> Shawn Clark
>
Re: Break points are not breaking [message #84665 is a reply to message #84654] Mon, 24 November 2008 17:50 Go to previous messageGo to next message
D Kelsey is currently offline D KelseyFriend
Messages: 232
Registered: July 2009
Senior Member
Given that eclipse is showing 19% implies to me that xdebug cannot contact your PDT setup or xdebug
doesn't load or attempt to initiate a session.

so it would be worth doing the following
1. write a little script that runs phpinfo() and invoke it from your browser. That will tell you if
xdebug is loaded on your server and what the settings are (suggest you post it here too along with
your php.ini entries for xdebug).

2. generate an xdebug log by adding an entry
xdebug.remote_log=c:\xdebug.log
(replace c:\xdebug.log with something appropriate for your system and operation system).
and post the log.

3. check the ports match 9000 on your server with 9000 on your PDT system and ensure that no
firewall is blocking that port.

I think you can probably delete the path mapping entry you have specified, if necessary in your case
PDT should work it out automatically.

Dave Kelsey

Mansour wrote:
> Shawn,Thank you.
>
> I have tried everything, and nothing seems to be working for me. I
> understand that the mapping has to be absolute, and that's what I have.
>
> Here's screenshots for my config:
>
> http://img152.imageshack.us/img152/9427/screenshot1en0.png
> http://img219.imageshack.us/img219/1281/screenshot2bj5.png
>
> Do you have any advice ?
>
>
>
>
> Shawn Clark wrote:
>> Mansour,
>>
>> When debugging I have seen this occur when I have not setup my "PHP
>> Web Page" server settings properly within Eclipse Debug Configuration.
>> The 19% is when Eclipse has done everything it can to start a debug
>> session and is waiting to hear back from Xdebug. Eclipse starts the
>> session up but won't actually do anything more until a filepath / line
>> number matches with what the path mappings have for the page settings.
>>
>> From your notes I don't see you ever going in and checking the PHP
>> server configuration within the Debug Configuration. If you click on
>> the down arrow beside the debug icon you will see a option to open up
>> the Debug Configurations. Within there under "PHP Web Page" check what
>> settings are for your site. Main thing to check is the PHP Server
>> setting within the server tab. If it is set to "Default PHP Web
>> Server" then that is the one for localhost. Use the configure button
>> and make sure the path mapping settings are correct. They have to be
>> absolute paths so the path on server should have something like
>> "home/mansour/public_html/Project" and the path in workspace should
>> just be a selection of that project.
>>
>> Once that is all setup then you should be able to debug your page.
>> Have it so that it IS breaking at the first line so that you are able
>> to make sure that it is starting a debug session. Once you have that
>> confirmed then you can remove the "break at first line" and setup
>> other breakpoints.
>>
>> --
>> Shawn Clark
>>
Re: Break points are not breaking [message #84707 is a reply to message #84665] Mon, 24 November 2008 19:28 Go to previous message
Eclipse UserFriend
Originally posted by: mansour.alakeel.gmail.com

It''s working now. Here's the modification I did to xdebug.ini:

mars ext # diff xdebug.ini xdebug.ini.defualt
2c2
< xdebug.auto_trace="1"
---
> xdebug.auto_trace="0"
29c29
< xdebug.profiler_enable="1"
---
> xdebug.profiler_enable="0"
33c33
< xdebug.profiler_append="1"
---
> xdebug.profiler_append="0"
35c35
< xdebug.remote_enable="true"
---
> xdebug.remote_enable="0"
41c41
< xdebug.remote_log="/var/log/apache2/xdebug.log"
---
> xdebug.remote_log=""

I don't know exactly which option got it to work, however I can debug
now web pages. The log file is not showing anything, but that's fine.
The file xdebug.ini.default is a back up copy of the default values when
you install Xdebug through gentoo portage.

I removed the server mapping as well like Dave suggested.

Thank you all. I really appreciate everyones help.

Dave Kelsey wrote:
> Given that eclipse is showing 19% implies to me that xdebug cannot
> contact your PDT setup or xdebug doesn't load or attempt to initiate a
> session.
>
> so it would be worth doing the following
> 1. write a little script that runs phpinfo() and invoke it from your
> browser. That will tell you if xdebug is loaded on your server and what
> the settings are (suggest you post it here too along with your php.ini
> entries for xdebug).
>
> 2. generate an xdebug log by adding an entry
> xdebug.remote_log=c:\xdebug.log
> (replace c:\xdebug.log with something appropriate for your system and
> operation system).
> and post the log.
>
> 3. check the ports match 9000 on your server with 9000 on your PDT
> system and ensure that no firewall is blocking that port.
>
> I think you can probably delete the path mapping entry you have
> specified, if necessary in your case PDT should work it out automatically.
>
> Dave Kelsey
>
> Mansour wrote:
>> Shawn,Thank you.
>>
>> I have tried everything, and nothing seems to be working for me. I
>> understand that the mapping has to be absolute, and that's what I have.
>>
>> Here's screenshots for my config:
>>
>> http://img152.imageshack.us/img152/9427/screenshot1en0.png
>> http://img219.imageshack.us/img219/1281/screenshot2bj5.png
>>
>> Do you have any advice ?
>>
>>
>>
>>
>> Shawn Clark wrote:
>>> Mansour,
>>>
>>> When debugging I have seen this occur when I have not setup my "PHP
>>> Web Page" server settings properly within Eclipse Debug
>>> Configuration. The 19% is when Eclipse has done everything it can to
>>> start a debug session and is waiting to hear back from Xdebug.
>>> Eclipse starts the session up but won't actually do anything more
>>> until a filepath / line number matches with what the path mappings
>>> have for the page settings.
>>>
>>> From your notes I don't see you ever going in and checking the PHP
>>> server configuration within the Debug Configuration. If you click on
>>> the down arrow beside the debug icon you will see a option to open up
>>> the Debug Configurations. Within there under "PHP Web Page" check
>>> what settings are for your site. Main thing to check is the PHP
>>> Server setting within the server tab. If it is set to "Default PHP
>>> Web Server" then that is the one for localhost. Use the configure
>>> button and make sure the path mapping settings are correct. They have
>>> to be absolute paths so the path on server should have something like
>>> "home/mansour/public_html/Project" and the path in workspace should
>>> just be a selection of that project.
>>>
>>> Once that is all setup then you should be able to debug your page.
>>> Have it so that it IS breaking at the first line so that you are able
>>> to make sure that it is starting a debug session. Once you have that
>>> confirmed then you can remove the "break at first line" and setup
>>> other breakpoints.
>>>
>>> --
>>> Shawn Clark
>>>
Previous Topic:Templates not working on PDT 2.0
Next Topic:Why there's no all-in-one package for M2
Goto Forum:
  


Current Time: Tue Mar 21 11:01:24 GMT 2023

Powered by FUDForum. Page generated in 0.02392 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top