Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » Cannot Find model UML
Cannot Find model UML [message #73896] Wed, 30 January 2008 12:10 Go to next message
Eclipse UserFriend
Originally posted by:

I'm trying to write a transformation from a UML model to a UML model.
This is the simple rule that I've written:

module UML2UML; -- Module Template
create OUT : UML2 from IN : UML2;

rule ModeltoModel{
i: UML!Model
o: UML!Model(
name <-

In the Run configuration I've setted UML2 like "Is Metamodel" and the
Model Handler is UML2. When I run the transformation I get in the ATL
console a message "Cannot Find model UML". I've tried to chenge the model
Handler from UML2 to EMF but nothing.
Where is the mistake?

Thank you

Re: Cannot Find model UML [message #73914 is a reply to message #73896] Wed, 30 January 2008 12:55 Go to previous message
Eclipse UserFriend
Originally posted by:

I've fixed the error. The problem was inside the code: I've wrote
UM2!Model instead of UML2!Model

Thank you anyway

Previous Topic:[ATL] Text wrapped in tags
Next Topic:[ATL] atl transf. from Java code
Goto Forum:

Current Time: Fri Sep 30 12:20:29 GMT 2022

Powered by FUDForum. Page generated in 0.01966 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top