Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » ToolBar and Item (default) Selection(Unwanted behavoiour RCP vs RAP)
ToolBar and Item (default) Selection [message #657123] Tue, 01 March 2011 16:33 Go to next message
Jens Kreidler is currently offline Jens KreidlerFriend
Messages: 17
Registered: July 2009
Junior Member
Hi Community,

i 'vs got an issue concerning ToolItems in a single-sourced environment.
Projects (for both RCP and RAP) are provided as attachment.

Short description:

There is a ToolBar with two IActions (manifested as ToolItems via the jface ToolBarManager-API), between these two items is a ControlContribution that displays a swt-Text widget.

The right item outputs the text in a label currently visible/entered in the textfield.
The left item resets the output.

In RCP, everything acts a wanted.
In RAP, do the following:
1- Start the ToolItems_Test rap application (accessible via "/rap?startup=ToolItem_Test.app")
2- Click left into the Text field
3- Enter any string and press return
4- Click left on 'Reset'
5- Click left into the Text field again
6- Enter any string and press return

=> you 'll see that the "action" *and* the reset-action occurs (?)
You 'll also see that the reset action is "pushed", so somehow in rap the ToolBar respectively the reset - ToolItem reacts on the return command.

Download mini-projects rcp/rap from bugzilla:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=338639
(tested against RAP 1.4M5 (from 4th Feb 2011))

Any hint or help is appreciated

[Updated on: Wed, 02 March 2011 10:27]

Report message to a moderator

Re: ToolBar and Item (default) Selection [message #657265 is a reply to message #657123] Wed, 02 March 2011 09:06 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Jens,
if your code works fine in RAP, but RAP, it's probably a bug in RAP.
Please file a bugzilla with the projects attached to the bug. Please
specify the RAP version used. There is a small chance that this problem
is fixed by the update of JFace/Workbench to current 3.7 code base (we
did this in 1.4 M5). Is it possible to test your project with 1.4M5 (or
CVS HEAD)?
Best,
Ivan

On 3/1/2011 6:33 PM, Jens Kreidler wrote:
> Hi Community,
>
> i 'vs got an issue concerning ToolItems in a single-sourced
> environment. Projects (for both RCP and RAP) are provided as attachment.
>
> Short description:
>
> There is a ToolBar with two IActions (manifested as ToolItems via the
> jface ToolBarManager-API), between these two items is a
> ControlContribution that displays a swt-Text widget.
>
> The right item outputs the text in a label currently visible/entered
> in the textfield.
> The left item resets the output.
>
> In RCP, everything acts a wanted.
> In RAP, do the following:
> 1- Start the ToolItems_Test rap application (accessible via
> "/rap?startup=ToolItem_Test.app")
> 2- Click left into the Text field
> 3- Enter any string and press return
> 4- Click left on 'Reset'
> 5- Click left into the Text field again
> 6- Enter any string and press return
>
> => you 'll see that the "action" *and* the reset-action occurs (?) You
> 'll also see that the reset action is "pushed", so somehow in rap the
> ToolBar respectively the reset - ToolItem reacts on the return command.
>
> Any hint or help is appreciated
Re: ToolBar and Item (default) Selection [message #657279 is a reply to message #657265] Wed, 02 March 2011 10:27 Go to previous message
Jens Kreidler is currently offline Jens KreidlerFriend
Messages: 17
Registered: July 2009
Junior Member
Thanks Ivan for quickly looking over this. It was already tested against rap 1.4M5.
I'vs filed a bugzilla here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=338639
and added the attachments for both RCP and RAP

[Updated on: Wed, 02 March 2011 10:28]

Report message to a moderator

Previous Topic:Server Side Requirements
Next Topic:[Table] Scrolling issue
Goto Forum:
  


Current Time: Sun Nov 28 23:56:06 GMT 2021

Powered by FUDForum. Page generated in 0.02139 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top