Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Deleting a launch configuration doesnt clean up the file system data
Deleting a launch configuration doesnt clean up the file system data [message #64466] Wed, 10 June 2009 08:25 Go to next message
Praveen Kumar V is currently offline Praveen Kumar VFriend
Messages: 4
Registered: July 2009
Junior Member
In the eclipse PDE, perform the following steps

1) Click on Run -> Run Configurations
2) Create a new Eclipse Application Launcher
3) A new Launch Configuration is created with the name "New Configuration"
4) Use the default values and launch the configuration
5) A new eclipse application launches successfully
6) Close the application and delete the launch configuration "New
Configuration" by right clicking on the configuration and select delete.
7) The launch configuration gets deleted from "Run Configurations" window.
But the associated file system data does not get cleaned up.

Is this behavior of eclipse intentional or is this a defect?

Awaiting Response. Thanks in Advance.
Re: Deleting a launch configuration doesnt clean up the file system data [message #64513 is a reply to message #64466] Wed, 10 June 2009 09:19 Go to previous messageGo to next message
Prakash G.R. is currently offline Prakash G.R.Friend
Messages: 621
Registered: July 2009
Senior Member
Praveen Kumar V wrote:
> 7) The launch configuration gets deleted from "Run Configurations"
> window. But the associated file system data does not get cleaned up.
> Is this behavior of eclipse intentional or is this a defect?

There can be multiple launch configurations associated with one
runtime workspace. So isn't the current behaviour the expected one?

- Prakash

---
http://blog.eclipse-tips.com
Re: Deleting a launch configuration doesnt clean up the file system data [message #64653 is a reply to message #64513] Thu, 11 June 2009 06:27 Go to previous message
Praveen Kumar V is currently offline Praveen Kumar VFriend
Messages: 4
Registered: July 2009
Junior Member
Prakash,

Its true that there can be multiple launch configuration for a single
workspace. But the issue here is when you delete a launch configuration in
the UI (PDE), then the associated configuration data in the file system is
not getting cleaned up.
Re: Deleting a launch configuration doesnt clean up the file system data [message #598212 is a reply to message #64466] Wed, 10 June 2009 09:19 Go to previous message
Prakash G.R. is currently offline Prakash G.R.Friend
Messages: 621
Registered: July 2009
Senior Member
Praveen Kumar V wrote:
> 7) The launch configuration gets deleted from "Run Configurations"
> window. But the associated file system data does not get cleaned up.
> Is this behavior of eclipse intentional or is this a defect?

There can be multiple launch configurations associated with one
runtime workspace. So isn't the current behaviour the expected one?

- Prakash

---
http://blog.eclipse-tips.com
Re: Deleting a launch configuration doesnt clean up the file system data [message #598258 is a reply to message #64513] Thu, 11 June 2009 06:27 Go to previous message
Praveen Kumar V is currently offline Praveen Kumar VFriend
Messages: 4
Registered: July 2009
Junior Member
Prakash,

Its true that there can be multiple launch configuration for a single
workspace. But the issue here is when you delete a launch configuration in
the UI (PDE), then the associated configuration data in the file system is
not getting cleaned up.
Previous Topic:Target Pltatform Based On Update Site
Next Topic:Target Pltatform Based On Update Site
Goto Forum:
  


Current Time: Mon Aug 02 10:31:23 GMT 2021

Powered by FUDForum. Page generated in 0.02430 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top