Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Errors while integrating CDT wit RCP app(NullPointerExceptions and SWTException )
Errors while integrating CDT wit RCP app [message #552530] Thu, 12 August 2010 14:18 Go to next message
vrush Mising nameFriend
Messages: 51
Registered: July 2009
Location: Pune

I'm trying to bundle CDT along with my RCP app. RCP app runs perfectly fine when executed through IDE but fails when executed as product i.e. it throws null pointers and SWT exceptions and so on which I don't see when i run my RCP app through IDE.
As far as the RCP app is concerned, it works fine in both the cases, executed using ide or as product. But when executed as a product, CDT never works. Even if right click in Project Explorer throws SWT and NullPointer exceptions.

I have tried following things,
- handled dependencies
- validated
- have not made any change in CDT code

And here is the stack trace,

org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
at org.eclipse.swt.SWT.error(
at org.eclipse.swt.SWT.error(
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3527)
at org.eclipse.swt.widgets.Display.readAndDispatch( :3174)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2629)
at org.eclipse.ui.internal.Workbench.runUI(
at org.eclipse.ui.internal.Workbench.access$4( 27)
at org.eclipse.ui.internal.Workbench$
at org.eclipse.core.databinding.observable.Realm.runWithDefault (
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at com.apm.vhp.mamba.Application.start(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe
at java.lang.reflect.Method.invoke(
at org.eclipse.equinox.launcher.Main.invokeFramework( 619)
at org.eclipse.equinox.launcher.Main.basicRun(
at org.eclipse.equinox.launcher.Main.main(
Caused by: java.lang.NullPointerException
at a:271)
at org.eclipse.jface.viewers.TreePathViewerSorter$
at java.util.Arrays.mergeSort(
at java.util.Arrays.sort(
at org.eclipse.jface.viewers.TreePathViewerSorter.sort(TreePath
at org.eclipse.jface.viewers.AbstractTreeViewer.getSortedChildr en(
at org.eclipse.jface.viewers.AbstractTreeViewer$
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:70)
at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(
at org.eclipse.jface.viewers.TreeViewer.createChildren(TreeView
at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(
at org.eclipse.jface.viewers.AbstractTreeViewer.internalInitial izeTree(
at org.eclipse.jface.viewers.TreeViewer.internalInitializeTree(
at org.eclipse.jface.viewers.AbstractTreeViewer$
at org.eclipse.jface.viewers.StructuredViewer.preservingSelecti on(
at org.eclipse.jface.viewers.TreeViewer.preservingSelection(Tre
at org.eclipse.jface.viewers.StructuredViewer.preservingSelecti on(
at org.eclipse.jface.viewers.AbstractTreeViewer.inputChanged(Ab
at org.eclipse.jface.viewers.ContentViewer.setInput(ContentView
at org.eclipse.jface.viewers.StructuredViewer.setInput(Structur
at org.eclipse.ui.internal.navigator.resources.actions.WorkingS etActionProvider.setWorkingSet( :308)
at org.eclipse.ui.internal.navigator.resources.actions.WorkingS etActionProvider$3.propertyChange(WorkingSetActionProvider.j ava:223)
at org.eclipse.ui.internal.navigator.extensions.ExtensionStateM odel.firePropertyChangeEvent(
at org.eclipse.ui.internal.navigator.extensions.ExtensionStateM odel.setBooleanProperty(
at org.eclipse.ui.internal.navigator.resources.actions.WorkingS etActionProvider$
at 5)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr
... 23 more

Am I missing anything here?
Please provide some pointers. Stuck badly. Any help would be great.

Thanks in advance,
Re: Errors while integrating CDT wit RCP app [message #552570 is a reply to message #552530] Thu, 12 August 2010 16:23 Go to previous message
Francis Upton IV is currently offline Francis Upton IVFriend
Messages: 472
Registered: July 2009
Location: Oakland, CA
Senior Member
I would look at the CDT source code and figure out why they are having an NPE there.

Maybe post this on the CDT newsgroup.

It could be that they are doing something to depend on the ProjectExplorer which it likely not present in your RCP app.

One open would be just to create the ProjectExplorer in your RCP app. You can look at the code and configuration in org.eclipse.ui.navigator.resources (in fact if you just include the plugin you should just get it).

Previous Topic:Help with the Project Explorer View
Next Topic:[Databinding] Dynamic UI
Goto Forum:

Current Time: Wed Nov 30 03:15:49 GMT 2022

Powered by FUDForum. Page generated in 0.02521 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top