Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Can't layout polygons(Figures defined as polygons don't seem to obey the layouts)
Can't layout polygons [message #550758] Wed, 04 August 2010 09:28
Arto Jarvinen is currently offline Arto JarvinenFriend
Messages: 32
Registered: May 2010
Location: Sweden
Member
I'm experimenting with my first GMF project and trying to create an figure that has the same layout as the "actor" figure in the GMF tutorial part 3 but with a centered label at the bottom. This has proven very hard. Using the grid layout I can use (at least) ellipses and rectangles and a label and get my desired layout. But when I throw in a polygon, I get a totally different behavior. There are more details on my blog (see signature) but essentially my question is: are polygons supposed to be treated differently from other more basic geometric shapes when it comes to layout (and why in that case) or is this a bug that may be fixed in the future? Any work-around hints would also be welcome. Thanks! -A
Edit: I'm using the DSL Toolkit "distribution" of Eclipse (Version: 1.0.0, Build id: 20090703-0844)


[Updated on: Thu, 05 August 2010 11:25]

Report message to a moderator

Previous Topic:problem about duplication function
Next Topic:GMF wizards and non containment references
Goto Forum:
  


Current Time: Fri Jun 14 10:31:37 GMT 2024

Powered by FUDForum. Page generated in 0.04296 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top