Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Export plugin build problem
Export plugin build problem [message #43318] Fri, 30 January 2009 15:22 Go to next message
Mikael Petterson is currently offline Mikael PettersonFriend
Messages: 157
Registered: July 2009
Senior Member
Hi,

I am trying to export my feature. The problem I have is I added a test
package and when I export I cannot build since the test libraries ( junit
and jmock) are not included or the test dir is in the build. When I
compile the project in Eclipse it is fine.
I suppose that I have to do something in my plugin.xml? Do I filter out
the test directory or do I have to add the libs somewhere to get this
working?
I am using Eclipse 3.4.0 on Windows.

cheers,

//mike
Re: Export plugin build problem [message #43350 is a reply to message #43318] Fri, 30 January 2009 16:28 Go to previous messageGo to next message
Chris Aniszczyk is currently offline Chris AniszczykFriend
Messages: 674
Registered: July 2009
Senior Member
Mikael Petterson wrote:
> Hi,
>
> I am trying to export my feature. The problem I have is I added a test
> package and when I export I cannot build since the test libraries (
> junit and jmock) are not included or the test dir is in the build. When
> I compile the project in Eclipse it is fine.
> I suppose that I have to do something in my plugin.xml? Do I filter out
> the test directory or do I have to add the libs somewhere to get this
> working?
> I am using Eclipse 3.4.0 on Windows.

How are you including Junit / Jmock? Are they plug-ins somewhere in your
target? Or are you including the library and listing it on your
Bundle-ClassPath?

Cheers,

~ Chris
Re: Export plugin build problem [message #43376 is a reply to message #43318] Sat, 31 January 2009 12:47 Go to previous messageGo to next message
Andreas Goetz is currently offline Andreas GoetzFriend
Messages: 110
Registered: July 2009
Senior Member
I've seen certain test folder excluded from copying in build.xml. This
should work as long as the junit plugin dependency is optional and the
excluded folders are not mentioned in the classpath (i.e. reside unser
../src instead of their own ./test).

Cheers,
Andi
Re: Export plugin build problem [message #43536 is a reply to message #43350] Mon, 02 February 2009 06:29 Go to previous messageGo to next message
Mikael Petterson is currently offline Mikael PettersonFriend
Messages: 157
Registered: July 2009
Senior Member
Hi,

I only need these for testing. The junit and jmock are added to the
classpath in my project. I have not added them anywhere else.

//mikael
Re: Export plugin build problem [message #44994 is a reply to message #43536] Wed, 04 February 2009 20:30 Go to previous message
Andreas Goetz is currently offline Andreas GoetzFriend
Messages: 110
Registered: July 2009
Senior Member
Did you see my comment? Seems to solve your issue?

On 02.02.2009 07:29, Mikael Petterson wrote:
> Hi,
>
> I only need these for testing. The junit and jmock are added to the
> classpath in my project. I have not added them anywhere else.
>
> //mikael
>
Re: Export plugin build problem [message #590841 is a reply to message #43318] Fri, 30 January 2009 16:28 Go to previous message
Chris Aniszczyk is currently offline Chris AniszczykFriend
Messages: 674
Registered: July 2009
Senior Member
Mikael Petterson wrote:
> Hi,
>
> I am trying to export my feature. The problem I have is I added a test
> package and when I export I cannot build since the test libraries (
> junit and jmock) are not included or the test dir is in the build. When
> I compile the project in Eclipse it is fine.
> I suppose that I have to do something in my plugin.xml? Do I filter out
> the test directory or do I have to add the libs somewhere to get this
> working?
> I am using Eclipse 3.4.0 on Windows.

How are you including Junit / Jmock? Are they plug-ins somewhere in your
target? Or are you including the library and listing it on your
Bundle-ClassPath?

Cheers,

~ Chris
Re: Export plugin build problem [message #590854 is a reply to message #43318] Sat, 31 January 2009 12:47 Go to previous message
Andreas Goetz is currently offline Andreas GoetzFriend
Messages: 110
Registered: July 2009
Senior Member
I've seen certain test folder excluded from copying in build.xml. This
should work as long as the junit plugin dependency is optional and the
excluded folders are not mentioned in the classpath (i.e. reside unser
../src instead of their own ./test).

Cheers,
Andi
Re: Export plugin build problem [message #590910 is a reply to message #43350] Mon, 02 February 2009 06:29 Go to previous message
Mikael Petterson is currently offline Mikael PettersonFriend
Messages: 157
Registered: July 2009
Senior Member
Hi,

I only need these for testing. The junit and jmock are added to the
classpath in my project. I have not added them anywhere else.

//mikael
Re: Export plugin build problem [message #591386 is a reply to message #43536] Wed, 04 February 2009 20:30 Go to previous message
Andreas Goetz is currently offline Andreas GoetzFriend
Messages: 110
Registered: July 2009
Senior Member
Did you see my comment? Seems to solve your issue?

On 02.02.2009 07:29, Mikael Petterson wrote:
> Hi,
>
> I only need these for testing. The junit and jmock are added to the
> classpath in my project. I have not added them anywhere else.
>
> //mikael
>
Previous Topic:PDE Build, P2 metadata: qualifiers for features missing..
Next Topic:How to create config.ini file to accept any eclipse plugins in my rcp
Goto Forum:
  


Current Time: Tue Jul 27 03:03:58 GMT 2021

Powered by FUDForum. Page generated in 0.02234 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top