Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse installer oomph hangs / not responding on first step
Eclipse installer oomph hangs / not responding on first step [message #1847917] Fri, 12 November 2021 14:26 Go to next message
Michael Hitz is currently offline Michael HitzFriend
Messages: 4
Registered: November 2021
Junior Member
Hello,
I have previously installed eclipse and have removed it in order to install the latest version. After downloading and starting the installer on first step the installer gets frozen / hangs / not responding (see attached screenshot). I cannot got further with installation and no log file seems to be available.
Every tip / hint is appreciated to surround that issue.
Thanks a lot in advance.
Best regards, Michael
Re: Eclipse installer oomph hangs / not responding on first step [message #1847921 is a reply to message #1847917] Fri, 12 November 2021 15:56 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33075
Registered: July 2009
Senior Member
That's a problem I've never seen reported before. You're in advanced mode in this picture.. That's not the mode it comes up in by default when you first download the installer. Is this a freshly downloaded installer? Did you use the menu to switch to advanced mode to get into this state? When you say you removed eclipse, what folder(s) did you remove?

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse installer oomph hangs / not responding on first step [message #1847923 is a reply to message #1847921] Fri, 12 November 2021 16:54 Go to previous messageGo to next message
Michael Hitz is currently offline Michael HitzFriend
Messages: 4
Registered: November 2021
Junior Member
Hello,
thanks for your fast response. I was fearing, that this hasn't been reported before, I haven't find anything about that.
When installing, as soon as I select "Eclipse IDE for Enterprise Java and Web Developers" in the next step the window is frozen and I cannot continue. Also the default installation path provides this issue (see attached screenshot). The downloaded installer is the latest one downloaded today. I had this issue also when the old version of Eclipse was installed / available before. I removed it in order to ensure the issue was not produced by an old installed version of Eclipse. I removed the installation directory, the .p2 directory. The installation has been done on Windows 10.
Thanks again so far for your support.
best regards, Michael

[Updated on: Fri, 12 November 2021 16:55]

Report message to a moderator

Re: Eclipse installer oomph hangs / not responding on first step [message #1847924 is a reply to message #1847923] Fri, 12 November 2021 16:59 Go to previous messageGo to next message
Michael Hitz is currently offline Michael HitzFriend
Messages: 4
Registered: November 2021
Junior Member
Hello,
To surround the issue I meanwhile downloaded the package and extracted it. I can normally start eclipse and it seems to work as expected. Is there any difference between using the installer and extracting the package with respect to the installation (except manually creation of desktop icon, etc.)? Are there some registry entries which may cause some issues?
Thanks a lot in advance.
best regards, Michael

[Updated on: Fri, 12 November 2021 17:10]

Report message to a moderator

Re: Eclipse installer oomph hangs / not responding on first step [message #1847926 is a reply to message #1847924] Fri, 12 November 2021 19:12 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33075
Registered: July 2009
Senior Member
Sorry, but the picture you show in the latest screen shot is in simple mode; the advance mode picture shown previously is not the one that will be next in the event sequence. The latest picture shows a blank "Java 11+ VM" entry and you won't be able to proceed unless there is a valid Java VM choice; Java 11 or higher. You say this too is frozen, but differently. You mention that "the default installation path provides the issue" but I don't know what you mean by that.

Note that there is also a ~/.eclipse folder that might point at deleted things.

If unzipping a package works, that's fine too.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse installer oomph hangs / not responding on first step [message #1847928 is a reply to message #1847926] Fri, 12 November 2021 23:10 Go to previous messageGo to next message
Michael Hitz is currently offline Michael HitzFriend
Messages: 4
Registered: November 2021
Junior Member
Hello,
thanks again for your response. I have tested the installation in 2 ways, which both leads to the frozen windows as shown in the screenshots. by default installation path I meant after the first installation window appears (as seen in my second screenshot on the left hand side) and then choose the installation package (in my case "Eclipse IDE for Enterprise Java and Web Developers") the following window gets immediately frozen (as seen in my second screenshot on the right hand side). I do not have the chance to select a Java VM as the window is already frozen right after it appears.
Secondly I tried not to select an installation package first, but got to advanced mode using the upper right menu bar on the first window, which offers among others the advanced mode. But in that case, as soon as this window appears it gets immediately frozen as well (as seen in my first screenshot).
Thanks again for your support.
Best regards, Michael
Re: Eclipse installer oomph hangs / not responding on first step [message #1847931 is a reply to message #1847928] Sat, 13 November 2021 05:33 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33075
Registered: July 2009
Senior Member
I've tried various ways to corrupt a user folder (deleting ~/.p2), bad paths in ~./org.eclipse.oomph.p2/*.info and also in ~/.org.eclipse.oomph.jreinfo/*, but none of those cause a hang.

If it's really deadlocked somehow, this approach could be used to get the stack traces for where it is stuck:

https://wiki.eclipse.org/How_to_report_a_deadlock#Getting_a_stack_trace_on_Windows


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse installer oomph hangs / not responding on first step [message #1858657 is a reply to message #1847931] Thu, 13 April 2023 18:20 Go to previous messageGo to next message
Moises Lejter is currently offline Moises LejterFriend
Messages: 1
Registered: April 2023
Junior Member
Did this ever get resolved? We've noticed that, if we have Semeru's JDK8 installed and in our PATH, then then Eclipse Installer hangs on its first dialog (where one could choose a JDK installation to use)
Re: Eclipse installer oomph hangs / not responding on first step [message #1858661 is a reply to message #1858657] Fri, 14 April 2023 05:54 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33075
Registered: July 2009
Senior Member
No, no one ever reported any details. Especially getting a stack trace would be helpful. I can't fix a problem I can't reproduce and for which there are no details beyond a screen capture... The installer does try to launch a Java process to determine version information in org.eclipse.oomph.jreinfo.InfoManager.testJRE(String) and if that hangs, I it could get stuck waiting. E.g., for me it runs this:
[C:\Program Files (x86)\Common Files\Oracle\Java\javapath\java.exe, -cp, D:\Users\merks\oomph-1.29\ws\.metadata\.plugins\org.eclipse.pde.core\.install_folders\1679049803708\..\..\..\..\..\..\git\org.eclipse.oomph\plugins\org.eclipse.oomph.extractor.lib\bin, org.eclipse.oomph.extractor.lib.JREValidator]
when I'm in debug mod and it want to test the system JRE, i.e., the one on the path.

Is it possible for you to determine if you can see such a process launched but not terminating?


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse installer oomph hangs / not responding on first step [message #1862682 is a reply to message #1858661] Wed, 20 December 2023 17:22 Go to previous messageGo to next message
Puneet Kumar is currently offline Puneet KumarFriend
Messages: 1
Registered: December 2023
Junior Member
I've been facing a similar issue. But instead of freezing, it gets launched and throws an error. "Not responding".
Please see attached screeshot.
Re: Eclipse installer oomph hangs / not responding on first step [message #1862720 is a reply to message #1862682] Fri, 22 December 2023 08:02 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 33075
Registered: July 2009
Senior Member
Your picture is not that of the installer. You can report problems for the IDE here:

https://github.com/eclipse-platform/eclipse.platform.ui

You'll need to provide more information:

https://wiki.eclipse.org/How_to_report_a_deadlock

Perhaps there is information in the Error Log view...


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Unable to load p2 metadata repository
Next Topic:Issue with downloading latest LTS from adoptium.net
Goto Forum:
  


Current Time: Sat Feb 24 11:06:11 GMT 2024

Powered by FUDForum. Page generated in 0.03567 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top