Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » Weaving EclipseLink entites
Weaving EclipseLink entites [message #1844443] Tue, 14 September 2021 08:13 Go to next message
Andrei Mura is currently offline Andrei MuraFriend
Messages: 2
Registered: September 2021
Junior Member
I want to deploy my OSGI bundle. It contains some entities. I use EclispeLink for JPA. How can I weave the entity classes? I think I would prefer a static weaving. Any tutorial on this topic?
Using EclipseLink 2.7.8.

Thanks,
Mura Andrei
Re: Weaving EclipseLink entites [message #1844451 is a reply to message #1844443] Tue, 14 September 2021 11:40 Go to previous messageGo to next message
Radek Felcman is currently offline Radek FelcmanFriend
Messages: 8
Registered: March 2021
Junior Member
Hello,

try following guide
https://wiki.eclipse.org/EclipseLink/UserGuide/JPA/Advanced_JPA_Development/Performance/Weaving/Static_Weaving

Radek Felcman
Re: Weaving EclipseLink entites [message #1844490 is a reply to message #1844451] Wed, 15 September 2021 07:00 Go to previous message
Andrei Mura is currently offline Andrei MuraFriend
Messages: 2
Registered: September 2021
Junior Member
Hi Radek,

It seems to me that it works. Thank you very much!

Andrei
Previous Topic:Metamodel class not found
Next Topic:JAXB throws Marshall Exception with message A descriptor with default root element was not found
Goto Forum:
  


Current Time: Mon May 16 22:38:51 GMT 2022

Powered by FUDForum. Page generated in 0.02174 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top