Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Titan » ANTLR version will be upgraded for Eclipse Titan Executor plugin
ANTLR version will be upgraded for Eclipse Titan Executor plugin [message #1841228] Fri, 07 May 2021 07:00 Go to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 37
Registered: September 2016
Member
Dear Community Members,

This topic aims mostly those of You who build and install the Eclipse Titan Executor plugin from the source code (https://gitlab.eclipse.org/eclipse/titan/titan.EclipsePlug-ins)

Those of You who install from prebuilt package will receive the new ANTLR Runtime version (4.7.1) bundled in the package as before.

The change in the code base is planned to be committed early next week, I will update this forum topic once the code change has taken place.

This is the step-by-step instruction set on how to update the ANTLR plugin manually in Eclipse:

From the Menu select "Help/Install New Software..."
Select "Eclipse Orbit Composite Site ..." in "Work with:"
Type "antlr" in "type filter text" field
(Press "Select all" button if needed)
Press "Next"
Select ANTLR 4.7.1 Runtime
Press "Finish"
Restart Eclipse


Regards,
Lenard Nagy


Re: ANTLR version will be upgraded for Eclipse Titan Executor plugin [message #1841350 is a reply to message #1841228] Wed, 12 May 2021 19:14 Go to previous message
Jeno Attila Balasko is currently offline Jeno Attila BalaskoFriend
Messages: 80
Registered: September 2013
Location: Budapest, Hungary
Member

Hi,

if you do not have such item as "Eclipse Orbit Composite Site ...", I would suggest
to copy "orbit R20200529191137 - http://download.eclipse.org/tools/orbit/downloads/drops/R20200529191137/repository" into the field "Work with..." and type "antlr" into the field "type filter text". Then continue as it is suggested by Lenard.

BR Jeno
Previous Topic:Variables used in several .cfg files
Next Topic:TCCIPsec handling functions
Goto Forum:
  


Current Time: Thu Jul 29 13:28:56 GMT 2021

Powered by FUDForum. Page generated in 0.02030 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top