Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » Ubuntu/Linux Drag and Drop problem in Window Builder(Components are positioned outside the Window and not added the Content Pane)
Ubuntu/Linux Drag and Drop problem in Window Builder [message #1836465] Mon, 04 January 2021 21:18
Horst Torpedo is currently offline Horst TorpedoFriend
Messages: 1
Registered: January 2021
Location: Stuttgart
Junior Member
Hello,

I have tested Eclipse IDE for Java Developers
Version: 2020-12 (4.18.0)
Build id: 20201210-1552
with Window Builder in Windows and Ubuntu. Windows is working fine. Same versions of Eclipse and Window Builder in Ubuntu cause troubles when dragging components to the window.

1. It is not possible to apply a Layout to the window via drag and drop.
instead it is necessary to drag the layout to structure>components>getContentPane( ) entry

2. Next there is a weird behavior when draging components (e.g. labels) to the window.
they seem to land outside the window.
the source code adds a comment: * @wbp.nonvisual location=-39,-33
and there is no getContentPane( ).add( xxx )

index.php/fa/39666/0/
index.php/fa/39667/0/
index.php/fa/39668/0/
index.php/fa/39669/0/
Previous Topic:Window Builder Window wont work
Next Topic:Window Builder. HELP ME!
Goto Forum:
  


Current Time: Sat Nov 26 22:59:40 GMT 2022

Powered by FUDForum. Page generated in 0.02618 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top