Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Lua Development Tools » Trouble with installation of Lua stable in latest Eclipse
Trouble with installation of Lua stable in latest Eclipse [message #1836420] Sun, 03 January 2021 07:20 Go to next message
Steve Kelem is currently offline Steve KelemFriend
Messages: 11
Registered: July 2009
Junior Member
I used the repository http://download.eclipse.org/ldt/releases/stable.
When I selected the available item, I get the following messages. Any idea on how to install Lua?

Cannot complete the install because one or more required items could not be found.
  Software being installed: Lua Development Tools - Remote Development Support SDK 1.4.2.201804031433 (org.eclipse.ldt.remote.source.feature.group 1.4.2.201804031433)
  Missing requirement: Lua Development Tools Core 1.3.0.201804031433 (org.eclipse.ldt 1.3.0.201804031433) requires 'osgi.bundle; org.eclipse.dltk.core [5.5.0,6.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Lua Development Tools - Core Feature 1.4.2.201804031433 (org.eclipse.ldt.core.feature.group 1.4.2.201804031433)
    To: org.eclipse.equinox.p2.iu; org.eclipse.ldt [1.3.0.201804031433,1.3.0.201804031433]
  Cannot satisfy dependency:
    From: Lua Development Tools 1.4.2.201804031433 (org.eclipse.ldt.feature.group 1.4.2.201804031433)
    To: org.eclipse.equinox.p2.iu; org.eclipse.ldt.core.feature.group [1.4.2.201804031433,1.4.2.201804031433]
  Cannot satisfy dependency:
    From: Lua Development Tools - Remote Development Support 1.4.2.201804031433 (org.eclipse.ldt.remote.feature.group 1.4.2.201804031433)
    To: org.eclipse.equinox.p2.iu; org.eclipse.ldt.feature.group 0.9.0
  Cannot satisfy dependency:
    From: Lua Development Tools - Remote Development Support SDK 1.4.2.201804031433 (org.eclipse.ldt.remote.source.feature.group 1.4.2.201804031433)
    To: org.eclipse.equinox.p2.iu; org.eclipse.ldt.remote.feature.group [1.4.2.201804031433,1.4.2.201804031433]
Re: Trouble with installation of Lua stable in latest Eclipse [message #1836431 is a reply to message #1836420] Sun, 03 January 2021 23:35 Go to previous message
Steve Kelem is currently offline Steve KelemFriend
Messages: 11
Registered: July 2009
Junior Member
I tried installing and updating my Eclipse software:
Eclipse SDK
Application Development Framework
Programming Languages (Fails Graph Visualization)
General Purpose Tools
Collaboration
Testing (Jubula)
Database Development
Web, XML, Java EE and OSGi Enterprise Development

-- got tired of trying, one-by-one
EclipseRT Target Platform Components
Performance, Profiling and Tracing Tools
Web, XML, Java EE and OSGi Enterprise Development
Eclipse Project Updates 4.18
Eclipse SDK
Eclipse Tests, Tools, Examples, and Extras
Uncategorized
Modeling

At first, one package at a time, but then, because "obvious" packages were taking a long time and not making a difference, I continued, installing/updating groups of packages. In the end, none made a difference. Lua-stable won't install.
Previous Topic:Moose debugging thru dcs connects but fails on lua code
Next Topic:Cant start debugger
Goto Forum:
  


Current Time: Thu Oct 21 03:43:27 GMT 2021

Powered by FUDForum. Page generated in 0.02583 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top