Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » "Store in Secure Store"doesn't work
"Store in Secure Store"doesn't work [message #1836262] Sun, 27 December 2020 04:25 Go to next message
sinuo xue is currently offline sinuo xueFriend
Messages: 2
Registered: December 2020
Junior Member
when i clone git repository with https,
check "Store in Secure Store".
throw exception :
org.eclipse.equinox.security.storage.StorageException: No password provided.

then i delete "secure storage" at Preferences > General > Security > secure storage > Contents > Git,
it's useful.
but when i reboot the eclipse, exception still exist.

the bug exists in 2020-06 and higher version (MacOS x86_64).
  • Attachment: 1.jpg
    (Size: 75.54KB, Downloaded 44 times)
  • Attachment: 2.jpg
    (Size: 201.92KB, Downloaded 34 times)
  • Attachment: 3.jpg
    (Size: 208.07KB, Downloaded 30 times)
Re: "Store in Secure Store"doesn't work [message #1836291 is a reply to message #1836262] Mon, 28 December 2020 13:38 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 401
Registered: August 2016
Senior Member
"No password provided" means that the master password could not be retrieved from the OS X keystore, or if was retrieved, it could not be verified.

  1. Are there any related errors with stack traces in the log?
  2. Open the file ~/.eclipse/org.eclipse.equinox.security/secure_storage with a text editor. It should have, amongst others, lines like
    /GIT/https\:\\2f\\2f....com\:443/password=....
    /GIT/http\:\\2f\\2f...com\:80/password=...
    
    What is the clear-text part just after these "=" signs (until the first \t)?
  3. Is there a password stored in the keychain for service "eclipse.equinox.secure" and your user account on the Mac? (Use the keychain app to examine your keychain.)
  4. In file ~/.eclipse/org.eclipse.equinox.security/secure_storage, is there a line that starts with "/org.eclipse.equinox.secure.storage/verification/org.eclipse.equinox.security.osxkeystoreintegration="?

Re: "Store in Secure Store"doesn't work [message #1838159 is a reply to message #1836291] Wed, 17 February 2021 19:31 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1180
Registered: July 2009
Senior Member
maybe this helps ?
https://bugs.eclipse.org/bugs/show_bug.cgi?id=391455
Re: "Store in Secure Store"doesn't work [message #1838881 is a reply to message #1838159] Mon, 08 March 2021 01:40 Go to previous message
sinuo xue is currently offline sinuo xueFriend
Messages: 2
Registered: December 2020
Junior Member
Matthias Sohn wrote on Wed, 17 February 2021 19:31
maybe this helps ?
https://bugs.eclipse.org/bugs/show_bug.cgi?id=391455


thanks very much
Previous Topic:integrated git console for EGit
Next Topic:cloning a repo with git-lfs support generates NumberFormatException: For input string: "t"
Goto Forum:
  


Current Time: Mon Aug 02 09:12:41 GMT 2021

Powered by FUDForum. Page generated in 0.02050 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top