Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Error 7009 since Java 11(Test Execution Error after migrating AUT to Java 11.)
Error 7009 since Java 11 [message #1828661] Tue, 16 June 2020 07:20 Go to next message
Niklas Schloegel is currently offline Niklas SchloegelFriend
Messages: 3
Registered: June 2020
Junior Member
I used Jubula to test our Java 1.8 Swing/FX-Application before. Now, after switching to Java 11.0.2, tests from Jubula are not running. The AUT starts, gets recognized and is listed under 'Running AUTs', but after starting a Test Suite, I get the following error pop-up:

An error occurred. Reason: 7009: Test Execution Error.
Details: This connection is not connected.

One latest log entry (in rc_swing.log) is following, often repeating Exception:

2020-06-16 08:56:02.503 [Thread-18] ERROR o.e.j.r.s.c.AUTSwingHierarchy - Method called outside of the dispatch thread. This may indicate a potential error in the AUT.
java.lang.Exception: null
	at org.eclipse.jubula.rc.swing.components.AUTSwingHierarchy.checkDispatchThread(AUTSwingHierarchy.java:1031) ~[org.eclipse.jubula.rc.swing_7.0.2.201902270829.jar:na]
	at org.eclipse.jubula.rc.swing.components.AUTSwingHierarchy.componentAdded(AUTSwingHierarchy.java:426) ~[org.eclipse.jubula.rc.swing_7.0.2.201902270829.jar:na]
	at java.desktop/java.awt.AWTEventMulticaster.componentAdded(AWTEventMulticaster.java:208) ~[na:na]
	at java.desktop/java.awt.Container.processContainerEvent(Container.java:2289) ~[na:na]
	at java.desktop/java.awt.Container.processEvent(Container.java:2260) ~[na:na]
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:5008) ~[na:na]
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2321) ~[na:na]
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4840) ~[na:na]
	at java.desktop/java.awt.Container.addImpl(Container.java:1163) ~[na:na]
	at java.desktop/java.awt.Container.add(Container.java:436) ~[na:na]
	at heissmann.gui.MainFrame.initHauptmenue(MainFrame.java:1229) ~[Heissmann.Gui-3.0.jar:na]
	at heissmann.gui.MainFrame.access$100(MainFrame.java:95) ~[Heissmann.Gui-3.0.jar:na]
	at heissmann.gui.MainFrame$1$1.run(MainFrame.java:154) ~[Heissmann.Gui-3.0.jar:na]
	at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na]


The AUT is started through following batch script:
java --module-path "C:\Program Files\Java\javafx-sdk-11.0.2\lib" --add-modules=javafx.base,javafx.controls,javafx.fxml,javafx.graphics,javafx.media,javafx.swing,javafx.web,javafx.swt -Xmx1028M -Xms128M -jar DataTool.jar --add-opens=javafx.controls/javafx.scene.control.skin=ALL-UNNAMED --illegal-access=permit


Re: Error 7009 since Java 11 [message #1828913 is a reply to message #1828661] Mon, 22 June 2020 07:34 Go to previous messageGo to next message
Zeb Ford-Reitz is currently offline Zeb Ford-ReitzFriend
Messages: 33
Registered: November 2010
Member
I don't think that the error dialog is related to the log entries, and I am not sure what the reason for the error dialog is.

The log entries indicate that Swing methods are being called on a thread other than the EDT (https://en.wikipedia.org/wiki/Event_dispatching_thread) . This can cause threading issues, so Jubula warns about it in the log file. You can check the stack trace to see which method invocations (in this case, probably MainFrame.initHauptmenue) need to be executed on the EDT and move them there (https://en.wikipedia.org/wiki/Event_dispatching_thread#Requests_from_other_threads).

Unfortunately, solving the problem causing the log entries will probably not solve the problem with the error dialog on its own (although who knows, it might!), but it will make your application a bit more stable.

I'm not sure whether Jubula still writes separate logs for the AUT Agent, but that and the client log might be good places to look for the source of the error dialog if there's no further information in the RC log.
Re: Error 7009 since Java 11 [message #1829094 is a reply to message #1828913] Thu, 25 June 2020 06:57 Go to previous messageGo to next message
Niklas Schloegel is currently offline Niklas SchloegelFriend
Messages: 3
Registered: June 2020
Junior Member
I found another log entry in the client.log-File from that time:

2020-06-16 08:55:43.404 [Connection.ReaderThread:Socket[addr=/127.0.0.1,port=62575,localport=60001]] ERROR o.e.j.autagent.OsgiAUTStartHelper - No bundle found for ID 'com.thoughtworks.xstream'.
2020-06-16 08:55:43.404 [Connection.ReaderThread:Socket[addr=/127.0.0.1,port=62575,localport=60001]] ERROR o.e.j.autagent.OsgiAUTStartHelper - No bundle found for ID 'org.xmlpull'.
2020-06-16 08:55:52.508 [Connection.ReaderThread:Socket[addr=/127.0.0.1,port=62575,localport=60001]] ERROR o.e.j.c.internal.Communicator - caught exception from 'org.eclipse.jubula.autagent.common.commands.ConnectToAutCommand.execute()'
java.lang.NullPointerException: null
	at org.eclipse.jubula.autagent.common.agent.AutAgent.sendConnectToClientMessage(AutAgent.java:709) ~[na:na]
	at org.eclipse.jubula.autagent.common.commands.ConnectToAutCommand.execute(ConnectToAutCommand.java:46) ~[na:na]
	at org.eclipse.jubula.communication.internal.Communicator$ConnectionListener.received(Communicator.java:921) ~[org.eclipse.jubula.communication_4.0.0.201902270829.jar:na]
	at org.eclipse.jubula.communication.internal.connection.Connection.fireMessageReceived(Connection.java:402) [org.eclipse.jubula.communication_4.0.0.201902270829.jar:na]
	at org.eclipse.jubula.communication.internal.connection.Connection.access$2(Connection.java:391) [org.eclipse.jubula.communication_4.0.0.201902270829.jar:na]
	at org.eclipse.jubula.communication.internal.connection.Connection$ReaderThread.run(Connection.java:454) [org.eclipse.jubula.communication_4.0.0.201902270829.jar:na]
2020-06-16 08:56:02.559 [Awaiting command: class org.eclipse.jubula.client.internal.commands.ConnectToAutResponseCommand] WARN  o.e.j.c.i.c.ConnectToAutResponseCommand - org.eclipse.jubula.client.internal.commands.ConnectToAutResponseCommandtimeout() called
2020-06-16 08:56:12.647 [Worker-7: Start working with Test Suite: DataTaeglicherAbgleich_V2_Teil01] ERROR o.e.j.c.c.c.AUTConnection - Connection to AUT could not be established.
2020-06-16 08:56:12.801 [Worker-7: Start working with Test Suite: DataTaeglicherAbgleich_V2_Teil01] ERROR o.e.j.client.internal.BaseConnection - request() called to an unconnected connection
2020-06-16 08:56:12.802 [Worker-7: Start working with Test Suite: DataTaeglicherAbgleich_V2_Teil01] ERROR o.e.j.c.c.b.TestExecution - AUTConnection fails
org.eclipse.jubula.client.internal.BaseConnection$NotConnectedException: This connection is not connected
	at org.eclipse.jubula.client.internal.BaseConnection.request(BaseConnection.java:157) ~[org.eclipse.jubula.client.api_3.4.0.201902270829.jar:na]
	at org.eclipse.jubula.client.core.businessprocess.TestExecution.processCap(TestExecution.java:751) [org.eclipse.jubula.client.core_7.0.2.201902270829.jar:na]
	at org.eclipse.jubula.client.core.businessprocess.TestExecution.startTestSuite(TestExecution.java:655) [org.eclipse.jubula.client.core_7.0.2.201902270829.jar:na]
	at org.eclipse.jubula.client.core.businessprocess.TestExecution.executeTestSuite(TestExecution.java:372) [org.eclipse.jubula.client.core_7.0.2.201902270829.jar:na]
	at org.eclipse.jubula.client.core.ClientTestImpl$1.run(ClientTestImpl.java:581) [org.eclipse.jubula.client.core_7.0.2.201902270829.jar:na]
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63) [org.eclipse.core.jobs_3.10.100.v20180817-1215.jar:na]
2020-06-16 09:21:46.463 [Worker-7: Start working with Test Suite: DataTaeglicherAbgleich_V2_Teil01] ERROR o.e.j.client.internal.BaseConnection - request() called to an unconnected connection
2020-06-16 09:21:46.464 [Worker-7: Start working with Test Suite: DataTaeglicherAbgleich_V2_Teil01] WARN  o.e.j.c.c.b.TestExecution - This connection is not connected
org.eclipse.jubula.client.internal.BaseConnection$NotConnectedException: This connection is not connected
	at org.eclipse.jubula.client.internal.BaseConnection.request(BaseConnection.java:157) ~[org.eclipse.jubula.client.api_3.4.0.201902270829.jar:na]
	at org.eclipse.jubula.client.core.businessprocess.TestExecution.endTestExecution(TestExecution.java:1447) [org.eclipse.jubula.client.core_7.0.2.201902270829.jar:na]
	at org.eclipse.jubula.client.core.businessprocess.TestExecution.fireError(TestExecution.java:1348) [org.eclipse.jubula.client.core_7.0.2.201902270829.jar:na]
	at org.eclipse.jubula.client.core.businessprocess.TestExecution.processCap(TestExecution.java:761) [org.eclipse.jubula.client.core_7.0.2.201902270829.jar:na]
	at org.eclipse.jubula.client.core.businessprocess.TestExecution.startTestSuite(TestExecution.java:655) [org.eclipse.jubula.client.core_7.0.2.201902270829.jar:na]
	at org.eclipse.jubula.client.core.businessprocess.TestExecution.executeTestSuite(TestExecution.java:372) [org.eclipse.jubula.client.core_7.0.2.201902270829.jar:na]
	at org.eclipse.jubula.client.core.ClientTestImpl$1.run(ClientTestImpl.java:581) [org.eclipse.jubula.client.core_7.0.2.201902270829.jar:na]
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63) [org.eclipse.core.jobs_3.10.100.v20180817-1215.jar:na]


Maybe this is more helpful.
Re: Error 7009 since Java 11 [message #1829309 is a reply to message #1829094] Wed, 01 July 2020 09:38 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 241
Registered: March 2012
Senior Member
The Problem here is that somehow the connection to the AUT could not be made from Jubula. This can happen due to various reasons.

Is there a Firewall which may block the connections?

best regards
Marvin Mueller
Re: Error 7009 since Java 11 [message #1833265 is a reply to message #1829309] Thu, 08 October 2020 06:53 Go to previous messageGo to next message
Niklas Schloegel is currently offline Niklas SchloegelFriend
Messages: 3
Registered: June 2020
Junior Member
A firewall for domain network is up, yes.
The settings for Java are in the screenshot below:

https://i.imgur.com/GKtRXJk.jpg
Re: Error 7009 since Java 11 [message #1833395 is a reply to message #1833265] Mon, 12 October 2020 08:37 Go to previous message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 241
Registered: March 2012
Senior Member
I had this issue happening once. It was happening because the network loopback interface had a low metric in Windows.
I will have a look into the code, because it seems with java 11 the problem is getting worse.

best regards
Marvin Mueller
Previous Topic:Test for GEF 5.x graphics Element with Jubula
Next Topic:Need Jubula 8.7.1.046 for Unix
Goto Forum:
  


Current Time: Mon Aug 02 18:36:40 GMT 2021

Powered by FUDForum. Page generated in 0.02480 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top