Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Tycho build fails(p2 repository- not reachable)
Tycho build fails [message #1816963] Wed, 13 November 2019 06:51 Go to next message
Aruna Deshpande is currently offline Aruna DeshpandeFriend
Messages: 2
Registered: November 2019
Junior Member
Trying to automate the build process for my sample plugin project usinf maven tycho. Tried all known solutions, but no luck.

Set up details :
1. Using eclipse 2018-12 with PDE plugin installed for plugin development
2. Proxy settings are done
3. Maven(3.6.0) is installed
4. Converted my simple plugin to maven project. And pom looks like below,


Upon building getting below error,
Caused by:
    at (
    at (
    at (
    at org.apache.http.impl.conn.SystemDefaultDnsResolver.resolve (
    at org.apache.http.impl.conn.DefaultClientConnectionOperator.resolveHostname (
    at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection (
    at (
    at org.apache.http.impl.client.DefaultRequestDirector.tryConnect (
    at org.apache.http.impl.client.DefaultRequestDirector.execute (
    at org.apache.http.impl.client.AbstractHttpClient.doExecute (
    at org.apache.http.impl.client.CloseableHttpClient.execute (
    at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientFileSystemBrowser.runRequest (
    at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$ (
    at (

Not able to make out what is wrong here. All proxy settings are fine, still host is unknown. Seems like its very old issue and have been discussed plenty of times in this forum, but no solution mentioned in those posts worked for me. So re-posting the issue.

Re: Tycho build fails [message #1816994 is a reply to message #1816963] Wed, 13 November 2019 13:57 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 33137
Registered: July 2009
Senior Member
A failure to find a server's name sounds like a fundamental DNS configuration problem in the server machine on which you run your Tycho build. I doubt than can be fixed via anything configurable in the Maven/Tycho build itself. Does the shell script "ping" work on that machine?

Ed Merks
Professional Support:
Previous Topic:how to merge two rown in BIRT
Next Topic:Grey screen of death
Goto Forum:

Current Time: Fri Apr 19 06:06:23 GMT 2024

Powered by FUDForum. Page generated in 0.04474 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top