Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Eclipse SmartHome » NPE trying to set up ESH development envirionment
NPE trying to set up ESH development envirionment [message #1765062] Tue, 06 June 2017 10:20 Go to next message
Thomas Quarendon is currently offline Thomas QuarendonFriend
Messages: 4
Registered: January 2017
Junior Member
I'm trying to set up a development environment, following the instructions here

I have tried this a number of times and each time I end up with many many errors in my workspace. I have run through all the way to step 9.

I suspect the issue might be related to null pointer exceptions it gets early on:

!ENTRY 4 2 2017-06-06 10:41:41.494
!MESSAGE An internal error occurred during: "Install download1".
	at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(
	at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(
	at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(
	at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.getArtifact(
	at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transferSingle(
	at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transfer(
	at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.perform(
	at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(

I get this for "download0", "download1", "download2" and "download3".

There is then:
!MESSAGE The current target platform contains errors, open Window > Preferences > Plug-in Development > Target Platform for details.
org.eclipse.core.runtime.CoreException: Problems occurred while resolving the target contents
	at org.eclipse.pde.internal.core.PluginModelManager.getExternalBundles(
	at org.eclipse.pde.internal.core.PluginModelManager.initializeTable(
	at org.eclipse.pde.internal.core.PluginModelManager.targetReloaded(
	at org.eclipse.oomph.util.pde.TargetPlatformUtil.activateTargetDefinition(
	at org.eclipse.oomph.setup.pde.impl.TargetPlatformTaskImpl.perform(
	at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(
	at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(
	at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$
	at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(
	at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(
	at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(
	at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(
	at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(
	at org.eclipse.oomph.setup.ui.wizards.ProgressPage$
	at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$

which I suspect is a knock on error. I get the same errors if I try and look at the target definition within the "targetplatform" project and try and reload that. IN the "Target Definition" editor I get a bunch of errors "Problems occurred while resolving the target contents", see the attached image. I', assuming that they are the result of the "install download" errors.

If I press on anyway I just get thousands of errors in my workspace. These don't go away if I do "Help->Perform Setup Tasks", and then clean the relevant projects, or "clean all" (the instructions say clean each project that has errors, but for me that's all of them).

I'm using Eclipse Neon, on Windows 10, it if makes a difference.

Any suggestions?
  • Attachment: Capture.PNG
    (Size: 65.24KB, Downloaded 177 times)
Re: NPE trying to set up ESH development envirionment [message #1765098 is a reply to message #1765062] Tue, 06 June 2017 14:31 Go to previous message
Thomas Quarendon is currently offline Thomas QuarendonFriend
Messages: 4
Registered: January 2017
Junior Member
Interestingly, I tried again this afternoon, and the NullPointerExceptions have gone. My surmise is that something was offline this morning that it was trying to download from.

However, I still get a bunch of errors.
I reran "Help->Perform Setup Tasks", and then selected the projects with red crosses and cleaned just those. Less errors than last time, but still errors.

Looking into a few of the errors, some code generation clearly hasn't been performed. The "org.eclipse.smarthome.model.thing" project for example has an error "Missing required source folder 'src-gen'" that is stopping it being built.

I've tried rerunning "Help->Perform Setup Tasks" *again* on the off chance it works. Hmm, this time it seems to have done. That's odd.
I now have no red crosses!

No idea why it required me to do the same thing about 4 times to make it work, but it seems to have done.

Previous Topic:Openhab-cloud connecter for ESH
Next Topic:Eclipse Smart Home and org.slf4j
Goto Forum:

Current Time: Fri Jun 21 01:02:44 GMT 2024

Powered by FUDForum. Page generated in 0.03559 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top