Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » First xtext project (First xtext project throws error can't find org.eclipse.ui.ide)
First xtext project [message #1739834] Thu, 04 August 2016 20:23 Go to next message
Geoffry Roberts is currently offline Geoffry RobertsFriend
Messages: 52
Registered: July 2016
Member
Its my first xtext project and I am simply running the "15 Minutes Tutorial". When I get to the section: "Run the Generated Eclipse Plug-in" I get an error saying "Could not resolve module: org.eclipse.ui.ide". Of course, the module is present in my
$HOME/.p2/pool/plugins directory 


I'm running eclipse neon and xtext appears to be v2.10.0.

What's going on?

Thanks

For good measure, Here's the full text of the error:

!SESSION 2016-08-04 16:05:05.345 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_65
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments:  -product org.eclipse.platform.ide
Command-line arguments:  -product org.eclipse.platform.ide -data /Users/gcr1/hopeWorkspace/../ws-cdo.client.example -dev file:/Users/gcr1/hopeWorkspace/.metadata/.plugins/org.eclipse.pde.core/ExampleClient/dev.properties -debug /Users/gcr1/hopeWorkspace/.metadata/.plugins/org.eclipse.pde.core/ExampleClient/.options -os macosx -ws cocoa -arch x86_64 -console

!ENTRY org.eclipse.ui.ide 4 0 2016-08-04 16:05:05.776
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.ide [2]
  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
       org.eclipse.ui [21]
         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
              org.eclipse.ui.workbench [12]
                Unresolved requirement: Import-Package: org.eclipse.e4.core.commands.internal
                  -> Export-Package: org.eclipse.e4.core.commands.internal; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,org.eclipse.ui.workbench"
                     org.eclipse.e4.core.commands [39]
                       Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts
                         -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts"; bundle-version="1.5.0.v20160504-0909"; version="0.0.0"
                            org.eclipse.e4.core.contexts [80]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                                   org.eclipse.e4.core.di [127]
                                     Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.annotations; bundle-version="[1.4.0,2.0.0)"; visibility:="reexport"
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="0.9.0"
                         -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                       Unresolved requirement: Import-Package: org.eclipse.e4.core.services.log
                         -> Export-Package: org.eclipse.e4.core.services.log; bundle-symbolic-name="org.eclipse.e4.core.services"; bundle-version="2.0.100.v20160509-1032"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.services,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.ui.workbench"
                            org.eclipse.e4.core.services [63]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                Unresolved requirement: Import-Package: org.eclipse.e4.core.commands
                  -> Export-Package: org.eclipse.e4.core.commands; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.ui.workbench,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.e4.ui.progress,  org.eclipse.e4.core.commands.tests"
  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.emf.cdo.ui 4 0 2016-08-04 16:05:05.780
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.cdo.ui [7]
  Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.edit; bundle-version="[1.5.0,2.0.0)"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.edit.swt; bundle-version="[1.5.0,2.0.0)"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.ui.view.swt; bundle-version="[1.5.0,2.0.0)"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"
    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
       org.eclipse.ui [21]
         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
              org.eclipse.ui.workbench [12]
                Unresolved requirement: Import-Package: org.eclipse.e4.core.commands.internal
                  -> Export-Package: org.eclipse.e4.core.commands.internal; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,org.eclipse.ui.workbench"
                     org.eclipse.e4.core.commands [39]
                       Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts
                         -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts"; bundle-version="1.5.0.v20160504-0909"; version="0.0.0"
                            org.eclipse.e4.core.contexts [80]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                                   org.eclipse.e4.core.di [127]
                                     Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.annotations; bundle-version="[1.4.0,2.0.0)"; visibility:="reexport"
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="0.9.0"
                         -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                       Unresolved requirement: Import-Package: org.eclipse.e4.core.services.log
                         -> Export-Package: org.eclipse.e4.core.services.log; bundle-symbolic-name="org.eclipse.e4.core.services"; bundle-version="2.0.100.v20160509-1032"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.services,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.ui.workbench"
                            org.eclipse.e4.core.services [63]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                Unresolved requirement: Import-Package: org.eclipse.e4.core.commands
                  -> Export-Package: org.eclipse.e4.core.commands; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.ui.workbench,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.e4.ui.progress,  org.eclipse.e4.core.commands.tests"
  Unresolved requirement: Require-Bundle: org.eclipse.net4j.util.ui; bundle-version="[3.0.0,4.0.0)"; visibility:="reexport"
    -> Bundle-SymbolicName: org.eclipse.net4j.util.ui; bundle-version="3.6.0.qualifier"; singleton:="true"
       org.eclipse.net4j.util.ui [118]
         Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"; resolution:="optional"
           -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.8.100.v20160518-1929"; singleton:="true"
              org.eclipse.ui.views [14]
                Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui.shared; bundle-version="[4.0.0,5.0.0)"
           -> Bundle-SymbolicName: org.eclipse.net4j.ui.shared; bundle-version="4.3.100.qualifier"; singleton:="true"
              org.eclipse.net4j.ui.shared [119]
                Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.cdo.transfer.ui; bundle-version="[4.2.0,5.0.0)"; visibility:="reexport"
    -> Bundle-SymbolicName: org.eclipse.emf.cdo.transfer.ui; bundle-version="4.2.300.qualifier"; singleton:="true"
       org.eclipse.emf.cdo.transfer.ui [124]
         Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator; bundle-version="[3.5.0,4.0.0)"; resolution:="optional"
           -> Bundle-SymbolicName: org.eclipse.ui.navigator; bundle-version="3.6.100.v20160518-1929"; singleton:="true"
              org.eclipse.ui.navigator [47]
                Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.net4j.util.ui; bundle-version="[3.0.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.net4j.util.ui; bundle-version="3.6.0.qualifier"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.emf.cdo.ui.shared; bundle-version="[4.1.0,5.0.0)"
           -> Bundle-SymbolicName: org.eclipse.emf.cdo.ui.shared; bundle-version="4.3.0.qualifier"; singleton:="true"
              org.eclipse.emf.cdo.ui.shared [83]
                Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui.shared; bundle-version="[4.1.0,5.0.0)"
           -> Bundle-SymbolicName: org.eclipse.net4j.ui.shared; bundle-version="4.3.100.qualifier"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui.shared; bundle-version="[4.0.0,5.0.0)"
    -> Bundle-SymbolicName: org.eclipse.net4j.ui.shared; bundle-version="4.3.100.qualifier"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.5.0,4.0.0)"; resolution:="optional"
    -> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.10.0.v20160530-2011"; singleton:="true"
       org.eclipse.ui.workbench.texteditor [36]
         Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
           -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.cdo.ui.shared; bundle-version="[4.0.0,5.0.0)"
    -> Bundle-SymbolicName: org.eclipse.emf.cdo.ui.shared; bundle-version="4.3.0.qualifier"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.edit.ui; bundle-version="[2.5.0,3.0.0)"; visibility:="reexport"
    -> Bundle-SymbolicName: org.eclipse.emf.edit.ui; bundle-version="2.12.0.v20160526-0356"; singleton:="true"
       org.eclipse.emf.edit.ui [75]
         Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.4.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.8.100.v20160518-1929"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ui.workbench 4 0 2016-08-04 16:05:05.795
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.workbench [12]
  Unresolved requirement: Import-Package: org.eclipse.e4.core.commands.internal
    -> Export-Package: org.eclipse.e4.core.commands.internal; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,org.eclipse.ui.workbench"
       org.eclipse.e4.core.commands [39]
         Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts
           -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts"; bundle-version="1.5.0.v20160504-0909"; version="0.0.0"
              org.eclipse.e4.core.contexts [80]
                Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                  -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                     org.eclipse.e4.core.di [127]
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.annotations; bundle-version="[1.4.0,2.0.0)"; visibility:="reexport"
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="0.9.0"
           -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
         Unresolved requirement: Import-Package: org.eclipse.e4.core.services.log
           -> Export-Package: org.eclipse.e4.core.services.log; bundle-symbolic-name="org.eclipse.e4.core.services"; bundle-version="2.0.100.v20160509-1032"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.services,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.ui.workbench"
              org.eclipse.e4.core.services [63]
                Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                  -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
  Unresolved requirement: Import-Package: org.eclipse.e4.core.commands
    -> Export-Package: org.eclipse.e4.core.commands; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.ui.workbench,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.e4.ui.progress,  org.eclipse.e4.core.commands.tests"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ui 4 0 2016-08-04 16:05:05.797
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui [21]
  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
       org.eclipse.ui.workbench [12]
         Unresolved requirement: Import-Package: org.eclipse.e4.core.commands.internal
           -> Export-Package: org.eclipse.e4.core.commands.internal; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,org.eclipse.ui.workbench"
              org.eclipse.e4.core.commands [39]
                Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts
                  -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts"; bundle-version="1.5.0.v20160504-0909"; version="0.0.0"
                     org.eclipse.e4.core.contexts [80]
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                         -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                            org.eclipse.e4.core.di [127]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.annotations; bundle-version="[1.4.0,2.0.0)"; visibility:="reexport"
                Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="0.9.0"
                  -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                Unresolved requirement: Import-Package: org.eclipse.e4.core.services.log
                  -> Export-Package: org.eclipse.e4.core.services.log; bundle-symbolic-name="org.eclipse.e4.core.services"; bundle-version="2.0.100.v20160509-1032"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.services,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.ui.workbench"
                     org.eclipse.e4.core.services [63]
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                         -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
         Unresolved requirement: Import-Package: org.eclipse.e4.core.commands
           -> Export-Package: org.eclipse.e4.core.commands; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.ui.workbench,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.e4.ui.progress,  org.eclipse.e4.core.commands.tests"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ui.intro 4 0 2016-08-04 16:05:05.799
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.intro [22]
  Unresolved requirement: Import-Package: org.eclipse.e4.core.di.annotations

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.e4.ui.model.workbench 4 0 2016-08-04 16:05:05.801
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.model.workbench [24]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.core.contexts; bundle-version="1.0.0"
    -> Bundle-SymbolicName: org.eclipse.e4.core.contexts; bundle-version="1.5.0.v20160504-0909"
       org.eclipse.e4.core.contexts [80]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
           -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
              org.eclipse.e4.core.di [127]
                Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.annotations; bundle-version="[1.4.0,2.0.0)"; visibility:="reexport"
  Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
    -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.0.100.v20160509-1032"; singleton:="true"
       org.eclipse.e4.core.services [63]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.contexts
           -> Bundle-SymbolicName: org.eclipse.e4.core.contexts; bundle-version="1.5.0.v20160504-0909"
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
           -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.net4j.ui 4 0 2016-08-04 16:05:05.805
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.net4j.ui [30]
  Unresolved requirement: Require-Bundle: org.eclipse.net4j.util.ui; bundle-version="[3.0.0,4.0.0)"; visibility:="reexport"
    -> Bundle-SymbolicName: org.eclipse.net4j.util.ui; bundle-version="3.6.0.qualifier"; singleton:="true"
       org.eclipse.net4j.util.ui [118]
         Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"; resolution:="optional"
           -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.8.100.v20160518-1929"; singleton:="true"
              org.eclipse.ui.views [14]
                Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
                     org.eclipse.ui [21]
                       Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
                         -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
                            org.eclipse.ui.workbench [12]
                              Unresolved requirement: Import-Package: org.eclipse.e4.core.commands.internal
                                -> Export-Package: org.eclipse.e4.core.commands.internal; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,org.eclipse.ui.workbench"
                                   org.eclipse.e4.core.commands [39]
                                     Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts
                                       -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts"; bundle-version="1.5.0.v20160504-0909"; version="0.0.0"
                                          org.eclipse.e4.core.contexts [80]
                                            Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                              -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                                                 org.eclipse.e4.core.di [127]
                                                   Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.annotations; bundle-version="[1.4.0,2.0.0)"; visibility:="reexport"
                                     Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="0.9.0"
                                       -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                                     Unresolved requirement: Import-Package: org.eclipse.e4.core.services.log
                                       -> Export-Package: org.eclipse.e4.core.services.log; bundle-symbolic-name="org.eclipse.e4.core.services"; bundle-version="2.0.100.v20160509-1032"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.services,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.ui.workbench"
                                          org.eclipse.e4.core.services [63]
                                            Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                              -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                              Unresolved requirement: Import-Package: org.eclipse.e4.core.commands
                                -> Export-Package: org.eclipse.e4.core.commands; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.ui.workbench,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.e4.ui.progress,  org.eclipse.e4.core.commands.tests"
         Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui.shared; bundle-version="[4.0.0,5.0.0)"
           -> Bundle-SymbolicName: org.eclipse.net4j.ui.shared; bundle-version="4.3.100.qualifier"; singleton:="true"
              org.eclipse.net4j.ui.shared [119]
                Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui.shared; bundle-version="[4.0.0,5.0.0)"
    -> Bundle-SymbolicName: org.eclipse.net4j.ui.shared; bundle-version="4.3.100.qualifier"; singleton:="true"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.emf.cdo.examples.client 4 0 2016-08-04 16:05:05.812
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.cdo.examples.client [32]
  Unresolved requirement: Require-Bundle: org.eclipse.emf.cdo.ui; bundle-version="[4.0.0,5.0.0)"
    -> Bundle-SymbolicName: org.eclipse.emf.cdo.ui; bundle-version="4.5.0.qualifier"; singleton:="true"
       org.eclipse.emf.cdo.ui [7]
         Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.edit; bundle-version="[1.5.0,2.0.0)"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.edit.swt; bundle-version="[1.5.0,2.0.0)"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.ui.view.swt; bundle-version="[1.5.0,2.0.0)"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
              org.eclipse.ui [21]
                Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
                  -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
                     org.eclipse.ui.workbench [12]
                       Unresolved requirement: Import-Package: org.eclipse.e4.core.commands.internal
                         -> Export-Package: org.eclipse.e4.core.commands.internal; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,org.eclipse.ui.workbench"
                            org.eclipse.e4.core.commands [39]
                              Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts
                                -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts"; bundle-version="1.5.0.v20160504-0909"; version="0.0.0"
                                   org.eclipse.e4.core.contexts [80]
                                     Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                       -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                                          org.eclipse.e4.core.di [127]
                                            Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.annotations; bundle-version="[1.4.0,2.0.0)"; visibility:="reexport"
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="0.9.0"
                                -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                              Unresolved requirement: Import-Package: org.eclipse.e4.core.services.log
                                -> Export-Package: org.eclipse.e4.core.services.log; bundle-symbolic-name="org.eclipse.e4.core.services"; bundle-version="2.0.100.v20160509-1032"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.services,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.ui.workbench"
                                   org.eclipse.e4.core.services [63]
                                     Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                       -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                       Unresolved requirement: Import-Package: org.eclipse.e4.core.commands
                         -> Export-Package: org.eclipse.e4.core.commands; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.ui.workbench,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.e4.ui.progress,  org.eclipse.e4.core.commands.tests"
         Unresolved requirement: Require-Bundle: org.eclipse.net4j.util.ui; bundle-version="[3.0.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.net4j.util.ui; bundle-version="3.6.0.qualifier"; singleton:="true"
              org.eclipse.net4j.util.ui [118]
                Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"; resolution:="optional"
                  -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.8.100.v20160518-1929"; singleton:="true"
                     org.eclipse.ui.views [14]
                       Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
                         -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui.shared; bundle-version="[4.0.0,5.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.net4j.ui.shared; bundle-version="4.3.100.qualifier"; singleton:="true"
                     org.eclipse.net4j.ui.shared [119]
                       Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
                         -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"
                  -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.emf.cdo.transfer.ui; bundle-version="[4.2.0,5.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.emf.cdo.transfer.ui; bundle-version="4.2.300.qualifier"; singleton:="true"
              org.eclipse.emf.cdo.transfer.ui [124]
                Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator; bundle-version="[3.5.0,4.0.0)"; resolution:="optional"
                  -> Bundle-SymbolicName: org.eclipse.ui.navigator; bundle-version="3.6.100.v20160518-1929"; singleton:="true"
                     org.eclipse.ui.navigator [47]
                       Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
                         -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.net4j.util.ui; bundle-version="[3.0.0,4.0.0)"; visibility:="reexport"
                  -> Bundle-SymbolicName: org.eclipse.net4j.util.ui; bundle-version="3.6.0.qualifier"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"
                  -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.emf.cdo.ui.shared; bundle-version="[4.1.0,5.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.emf.cdo.ui.shared; bundle-version="4.3.0.qualifier"; singleton:="true"
                     org.eclipse.emf.cdo.ui.shared [83]
                       Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
                         -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui.shared; bundle-version="[4.1.0,5.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.net4j.ui.shared; bundle-version="4.3.100.qualifier"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui.shared; bundle-version="[4.0.0,5.0.0)"
           -> Bundle-SymbolicName: org.eclipse.net4j.ui.shared; bundle-version="4.3.100.qualifier"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.5.0,4.0.0)"; resolution:="optional"
           -> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.10.0.v20160530-2011"; singleton:="true"
              org.eclipse.ui.workbench.texteditor [36]
                Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.emf.cdo.ui.shared; bundle-version="[4.0.0,5.0.0)"
           -> Bundle-SymbolicName: org.eclipse.emf.cdo.ui.shared; bundle-version="4.3.0.qualifier"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.emf.edit.ui; bundle-version="[2.5.0,3.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.emf.edit.ui; bundle-version="2.12.0.v20160526-0356"; singleton:="true"
              org.eclipse.emf.edit.ui [75]
                Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.4.0,4.0.0)"; visibility:="reexport"
                  -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.8.100.v20160518-1929"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.5.0,4.0.0)"; visibility:="reexport"
                  -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.net4j.util.ui; bundle-version="[3.0.0,4.0.0)"
    -> Bundle-SymbolicName: org.eclipse.net4j.util.ui; bundle-version="3.6.0.qualifier"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.cdo.ui.admin; bundle-version="[4.0.0,5.0.0)"
    -> Bundle-SymbolicName: org.eclipse.emf.cdo.ui.admin; bundle-version="4.1.300.qualifier"; singleton:="true"
       org.eclipse.emf.cdo.ui.admin [106]
         Unresolved requirement: Require-Bundle: org.eclipse.emf.cdo.ui.shared; bundle-version="[4.0.0,5.0.0)"
           -> Bundle-SymbolicName: org.eclipse.emf.cdo.ui.shared; bundle-version="4.3.0.qualifier"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui; bundle-version="[4.0.0,5.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.net4j.ui; bundle-version="4.2.300.qualifier"; singleton:="true"
              org.eclipse.net4j.ui [30]
                Unresolved requirement: Require-Bundle: org.eclipse.net4j.util.ui; bundle-version="[3.0.0,4.0.0)"; visibility:="reexport"
                  -> Bundle-SymbolicName: org.eclipse.net4j.util.ui; bundle-version="3.6.0.qualifier"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui.shared; bundle-version="[4.0.0,5.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.net4j.ui.shared; bundle-version="4.3.100.qualifier"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.emf.cdo.ui; bundle-version="[4.0.0,5.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.emf.cdo.ui; bundle-version="4.5.0.qualifier"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.net4j.ui.shared; bundle-version="[4.0.0,5.0.0)"
           -> Bundle-SymbolicName: org.eclipse.net4j.ui.shared; bundle-version="4.3.100.qualifier"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.ui.ide.application; bundle-version="[1.0.0,2.0.0)"
    -> Bundle-SymbolicName: org.eclipse.ui.ide.application; bundle-version="1.1.100.v20160518-1929"; singleton:="true"
       org.eclipse.ui.ide.application [42]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench
           -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench; bundle-version="1.4.0.v20160517-1624"; singleton:="true"
              org.eclipse.e4.ui.workbench [95]
                Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.model.workbench; bundle-version="1.2.0"
                  -> Bundle-SymbolicName: org.eclipse.e4.ui.model.workbench; bundle-version="1.2.0.v20160229-1459"; singleton:="true"
                     org.eclipse.e4.ui.model.workbench [24]
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
                         -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.0.100.v20160509-1032"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.services; bundle-version="0.9.0"
                  -> Bundle-SymbolicName: org.eclipse.e4.ui.services; bundle-version="1.2.100.v20160506-0759"; singleton:="true"
                     org.eclipse.e4.ui.services [107]
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
                         -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.0.100.v20160509-1032"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
                  -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.0.100.v20160509-1032"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
           -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator.resources; bundle-version="[3.4.0,4.0.0)"
           -> Bundle-SymbolicName: org.eclipse.ui.navigator.resources; bundle-version="3.5.100.v20160518-1929"; singleton:="true"
              org.eclipse.ui.navigator.resources [71]
                Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.6.0,4.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.12.0.v20160601-1609"; singleton:="true"
                     org.eclipse.ui.ide [2]
                       Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
                         -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
                       Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
                         -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.6.0,4.0.0)"
           -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.12.0.v20160601-1609"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.model.workbench
           -> Bundle-SymbolicName: org.eclipse.e4.ui.model.workbench; bundle-version="1.2.0.v20160229-1459"; singleton:="true"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ui.workbench.texteditor 4 0 2016-08-04 16:05:05.814
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.workbench.texteditor [36]
  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
       org.eclipse.ui [21]
         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
              org.eclipse.ui.workbench [12]
                Unresolved requirement: Import-Package: org.eclipse.e4.core.commands.internal
                  -> Export-Package: org.eclipse.e4.core.commands.internal; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,org.eclipse.ui.workbench"
                     org.eclipse.e4.core.commands [39]
                       Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts
                         -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts"; bundle-version="1.5.0.v20160504-0909"; version="0.0.0"
                            org.eclipse.e4.core.contexts [80]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                                   org.eclipse.e4.core.di [127]
                                     Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.annotations; bundle-version="[1.4.0,2.0.0)"; visibility:="reexport"
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="0.9.0"
                         -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                       Unresolved requirement: Import-Package: org.eclipse.e4.core.services.log
                         -> Export-Package: org.eclipse.e4.core.services.log; bundle-symbolic-name="org.eclipse.e4.core.services"; bundle-version="2.0.100.v20160509-1032"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.services,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.ui.workbench"
                            org.eclipse.e4.core.services [63]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                Unresolved requirement: Import-Package: org.eclipse.e4.core.commands
                  -> Export-Package: org.eclipse.e4.core.commands; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.ui.workbench,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.e4.ui.progress,  org.eclipse.e4.core.commands.tests"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ui.ide.application 4 0 2016-08-04 16:05:05.817
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.ide.application [42]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench
    -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench; bundle-version="1.4.0.v20160517-1624"; singleton:="true"
       org.eclipse.e4.ui.workbench [95]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.model.workbench; bundle-version="1.2.0"
           -> Bundle-SymbolicName: org.eclipse.e4.ui.model.workbench; bundle-version="1.2.0.v20160229-1459"; singleton:="true"
              org.eclipse.e4.ui.model.workbench [24]
                Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
                  -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.0.100.v20160509-1032"; singleton:="true"
                     org.eclipse.e4.core.services [63]
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                         -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                            org.eclipse.e4.core.di [127]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.annotations; bundle-version="[1.4.0,2.0.0)"; visibility:="reexport"
         Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.services; bundle-version="0.9.0"
           -> Bundle-SymbolicName: org.eclipse.e4.ui.services; bundle-version="1.2.100.v20160506-0759"; singleton:="true"
              org.eclipse.e4.ui.services [107]
                Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
                  -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.0.100.v20160509-1032"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
           -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.0.100.v20160509-1032"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
       org.eclipse.ui [21]
         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
              org.eclipse.ui.workbench [12]
                Unresolved requirement: Import-Package: org.eclipse.e4.core.commands.internal
                  -> Export-Package: org.eclipse.e4.core.commands.internal; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,org.eclipse.ui.workbench"
                     org.eclipse.e4.core.commands [39]
                       Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts
                         -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts"; bundle-version="1.5.0.v20160504-0909"; version="0.0.0"
                            org.eclipse.e4.core.contexts [80]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                                -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="0.9.0"
                         -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.0.v20160319-0612"
                       Unresolved requirement: Import-Package: org.eclipse.e4.core.services.log
                         -> Export-Package: org.eclipse.e4.core.services.log; bundle-symbolic-name="org.eclipse.e4.core.services"; bundle-version="2.0.100.v20160509-1032"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.services,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.ui.workbench"
                Unresolved requirement: Import-Package: org.eclipse.e4.core.commands
                  -> Export-Package: org.eclipse.e4.core.commands; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.11.100.v20160506-0804"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.ui.workbench,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.e4.ui.progress,  org.eclipse.e4.core.commands.tests"
  Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator.resources; bundle-version="[3.4.0,4.0.0)"
    -> Bundle-SymbolicName: org.eclipse.ui.navigator.resources; bundle-version="3.5.100.v20160518-1929"; singleton:="true"
       org.eclipse.ui.navigator.resources [71]
         Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.6.0,4.0.0)"
           -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.12.0.v20160601-1609"; singleton:="true"
              org.eclipse.ui.ide [2]
                Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.6.0,4.0.0)"
    -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.12.0.v20160601-1609"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.model.workbench
    -> Bundle-SymbolicName: org.eclipse.e4.ui.model.workbench; bundle-version="1.2.0.v20160229-1459"; singleton:="true"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.e4.ui.di 4 0 2016-08-04 16:05:05.818
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.di [43]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.core.d



Re: First xtext project [message #1739849 is a reply to message #1739834] Fri, 05 August 2016 04:08 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14665
Registered: July 2009
Senior Member
did you check your target platform in eclipse settings?

Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: First xtext project [message #1739892 is a reply to message #1739849] Fri, 05 August 2016 13:24 Go to previous messageGo to next message
Geoffry Roberts is currently offline Geoffry RobertsFriend
Messages: 52
Registered: July 2016
Member
I set my target platform and that cleared up the error I posted. I pointed the target to this .p2/pool/plugin directory. Now I am getting a CNFE: org.eclipse.core.runtime.adaptor.EclipseStarter. Apparently this plugin is not in the aforementioned directory.

I have run things as an eclipse application before, but its been a while. It would appear something(s) has changed. e.g. I never before set a target platform. The whole thing just worked. Also, I never before had to select from a list of clients. Now, I am seeing Buddy*, example*, etc. For running xtext, do these matter?
Re: First xtext project [message #1739893 is a reply to message #1739892] Fri, 05 August 2016 13:28 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14665
Registered: July 2009
Senior Member
Usually if you don't change anything it works out ogf the box

Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: First xtext project [message #1739896 is a reply to message #1739893] Fri, 05 August 2016 13:36 Go to previous messageGo to next message
Geoffry Roberts is currently offline Geoffry RobertsFriend
Messages: 52
Registered: July 2016
Member
That was the first thing I tried. I did nothing but follow the xtext tutorial. Could the tutorial be out of date? I was commenting how things have changed. In my new installation, there are no plugins in the installation. They now are all in this .p2 directory. I've been Googling and everything I find seems dated.
Re: First xtext project [message #1739897 is a reply to message #1739896] Fri, 05 August 2016 13:40 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14665
Registered: July 2009
Senior Member
Geoffry Roberts <forums-noreply@xxxxxxxx> wrote:
> That was the first thing I tried. I did nothing but follow the xtext
> tutorial. Could the tutorial be out of date? I was commenting how
> things have changed. In my new installation, there are no plugins in the
> installation. They now are all in this .p2 directory. I've been
> Googling and everything I find seems dated.
>

Did you try a fresh workspace or a fresh eclipse


Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:Using Xbase
Next Topic:Propagation of errors to Problems view
Goto Forum:
  


Current Time: Fri Apr 19 16:35:45 GMT 2024

Powered by FUDForum. Page generated in 0.02065 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top