Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » NoSuchMethodError _persistence_set(Ljava/lang/String;Ljava/lang/Object;)V (StaticWeaving)
NoSuchMethodError _persistence_set(Ljava/lang/String;Ljava/lang/Object;)V [message #1728660] Wed, 06 April 2016 10:51
Ludwig Moser is currently offline Ludwig MoserFriend
Messages: 476
Registered: July 2009
Senior Member
Using EclipseLink 2.6.1/2
Eclipse 4.5.1

I'm making progress for getting lazy loadin (weaving) working.
i worked out that all my libraries get woven (also the 3rd party)
so now all my classes (including the EMF classes, which i extend) got woven.

i still get an exception.
NoSuchMethodError _persistence_set(Ljava/lang/String;Ljava/lang/Object;)V

Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        at org.eclipse.persistence.internal.descriptors.MethodAttributeAccessor.setAttributeValueInObject(
        ... 148 more
Caused by: java.lang.NoSuchMethodError: lumo.core.biooffice.impl.NativeLanguageSupportImpl._persistence_checkFetched(Ljava/lang/String;)V
        at lumo.core.biooffice.impl.NativeLanguageSupportImpl._persistence_get_id(
        at lumo.core.biooffice.impl.NativeLanguageSupportImpl.setId(

the 'funny' part is that if i decompile this Class i get this code:
public Integer getId()
    return _persistence_get_id();

  public void setId(Integer newId)
    Integer oldId = _persistence_get_id();
    if (eNotificationRequired())
        new ENotificationImpl(this, 1, 3, oldId, 

public Integer _persistence_get_id()

the missing method can be found int the top level class (obviously java reflection does not search there...
ALL the super classes are woven. my Type Hierarchy is this:
NativeLanguageSupportImpl (mapped) [mine]
JavaBeanSupport (not mapped) [mine]
EObjectImpl [EMF]
BasicEObjectImpl [EMF]
BasicNotifierImpl [EMF]
Object [Java]

what am i doing wrong?
Previous Topic:Include/Weave 3rd party Jar (updated)
Next Topic:(eclipse helios,mandriva) Schema "dbo" cannot be resolved for table "t_address"
Goto Forum:

Current Time: Sun Apr 18 00:44:47 GMT 2021

Powered by FUDForum. Page generated in 0.02194 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top