Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » IdentityHashMap gets NPE when trying to put
IdentityHashMap gets NPE when trying to put [message #1720103] Thu, 14 January 2016 12:44 Go to next message
Shay Sofer is currently offline Shay SoferFriend
Messages: 1
Registered: January 2016
Junior Member
I'm using `EclipseLink 2.6.0-M3` apparently when trying to query and call getResult().

I get this exception that looks weird (EclipseLink code looks safe from NPE) and main suspect is the JDK:

**Caused by: java.lang.NullPointerException
at java.util.IdentityHashMap.put(IdentityHashMap.java:447)**
at org.eclipse.persistence.internal.sessions.UnitOfWorkChangeSet.addObjectChangeSet(UnitOfWorkChangeSet.java:160)
at org.eclipse.persistence.internal.sessions.UnitOfWorkChangeSet.mergeUnitOfWorkChangeSet(UnitOfWorkChangeSet.java:510)
at org.eclipse.persistence.internal.sessions.RepeatableWriteUnitOfWork.writeChanges(RepeatableWriteUnitOfWork.java:469)
at org.eclipse.persistence.internal.jpa.EntityManagerImpl.flush(EntityManagerImpl.java:874)
at org.eclipse.persistence.internal.jpa.QueryImpl.performPreQueryFlush(QueryImpl.java:963)
at org.eclipse.persistence.internal.jpa.QueryImpl.executeReadQuery(QueryImpl.java:207

)
at org.eclipse.persistence.internal.jpa.QueryImpl.getResultList(QueryImpl.java:461)

Using this Java version (IBM JDK) -
Java(TM) SE Runtime Environment (build pxi3270sr9fp20-20151106_01(SR9 FP20))

It happens rarely, so debug won't help here.

Thanks in advance.
Re: IdentityHashMap gets NPE when trying to put [message #1720209 is a reply to message #1720103] Fri, 15 January 2016 09:04 Go to previous message
Lukas JungmannFriend
Messages: 34
Registered: November 2013
Location: Prague, Czech Republic
Member
Hi,

looks like a bug similar to https://bugs.eclipse.org/bugs/show_bug.cgi?id=463350 but without a test which fails at least rarely it is hard to fix. Can you file a bug and attach full stack trace and your test there, please?

Thanks!

--lukas
Previous Topic:Cache Coordination: setting reuseJMSTopicPublisher to true when using ActiveMQ as the JMS provider
Next Topic:Overriding orm.xml with eclipselink-orm.xml?
Goto Forum:
  


Current Time: Thu Apr 15 16:20:00 GMT 2021

Powered by FUDForum. Page generated in 0.02208 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top