Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » XDEBUG still doesn't work(keeps pending though it seems that eclipse isn't able to make a connection with xdebug)
XDEBUG still doesn't work [message #1716724] Mon, 07 December 2015 18:19 Go to next message
Eran Lev is currently offline Eran LevFriend
Messages: 2
Registered: October 2015
Junior Member
Eclipse keeps getting stuck with xdebug. It waits to xdebug begin forever.
Here are the xdebug settings:

Directive Local Value Master Value
xdebug.auto_trace Off Off
xdebug.cli_color 0 0
xdebug.collect_assignments Off Off
xdebug.collect_includes On On
xdebug.collect_params 0 0
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.coverage_enable On On
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On On
xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.file_link_format no value no value
xdebug.idekey no value no value
xdebug.max_nesting_level 100 100
xdebug.overload_var_dump On On
xdebug.profiler_aggregate Off Off
xdebug.profiler_append Off Off
xdebug.profiler_enable Off Off
xdebug.profiler_enable_trigger Off Off
xdebug.profiler_output_dir /tmp /tmp
xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
xdebug.remote_autostart Off Off
xdebug.remote_connect_back Off Off
xdebug.remote_cookie_expire_time 3600 3600
xdebug.remote_enable On On
xdebug.remote_handler dbgp dbgp
xdebug.remote_log no value no value
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.scream Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_enable_trigger Off Off
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir /tmp /tmp
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth 3 3

Can someone help?
Re: XDEBUG still doesn't work [message #1718452 is a reply to message #1716724] Wed, 23 December 2015 22:49 Go to previous messageGo to next message
Doug Needham is currently offline Doug NeedhamFriend
Messages: 2
Registered: December 2015
Junior Member
Does it just sit there saying something like "Launching test2: (78%)" while the program seems to execute to completion?? Also, are you trying to debug as a web application or a CLI application?? You might also want to add a line like this to your php.ini:


and capture the results.

I just went through the process of installing Mars (4.5.1) and FF directly on a CentOS VM I have, when I realized that my Kepler install on the Win 7 host on which the VMs run had broken breakpoints. I have determined that in my case, that breakpoints are not being sent across in the case of the web application debugging, even though I can see the xdebug session setting features and communicating everything else. In testing with a little test PHP file (a version of what was found here), in a new project setup under the local server, I found that as a CLI application, the breakpoints are sent and I can debug fine. However, with a web application (which I need for the application on which I am working), no breakpoints. And this is even with my having reinstalled things which were working earlier on in the Kepler release and which have been unchanged since then (until at some point I pulled updates to look at Luna).

Re: XDEBUG still doesn't work [message #1718494 is a reply to message #1716724] Thu, 24 December 2015 19:42 Go to previous message
Doug Needham is currently offline Doug NeedhamFriend
Messages: 2
Registered: December 2015
Junior Member
Thought I had posted the reply last night, but for some reason it is not showing up.

First, what sort of application are you trying to debug, a PHP CLI app, or a PHP Web app. And what sort of behavior is it displaying, such as saying "Launching testapp: (78%)" and just sitting there, while the application seems to run as if you have no breakpoints? Also, knowing some information about your environment would help, such as eclipse version, OS, etc. And lastly, there is an additional directive which will help for xdebug. In your xdebug configuration in your php INI files, add a line such as the following:


Place it in a location where your web server or you can open it, make sure it exists and it writable, and give it a try. Also, double check and make sure your breakpoints are not disabled (indicated with a \ through them).

I am curious, as this may be the same exact behavior I have been dealing with. I have a CentOS 6 VM which is running PHP 5.3.3 for a huge legacy web app project on which I am a developer. I had a Kepler install on the Win7 machine on which the VM runs which worked, but at some point in the past, perhaps when I pulled updates in preparation for cloning and trying to update to Luna (with a cloned workspace as well), breakpoints stopped working. I recently went through the process of installing the 64-bit Mars.1 version of Eclipse for PHP developers on the VM, but breakpoints still do not work when I am dealing with a Web app, even with the break on first line set. (This is with even with a new workspace, new copy of the source added as a new project, etc.) The CLI app breakpoints work for test apps, such as the one talked about in the Eclipse documentation, but the moment I try to debug something, even something which had breakpoints work on the CLI app debugger, it is as if no breakpoints are set. This is backed up by the xdebug.log showing features being set, stream information being passed, etc, but no breakpoint_set messages or similar. And I have tried various path mappings, including those based on the fileuri in the init message of the debug stream. At present, the source, Eclipse and everything else reside on filesystems on the VM. But the nature of the legacy code still has us stuck on PHP 5.3.3 and xdebug 2.2.3, even after 3yrs of work, and while debugging with Eclipse is not frequently necessary, right now I really need it to work.

Previous Topic:install ftp in eclipse mars php
Next Topic:Open editors list
Goto Forum:

Current Time: Sat Mar 25 05:00:38 GMT 2023

Powered by FUDForum. Page generated in 0.63778 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top