Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Buckminster » chmod problem when building mac product
chmod problem when building mac product [message #1707316] Thu, 03 September 2015 16:32 Go to next message
Axel Guckelsberger is currently offline Axel GuckelsbergerFriend
Messages: 354
Registered: July 2009
Senior Member
Hi all,

I have trouble with a Jenkins job building an installer product for multiple
operating systems. Here is what happens during calling the "p2.director" ant

INFO:  [start$1.0.0#create.installer.product]
[ant] An error occurred while installing the items
[ant]  session context was:(profile=MyInstallerProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]my.installer.product.executable.cocoa.macosx.x86_64 1.1.0.qualifier, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.ChmodAction).
[ant]  The action chmod failed - file /var/lib/jenkins/.../workspace/buckminster.output/my.installer.build_1.0.0-eclipse.feature/ does not exist
[ant] A problem occured while invoking the director.
ERROR: org.eclipse.core.runtime.CoreException: /var/.../product.ant:30: A problem occured while invoking the director.
Caused by:
	at sun.reflect.GeneratedMethodAccessor8.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.lang.reflect.Method.invoke(
	at org.eclipse.ant.internal.core.ant.EclipseDefaultExecutor.executeTargets(
	at sun.reflect.GeneratedMethodAccessor51.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.lang.reflect.Method.invoke(
	... 25 more

Honestly I have no clue why this happens :-|

Using Buckminster headless 4.5 for Mars.

Indeed the MacOS/Setup file/folder does not exist in the workspace.
Interestingly this job worked without problems a few weeks ago. There was
not any relevant change though since then. The only thing that changed in
the repository was raising a few dependency versions (for Xtend).

Any idea how to approach this? Or should I leave out the Mac version
temporarily and just hope that things are going to work again somewhen in

Thanks for your advice.


[Updated on: Thu, 03 September 2015 16:41]

Report message to a moderator

Re: chmod problem when building mac product [message #1730135 is a reply to message #1707316] Thu, 21 April 2016 16:06 Go to previous message
Matthew Webber is currently offline Matthew WebberFriend
Messages: 15
Registered: September 2014
Junior Member
This appears to be a problem that was introduced with Eclipse/Buckminster 4.5. We always get the problem, but things worked in Eclipse/Buckminster 4.4.

There are a number of Bugzilla entries that appear to relate to this:
465602 p2 fails to resolve a target platform with Eclipse Mars artifacts on Mac OS X
474494 Wrong directory structure for MacOS executables created
483101 [macosx] Rcp product build fails with 4.5
468131 PDE headless build does not generate the Mac OS X package correctly

Bugzilla 474494 contains a patch to Buckminster to fix it, but it's not clear if it's the correct solution, and I suspect that the Buckminster devs might not have seen this. Bugzilla 468131 has a longer discussion of the problem.

I think we'll have to wait till Thomas or someone takes a look.

Previous Topic:Target platform not materializing
Next Topic:Can't install buckminster headless on macosx
Goto Forum:

Current Time: Wed Jun 12 15:30:08 GMT 2024

Powered by FUDForum. Page generated in 0.02955 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top